Highlighted

IE 11 - scripts or activeX

New Here ,
Mar 22, 2018

Copy link to clipboard

Copied

Dear All

I created a internal website for out team with muse. Sadly standard browser is internet explorer.

When I want to open the site i get this message: "internet explorer has restricted this webpage from running scripts or activeX controls"

Is there any possibility to solve that problem?

I already Implemented the following Metadata: <meta http-equiv="X-UA-Compatible" content="IE=11" />

But that didn't solve the problem.

Can anyone help?

And is it possible to choose the browser via code?

Thanks for helping.

KR Annika

Hey Annika,

It's a warning, not an error - it's Microsoft trying to protect your computer from local HTML files.

Your client should not see the message if the site is on a web server.

If they do, it tells that the server is a file server or a different configuration.

You may add the below note when hen distributing the site link so the viewer can disable the warning.

Go to Internet Options > Advanced Tab and scroll down to security.

Tick Allow Active Content to run in files on My Computer.

Hope this helps!

Regards,

Ankush

Views

502

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

IE 11 - scripts or activeX

New Here ,
Mar 22, 2018

Copy link to clipboard

Copied

Dear All

I created a internal website for out team with muse. Sadly standard browser is internet explorer.

When I want to open the site i get this message: "internet explorer has restricted this webpage from running scripts or activeX controls"

Is there any possibility to solve that problem?

I already Implemented the following Metadata: <meta http-equiv="X-UA-Compatible" content="IE=11" />

But that didn't solve the problem.

Can anyone help?

And is it possible to choose the browser via code?

Thanks for helping.

KR Annika

Hey Annika,

It's a warning, not an error - it's Microsoft trying to protect your computer from local HTML files.

Your client should not see the message if the site is on a web server.

If they do, it tells that the server is a file server or a different configuration.

You may add the below note when hen distributing the site link so the viewer can disable the warning.

Go to Internet Options > Advanced Tab and scroll down to security.

Tick Allow Active Content to run in files on My Computer.

Hope this helps!

Regards,

Ankush

Views

503

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 22, 2018 0
Mar 22, 2018

Copy link to clipboard

Copied

Hey Annika,

It's a warning, not an error - it's Microsoft trying to protect your computer from local HTML files.

Your client should not see the message if the site is on a web server.

If they do, it tells that the server is a file server or a different configuration.

You may add the below note when hen distributing the site link so the viewer can disable the warning.

Go to Internet Options > Advanced Tab and scroll down to security.

Tick Allow Active Content to run in files on My Computer.

Hope this helps!

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2018 0
pziecina LATEST
LEGEND ,
Mar 22, 2018

Copy link to clipboard

Copied

To add to the reply by Ankush.

It is o/k to use javascript in IE11 but on no account should you have anything that requires active-x. The reason for this is because by the end of 2020 Microsoft will remove the ability completely from IE11 to run active-x.

Along with any flash content.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2018 1