Highlighted

Latest update has broken reflow of page elements

Community Beginner ,
Aug 25, 2017

Copy link to clipboard

Copied

The latest update to Muse has completely screwed up my Adobe Muse site, which was working perfectly prior to the update.

The problem is as follows. My pages use text frames which are set to responsive width. Between multiple text frames are some rectangles with images/text on them, all grouped together. These are set not to resize, and are pinned to the middle, so they stay centred as the browser width decreases.

Until the latest update, when the main text boxes reduced in width, they would increase in height to fit all the text, and push the grouped rectangles and details down too, so the page reflowed correctly.

Now, with the latest update, the rectangles do not move vertically. They stay horizontally centred, but do not move down as the text reflows,so the text ends up overlapping them. If I unpin the rectangles from the horizontal middle, they do reflow, but then they do not centre properly.

EDIT: Here's a sample .muse file to show the issue. The green rectangle should get pushed down as the text reflows. It does in previous versions, but is broken in the latest update.

I got your sample file which I have fixed it. But for that you need to redesign your website. We have fixed this issue in pre-release build. Please join pre-release program and provide feedback if something still not working. Meanwhile attaching your sample fixed file.

Views

867

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Latest update has broken reflow of page elements

Community Beginner ,
Aug 25, 2017

Copy link to clipboard

Copied

The latest update to Muse has completely screwed up my Adobe Muse site, which was working perfectly prior to the update.

The problem is as follows. My pages use text frames which are set to responsive width. Between multiple text frames are some rectangles with images/text on them, all grouped together. These are set not to resize, and are pinned to the middle, so they stay centred as the browser width decreases.

Until the latest update, when the main text boxes reduced in width, they would increase in height to fit all the text, and push the grouped rectangles and details down too, so the page reflowed correctly.

Now, with the latest update, the rectangles do not move vertically. They stay horizontally centred, but do not move down as the text reflows,so the text ends up overlapping them. If I unpin the rectangles from the horizontal middle, they do reflow, but then they do not centre properly.

EDIT: Here's a sample .muse file to show the issue. The green rectangle should get pushed down as the text reflows. It does in previous versions, but is broken in the latest update.

I got your sample file which I have fixed it. But for that you need to redesign your website. We have fixed this issue in pre-release build. Please join pre-release program and provide feedback if something still not working. Meanwhile attaching your sample fixed file.

Views

868

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 25, 2017 0
Aug 25, 2017

Copy link to clipboard

Copied

Hey garywood84,

The problem is because you have pinned the rectangle in the middle.

The current version of  Muse has improved a lot with respect to placement of objects.

You just need to unpin and set it as responsive width and height.

Your issue will be resolved.

Let me know if this helps.

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2017 0
Community Beginner ,
Aug 25, 2017

Copy link to clipboard

Copied

Thanks, Ankush. However, I don't want responsive width and height on the green block. I just want it to always be centred, but to flow within the text.

To see what I'm trying to achieve, please have a look at SELA: Staff & Operations and note what happens to the grey blocks as you resize the window.

That page was published from Muse before the update, but the update breaks it, and I can't find any combination of settings that provides the same result.

Thanks,

Gary

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2017 0
Adobe Employee ,
Aug 26, 2017

Copy link to clipboard

Copied

It is the case of mixed pinning and in case of mixed pinning content was never pushing down and after responsive its more visible now. We are working on this feature problem and next release this will be sure addressed. Meanwhile I provided a workaround by adding rectangle inside the  state button and rectangle is centered pinning w.r.t to state button. Attach fixed workaround file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2017 0
Adobe Employee ,
Aug 26, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 26, 2017 0
Aug 28, 2017

Copy link to clipboard

Copied

Hey Gary,

Can you work with the file provided above by Amit?

Also to inform you that we have logged a bug for this case as well and will be set in our next update.

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2017 0
Community Beginner ,
Sep 04, 2017

Copy link to clipboard

Copied

Hi Amit & Ankush,

Thanks for your replies, and apologies for the delay in my response - I was away on holiday and offline last week.

I've downloaded the file that Amit posted, but it's not based on my original file and is for a totally different website. I'm not sure if it's the wrong link, or if you're suggesting I extract something from this file. Can you please check and clarify?

Many thanks,

Gary

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 04, 2017 0
Adobe Employee ,
Sep 05, 2017

Copy link to clipboard

Copied

Have requested Amit to have a look at this post. Stay tuned.


Thanks,Preran

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Community Beginner ,
Sep 10, 2017

Copy link to clipboard

Copied

Any update Preran​? I really need a fix for this, because I currently can't update my website which was working perfectly in the previous version of Muse!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 10, 2017 0
Community Beginner ,
Sep 11, 2017

Copy link to clipboard

Copied

Hi ankushr40215001,

Thanks for the reply above. I still haven't received a file from Preran, but I have been able to recreate his suggestion of using a State Button containing the items that I want to push down the page. This works, although it's a big hassle to have to go through my entire site to insert these buttons, especially since it worked fine without this workaround until the last update.

It seems that the problem is that since the update, pinning doesn't just pin objects along the horizontal, x, axis, but also pins them vertically, on the y axis.

I note with thanks that you have raised a bug report for this. Do you have any idea when an update including a fix for this is likely to be available? The last update is causing me significant problems because of this issue -- to the extent that I've had to roll back to the previous version, and avoid installing the update until I can be sure it's working correctly. It would be great if the fix can be issued soon.

Many thanks,

Gary

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 0
Adobe Community Professional ,
Sep 11, 2017

Copy link to clipboard

Copied

I encourage you to give it a try at the prerelease forum and test your site in the prerelease – best way to make them aware of existing bugs.

Best regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 0
Community Beginner ,
Sep 11, 2017

Copy link to clipboard

Copied

Thanks, fotoroeder​. I'd be happy to do that. Can you tell me where I can find the pre-release forum and download pre-release software, please?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 0
Adobe Community Professional ,
Sep 11, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 0
Adobe Community Professional ,
Sep 11, 2017

Copy link to clipboard

Copied

So your issue is only text reflow, did I get it right?

Bildschirmfoto 2017-09-11 um 16.26.48.png

Bildschirmfoto 2017-09-11 um 16.37.41.png

Checking your file in prerelease shows the same.

I am not sure, wether text reflow was responsive before or not? Did it work properly? In my experience it worked only for fixed width breakpoints.

At the moment I would step back to the version where this worked or try a different design approach with text boxes and pictures

without reflow action. Does this fit your needs? Could you provide a link from this earlier version?

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 1
Community Beginner ,
Sep 11, 2017

Copy link to clipboard

Copied

fotoroeder​,

Thanks for this. No, the issue is that other page elements don't reflow as text spaces expand.

Have a look at SELA: Staff & Operations​. That page was published from Muse before the update. Notice how the grey boxes that give the names and profile pictures of our team are pinned centre, but move down the page as the text above them reflows.

Compare that to the box in the Muse file I posted above, in the original post. If you open that file in latest Muse, you'll see that the green block, which has the same pinning options as the grey blocks in the SELA site, stays centred but is also locked in position vertically, so it doesn't get pushed down by the reflowing text.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 0
Community Beginner ,
Sep 11, 2017

Copy link to clipboard

Copied

PS: Changing my design is not an option. I can't rely on Muse if something that works in one version will break in the next. I'm all for adding new features and functionality, but you can't do that at the expense of breaking or removing existing functionality, or nobody can rely on the software.

EDIT: There's a post before this awaiting moderation, which contains more substantive details.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 0
Adobe Community Professional ,
Sep 11, 2017

Copy link to clipboard

Copied

I can see what you were talking about now.

Take a look at the prerelease forum I suggest.

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 1
Adobe Community Professional ,
Sep 11, 2017

Copy link to clipboard

Copied

Changing in your design would of course not help. And of course is not the best if even a solution.

Sorry

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 0
Community Beginner ,
Sep 11, 2017

Copy link to clipboard

Copied

Thanks, fotoroeder​. I will have a look at the pre-release, and hope for some more positive news from Adobe very soon.

Gary

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 0
Adobe Employee ,
Sep 11, 2017

Copy link to clipboard

Copied

I got your sample file which I have fixed it. But for that you need to redesign your website. We have fixed this issue in pre-release build. Please join pre-release program and provide feedback if something still not working. Meanwhile attaching your sample fixed file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 0
Adobe Employee ,
Sep 11, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 1
Adobe Employee ,
Sep 11, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2017 1
Community Beginner ,
Sep 12, 2017

Copy link to clipboard

Copied

Many thanks, amitcs06​. I have joined the pre-release programme and downloaded today's release, which does indeed fix my issue. Do you have any idea when the fixes captured in this update will be pushed out to release?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2017 0
amitcs06 LATEST
Adobe Employee ,
Sep 12, 2017

Copy link to clipboard

Copied

We are working towards its and hopefully will be able to pushed out release soon. Meanwhile we will keep updating pre-release program with our fixes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2017 1