Highlighted

Left property should be a pixel value! Troubles with Adobe Muse.

Explorer ,
Sep 05, 2017

Copy link to clipboard

Copied

Hey Adobe Muse Team.

I got some troubles after updating Adobe Muse to the latest version 2017.1. Whenever i try to publish my clients site Adobe Muse gets shut down and it says "left property should be a pixel value". Could you help me solving the problem because its really important for me to upload the site as soon as possible!

Thanks in advance!

Leo

Adobe Community Professional
Correct answer by fotoroeder | Adobe Community Professional

Using the scrubber on your A-Master shows this:

Bildschirmfoto 2017-09-06 um 04.31.21.png

Your landing page shows strange alignments and layers:

Bildschirmfoto 2017-09-06 um 04.33.58.png

There´s a rectangle at the top, quite empty, moved above any browser border (blue header guide lines).

Moving everything down, leads to:

Bildschirmfoto 2017-09-06 um 04.40.53.png

Watching the yet empty rectangle on top, setting it invisible finding another menu hidden by this rectangle.

Bildschirmfoto 2017-09-06 um 04.36.43.png

I am really not sure, what this "left property value pixel" is all about but …, if you help yourself with the guidelines on B-Master

and set the header guideline to 90 px, like your rectangle with opacity of 38% it gets better and I can preview this page in browser easily.

Bildschirmfoto 2017-09-06 um 04.54.01.png

Did you forget the hidden menu?

I think it should be possible to add all the menu stuff on your B-Master for landing page and of course also for all pages.

If you need further, additional alternative designs you could copy that master and add what ever you need and use this master for

the other pages that might need something else.

On of the other pages you also force your content to leave canvas which should not happen at all:

Bildschirmfoto 2017-09-06 um 05.02.12.png

Not to forget the submenu on certain breakpoint. It seems to be OK in Design Mode but browser shows it pushed outside (Safari 10.1.2)

Bildschirmfoto 2017-09-06 um 05.04.08.png

Finally I was able to publish to BC, I stopped it, because unnecessary – it works with no warning.

I recommend to organize your masters as desired for all breakpoints not only for smaller breakpoints like 960.

I recommend to set the anchors inside the canvas on its left border (browsers try to show every content and align it to the left edge, so on mobiles this can cause a tiny little white unexpected border).

I highly recommend to check the mobile breakpoints, beginning with your master pages.

Best Regards,

Uwe

Views

2.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Left property should be a pixel value! Troubles with Adobe Muse.

Explorer ,
Sep 05, 2017

Copy link to clipboard

Copied

Hey Adobe Muse Team.

I got some troubles after updating Adobe Muse to the latest version 2017.1. Whenever i try to publish my clients site Adobe Muse gets shut down and it says "left property should be a pixel value". Could you help me solving the problem because its really important for me to upload the site as soon as possible!

Thanks in advance!

Leo

Adobe Community Professional
Correct answer by fotoroeder | Adobe Community Professional

Using the scrubber on your A-Master shows this:

Bildschirmfoto 2017-09-06 um 04.31.21.png

Your landing page shows strange alignments and layers:

Bildschirmfoto 2017-09-06 um 04.33.58.png

There´s a rectangle at the top, quite empty, moved above any browser border (blue header guide lines).

Moving everything down, leads to:

Bildschirmfoto 2017-09-06 um 04.40.53.png

Watching the yet empty rectangle on top, setting it invisible finding another menu hidden by this rectangle.

Bildschirmfoto 2017-09-06 um 04.36.43.png

I am really not sure, what this "left property value pixel" is all about but …, if you help yourself with the guidelines on B-Master

and set the header guideline to 90 px, like your rectangle with opacity of 38% it gets better and I can preview this page in browser easily.

Bildschirmfoto 2017-09-06 um 04.54.01.png

Did you forget the hidden menu?

I think it should be possible to add all the menu stuff on your B-Master for landing page and of course also for all pages.

If you need further, additional alternative designs you could copy that master and add what ever you need and use this master for

the other pages that might need something else.

On of the other pages you also force your content to leave canvas which should not happen at all:

Bildschirmfoto 2017-09-06 um 05.02.12.png

Not to forget the submenu on certain breakpoint. It seems to be OK in Design Mode but browser shows it pushed outside (Safari 10.1.2)

Bildschirmfoto 2017-09-06 um 05.04.08.png

Finally I was able to publish to BC, I stopped it, because unnecessary – it works with no warning.

I recommend to organize your masters as desired for all breakpoints not only for smaller breakpoints like 960.

I recommend to set the anchors inside the canvas on its left border (browsers try to show every content and align it to the left edge, so on mobiles this can cause a tiny little white unexpected border).

I highly recommend to check the mobile breakpoints, beginning with your master pages.

Best Regards,

Uwe

Views

2.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 05, 2017 0
Adobe Employee ,
Sep 05, 2017

Copy link to clipboard

Copied

Hi Leo

Sorry for the troubles!

If you have the file saved in previous version then it would help, if not then also please upload the file and share the link to download.

I will check it out!

Thanks,

Sanjit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Explorer ,
Sep 05, 2017

Copy link to clipboard

Copied

Upload it where? To my FTP Host? And which link do you mean?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Adobe Employee ,
Sep 05, 2017

Copy link to clipboard

Copied

You can use Dropbox , or WeTransfer   . Upload and then share the link.

Thanks,

Sanjit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Explorer ,
Sep 05, 2017

Copy link to clipboard

Copied

The problem is that i even can't export the site as a html file. The same error appears. So i can't upload it on dropbox...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Adobe Employee ,
Sep 05, 2017

Copy link to clipboard

Copied

We would need only .muse file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Explorer ,
Sep 05, 2017

Copy link to clipboard

Copied

Ok. Here we go. (I combined your two posts - moderator)

Dropbox - Praxis Website.muse

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Adobe Community Professional ,
Sep 05, 2017

Copy link to clipboard

Copied

Using the scrubber on your A-Master shows this:

Bildschirmfoto 2017-09-06 um 04.31.21.png

Your landing page shows strange alignments and layers:

Bildschirmfoto 2017-09-06 um 04.33.58.png

There´s a rectangle at the top, quite empty, moved above any browser border (blue header guide lines).

Moving everything down, leads to:

Bildschirmfoto 2017-09-06 um 04.40.53.png

Watching the yet empty rectangle on top, setting it invisible finding another menu hidden by this rectangle.

Bildschirmfoto 2017-09-06 um 04.36.43.png

I am really not sure, what this "left property value pixel" is all about but …, if you help yourself with the guidelines on B-Master

and set the header guideline to 90 px, like your rectangle with opacity of 38% it gets better and I can preview this page in browser easily.

Bildschirmfoto 2017-09-06 um 04.54.01.png

Did you forget the hidden menu?

I think it should be possible to add all the menu stuff on your B-Master for landing page and of course also for all pages.

If you need further, additional alternative designs you could copy that master and add what ever you need and use this master for

the other pages that might need something else.

On of the other pages you also force your content to leave canvas which should not happen at all:

Bildschirmfoto 2017-09-06 um 05.02.12.png

Not to forget the submenu on certain breakpoint. It seems to be OK in Design Mode but browser shows it pushed outside (Safari 10.1.2)

Bildschirmfoto 2017-09-06 um 05.04.08.png

Finally I was able to publish to BC, I stopped it, because unnecessary – it works with no warning.

I recommend to organize your masters as desired for all breakpoints not only for smaller breakpoints like 960.

I recommend to set the anchors inside the canvas on its left border (browsers try to show every content and align it to the left edge, so on mobiles this can cause a tiny little white unexpected border).

I highly recommend to check the mobile breakpoints, beginning with your master pages.

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Explorer ,
Sep 06, 2017

Copy link to clipboard

Copied

Thanks so much for the useful tipps. Although a few points which you mentioned are part of an effect, that the fixed Menu appears only under the slideshow, you mentioned some very useful points for me to improve.

But i don't think that any of these things cause the pixel value problem. I'll keep on troubleshooting since the most important point is, to get the site updated again and i'm grateful for every further hint!

Leo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2017 0
Adobe Community Professional ,
Sep 06, 2017

Copy link to clipboard

Copied

But as soon as I fixed some issues, I was able to publish without warning. So one of these fixed issues must have caused the error, right?

Best Regards

und alles Gute

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2017 1
Explorer ,
Sep 20, 2017

Copy link to clipboard

Copied

So what if you don't have anything outside the canvas and your still getting this error message like I am? It's maddening. I've searched the site with a fine toothed comb. I was able to upload it without a problem before - all of the sudden it just started giving me this error message (Left property should be a pixel value) and crashing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 1
New Here ,
Sep 20, 2017

Copy link to clipboard

Copied

I am in the same boat. This is ridiculous. Basically Muse is currently useless.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 3
Adobe Community Professional ,
Sep 20, 2017

Copy link to clipboard

Copied

Hi Abigail Darrin​, are you able to publish to BC? Remember post No 3? We have to start again – show me/us just one page, that shows this error. There must be a solution. I was able to preview without error.

anthonym76113000​, please open a new thread, as this one is already marked as solved. Not too many people will have a look at it.

In this new thread show us a link or even better a .muse, by following these steps, please: Please Provide a .muse File to Help Us Fixing Your Issue!

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 0
Explorer ,
Sep 20, 2017

Copy link to clipboard

Copied

You're not really making a whole lot of sense. #3 is leom75663467 asking a question. And it's not one page that has that error. It's the whole site. I cannot attempt upload it without it crashing the program and saying that "Left property should be a pixel value" as the reason. Which makes no sense what-so-ever. I went through the whole site with a fine toothed comb to make sure nothing was off a canvas, scrubbing the breakpoints, checking external HTML for errors. There's nothing! All of this started when I ran the most recent update. It's obviously a bug - what I want to know is has anyone come up with a work around OTHER than downloading a pre-released version? ? ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 0
Explorer ,
Sep 20, 2017

Copy link to clipboard

Copied

You said it buddy. I can't believe this is an Adobe product. They really need to get their act together.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 0
Adobe Community Professional ,
Sep 20, 2017

Copy link to clipboard

Copied

But why have I been able with your file to publish it without warning?

I cannot force it, I can only make an offer and ask for a site, in your case show me the site and I try to inspect as much as possible.

I can also invite Sanjit_Das​, maybe as a staff member he has more possibilities to inspect?

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 0
Adobe Community Professional ,
Sep 20, 2017

Copy link to clipboard

Copied

Sanjit_Das​, Pavel Homeriki, Ussnorway, Günter Heißenbüttel could you try to explain the "left property should be a pixel value"?

Thanks in advance

If all the others out there who have issues with that, I recommend, to open a new thread. In my opinion every case has a different solution, it might be layout issues or whatsoever.

This thread is marked a s solved as leom75663467 ​didn´t respond any more so far. How is it working on your side?

The chance to get forum members and staff is better, if opened in a new thread.

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 0
Most Valuable Participant ,
Sep 20, 2017

Copy link to clipboard

Copied

fotoroeder  wrote

could you try to explain the "left property should be a pixel value"?

= bad code... the system expects to see a number like 1 or 55 so that it can place (whatever) object on the screen at that point... instead of a number it is getting something else like 'X=y+ 4 to the value of' and it doesn't understand

the most common cause is when people take 3rd party code designed to run on other systems like wordpress or asp and try to drop them into html... I'm not sure why it is happening in this case but that is what I would look for first then I would remove any 3rd party widgets (one at a time) and rebuild the site until I find the problem

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 4
Adobe Community Professional ,
Sep 20, 2017

Copy link to clipboard

Copied

Many Thanks Ussnorway​,

this is quite helpful. Let´s see, if users are able to accept this and make a step backwards.

Hi

diego fabiánr21376751​, Abigail Darrin​, anthonym76113000​, leom75663467​,

please contact "your" 3rdparty inventors about this.

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 0
Adobe Community Professional ,
Sep 05, 2017

Copy link to clipboard

Copied

Could you try to publish to BC as a provisional site?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 05, 2017 0
Explorer ,
Sep 20, 2017

Copy link to clipboard

Copied

Tengo el mismo problema adobe muse da error al abrir VISTA PREVIA DE PAGINA EN NAVEGADOR y también LA PREVISUALIZACIÓN DEL PROGRAMA error: Left property should be a pixel value

error muse 2.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2017 0
Explorer ,
Sep 21, 2017

Copy link to clipboard

Copied

Hi, I have solved all my problems by installing the version 2018.0.0 Prerelease, Thank you very much for your help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 21, 2017 0
Explorer ,
Oct 11, 2017

Copy link to clipboard

Copied

Where do you get "version 2018.0.0 Prerelease"? I have the same problem with Muse quitting and popping up "left property..." message. It's been a pure frustration and stress.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 11, 2017 0
Adobe Community Professional ,
Oct 11, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 11, 2017 0