magnetic auto anchor scroll not working on mobile devices for me...

New Here ,
Jan 20, 2018 Jan 20, 2018

Copy link to clipboard

Copied

Hello to all,

Other than being new to making websites, my problem is this; I'm beginning to put a website together that uses the Muse's "Fixed Width" and "Add Alternative Layout" (Desktop, Tablet and Phone) options... I wanted to employ the method of magnetic auto anchor scrolling to my creation for all three venues, again, Desktop, Tablet and Phone... I've tried three different widgets that offer the possibilities to accomplish this particular feature from the very nice vendors that offer them for free online.

They all work great on the desktop version, BUT, I don't seem to be able to accomplish the "magnetic auto scroll" on the phone version after uploading the designs... Meaning, I did the exact same thing on the phone design interface as I did on the desktop design interface... but no dice. (I haven't yet designed the tablet version).

My site is sciforms.com if anyone would be interested in giving it a look see... (but it should be noted that the design is nowhere near being done, so it will appear rather drab at this point... I had hoped to cover some of the technical aspects before digging in with some good content... but initial digging in the tech has me stuck in mud... Acckkk..!

Am I doing something wrong, or is it a glitch in the program..? The "preview" option doesn't reflect the magnetic auto scroll in a finished product, but the "preview page in browser" does (for both desktop and phone)...it shows that it works for both... But most importantly, after uploading via "publish" with FTP, and testing both on several desktops and mobile devices, only the desktop version shows the auto scroll effect. I've tested the initial design on an iPhone 6 with Safari and Firefox browsers and on a LG mobile running Android... neither worked, reflecting an auto scroll... I've also tried a different design that just had some rectangles, anchor points and 1 widget for accomplishing auto scroll, spread throughout one long page... but it had the same effect (or didn't as the case may be)... it still didn't work.

By process of elimination, it seems that it is stemming from the output code from Muse, which isn't to blame Adobe... I could very well be doing something wrong. I just dunno what... I hope I explained my problem clearly... Anyway, any help, theories or pointers will be greatly appreciated.

Kind regards, David.

Views

297

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

LEGEND , Jan 20, 2018 Jan 20, 2018
hi david,the point of an alt layout is for the host server to see a phone and give it the phone layout but that is not happening on your test site... this is a setting in the muse options and needs a host server that is setup correctyour autoscroll works ok on my windows phone because windows phones allow that... what you call "magnetic auto scroll" is a script to adjust speed 'of scroll' and most phones don't trust such scripts but they will still scroll if you set the links wellimo your design...

Likes

Translate

Translate
LEGEND ,
Jan 20, 2018 Jan 20, 2018

Copy link to clipboard

Copied

hi david,

the point of an alt layout is for the host server to see a phone and give it the phone layout but that is not happening on your test site... this is a setting in the muse options and needs a host server that is setup correct

your autoscroll works ok on my windows phone because windows phones allow that... what you call "magnetic auto scroll" is a script to adjust speed 'of scroll' and most phones don't trust such scripts but they will still scroll if you set the links well

phone.jpg

imo your design needs some work like the contact in fact points to links but as you say early days yet

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2018 Jan 20, 2018

Copy link to clipboard

Copied

LATEST

Ussnorway...

You are my hero... I would never have known, or thought to think of that, that in a million years... Thank you so much for your insight... Then I will look for the correct set up with my web hosting service and try and correct this issue on the host server side and then set the Muse options accordingly...

Yes indeed, embarrassed am I to have posted the link to the bare bones design that is in it's infancy, but your humble opinion humbles me more so to endeavor for much better in the coming weeks... I resisted using the term "noob" for myself, but I suppose... if the shoe fits...

Thank you again so much.

All my best, David.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines