Highlighted

Mobile break point scrolling left/right on 2 pages

Community Beginner ,
Dec 21, 2017

Copy link to clipboard

Copied

I just published a new site and on the mobile break point (751-fluid), the "solutions" page and the "contact" pages are scrolling to the right (if you swipe right->left).  I have tried to edit->select all to see if there was anything outside of the page width but cannot see anything.  I've been over the master page and the individual pages and cannot find anything.  Any help would be appreciated.

www.businesselectronics.com

TIA

Most Valuable Participant
Correct answer by Ussnorway | Most Valuable Participant

a lot of small layout mistakes and two big issues

the popup is fixed... phones don't like pin as a rule so this will cause issues

don't use lightbox for menu... it never works well

Screenshot (368).pngScreenshot (367).pngScreenshot (366).pngScreenshot (365).pngScreenshot (364).png

Views

227

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Mobile break point scrolling left/right on 2 pages

Community Beginner ,
Dec 21, 2017

Copy link to clipboard

Copied

I just published a new site and on the mobile break point (751-fluid), the "solutions" page and the "contact" pages are scrolling to the right (if you swipe right->left).  I have tried to edit->select all to see if there was anything outside of the page width but cannot see anything.  I've been over the master page and the individual pages and cannot find anything.  Any help would be appreciated.

www.businesselectronics.com

TIA

Most Valuable Participant
Correct answer by Ussnorway | Most Valuable Participant

a lot of small layout mistakes and two big issues

the popup is fixed... phones don't like pin as a rule so this will cause issues

don't use lightbox for menu... it never works well

Screenshot (368).pngScreenshot (367).pngScreenshot (366).pngScreenshot (365).pngScreenshot (364).png

Views

228

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 21, 2017 0
Most Valuable Participant ,
Dec 21, 2017

Copy link to clipboard

Copied

a lot of small layout mistakes and two big issues

the popup is fixed... phones don't like pin as a rule so this will cause issues

don't use lightbox for menu... it never works well

Screenshot (368).pngScreenshot (367).pngScreenshot (366).pngScreenshot (365).pngScreenshot (364).png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 21, 2017 1
Community Beginner ,
Dec 27, 2017

Copy link to clipboard

Copied

UssNorway​, for my future knowledge, what are the two big issues?  I removed all pinning on the solutions and contact page and still getting that right to left swipe??

Also, for the mobile menu, what would be better to use the accordion panel and place the vertical menu inside?

Thanks for your help

MS

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 27, 2017 0
Most Valuable Participant ,
Dec 27, 2017

Copy link to clipboard

Copied

mobile menu = a menu widget, don't add a lightbox or an accordion. you can have it inside a blank comp widget if you really must but with phone design the rule is "less is more"... on that note your site takes 35 seconds to fully load into my desktop browser and (to me) the repeating music is very off putting

its your site and the layout is visually appealing so perhaps other people will like the music too?

p.s, a fixed popup is a kind of pin. your code in the "leave a message" script will say {place X pixels in from the left border and Y pixels down from the top border}... I assume some of the other objects are also fixed but I need a copy of the .muse file to be sure

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 27, 2017 1
Community Beginner ,
Dec 28, 2017

Copy link to clipboard

Copied

Ussnorway

The video should only play once and not loop.  Either way, it is just a place holder for now until I can completely edit a "commercial" type video for the business.  I wonder why it takes so long to load on your desktop.  Here, after clearing history, cache, cookies, etc, it takes less than 2 seconds.

I removed the chat pop up for now to make sure I can get the site to act right.  I'm changing some other things while I'm at it as well.  I'll let you know how it turns out after I upload.

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 28, 2017 0
Most Valuable Participant ,
Dec 28, 2017

Copy link to clipboard

Copied

because your host server is not on the other side of the world and the cms gives you first pick

also looking at your code I think you have two different copies of the video across your breakpoints so (set to auto play) will make them load one after the other... that tends to be an autoloader error and could be caused by your host server

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 28, 2017 0