Muse and Shopify

Community Beginner ,
Nov 27, 2017 Nov 27, 2017

Copy link to clipboard

Copied

I am creating a page full of buy buttons from shopify. When I add new products the page will not load after I publish it. Debugger says that it failed to load this resource "jquery-private.js"

Occasionally when I hit refresh, I get this error "JavaScript exception: Error calling selector function: TypeError: $( '.breakpoint' ).registerBreakpoint is not a function. (In '$( '.breakpoint' ).registerBreakpoint()', '$( '.breakpoint' ).registerBreakpoint' is undefined)" If I dismiss this dialog prompt, then the page loads and is fine. Debugger no longer reports the missing .js file.

Most of the time the page just won't load and is blank.

Here is the page link: LegacyTest7

Is there any way to fix this, or a better way to make a responsive shopify collection of buy buttons?

Views

277

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Nov 28, 2017 Nov 28, 2017
Thanks for the suggestion Ussnorway. Posted on business catalyst, but it's still not working.Link: index It seems to have something to do with the total number of shopify buttons on one page. On test page 8 and 9 I reduced the number of products, and it works fine. Breaking up the products is not what we want to do, so I'll be looking for a different solution.

Likes

Translate

Translate
LEGEND ,
Nov 27, 2017 Nov 27, 2017

Copy link to clipboard

Copied

at my end it shows as a blank white box... this is tip a host error so my advice is to try hosting the site to Adobe bc and test it there

Screenshot (162).png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 28, 2017 Nov 28, 2017

Copy link to clipboard

Copied

LATEST

Thanks for the suggestion Ussnorway. Posted on business catalyst, but it's still not working.

Link: index

It seems to have something to do with the total number of shopify buttons on one page. On test page 8 and 9 I reduced the number of products, and it works fine. Breaking up the products is not what we want to do, so I'll be looking for a different solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines