Highlighted

Muse CC 2018: Some files on the server may be missing or incorrect

Participant ,
Nov 08, 2017

Copy link to clipboard

Copied

"Some files on the server may be missing or incorrect. Clear browser cache and try again. If the problem persists please contact web author."

This has been an ongoing problem through CC 2017 and still unresolved in CC 2018. The main problem is this statement shows up when other people access my sites.

When I try the workaround here: Some files on the server may be incorrect or missing

that instructs going to Library > Preferences > Adobe > Adobe Muse CC > 2018 and then Modify the <key>SuppressMissingFileError</key> value from <false/> to <true/> by opening the AppPrefs.xml file, the app Big Bang Tic-Tac-Toe opens??

Screen Shot 2017-11-08 at 11.23.47 AM.png

How can this issue be resolved??

wsyneswhirld​:  Your problem is that simple to solve: As you have evidently no application on your machine, which is dedicated to open „.xml“ files, right click onto the „AppPrefs.xml" file and choose „Open in TextEdit".

imachrischan2​ : First an explanation, why this alert exists:

  • It may appear, when there is a conflict between expected data and existing data. If this is the case, use Muse’s „Publish“ command instead of a third party FTP application. If necessary, choose the export option „All files“ instead of „Only Modified Files“ in the FTP Upload dialog
  • It may also appear, if your browser has cached data, which conflict with data newly uploaded to the server. Normally in this case it helps, to clear the browser cache.
  • Sometimes this alert occurs, if there is a conflict between the data newly uploaded to the server and a caching mechanism provided by the hosting server.

If you don’t get rid of this alert, when you have cleared your browser cache, and you are sure, that really no file is missing, you may edit the file "AppPrefs.xml“:

  • Close Muse (this is important).
  • Find the file „AppPrefs.xml“ on your machine.
  • On Windows go to "C:\Users\(username)\AppData\Roaming\Adobe\Adobe Muse CC Prerelease\2017.0"
  • On a Mac go to the Finder menu „Go/Go to Folder …“ and give in or better copy the following line and paste it into the „Go to Folder“ dialog.

~/Library/Preferences/Adobe/Adobe Muse CC/2018.0/appPrefs.xml

  • Important: Don’t forget the "~" at first place!
  • Important: The folder „2018.0“ is the correct one, if you are using Muse 2018.0. If you use 2017.1, choose the folder „2017.1" and so on.
  • Open “AppPrefs.xml" with a text editor and change

<key>SuppressMissingFileError</key><false/>

to

<key>SuppressMissingFileError</key><true/>

  • Save this file as pure text again.
  • Open Muse again. Muse will now read this new preference data and make sure in its output data, that the browser won’t show the „Missing Files“ alert again, until you revert your changes within „AppPref.xml"
  • Don’t forget to publish your site again.
  • To make sure, that no outdated data are residing in your browser’s cache, clear it a last time.

Now open your site. All should be ok now.

Views

6.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Muse CC 2018: Some files on the server may be missing or incorrect

Participant ,
Nov 08, 2017

Copy link to clipboard

Copied

"Some files on the server may be missing or incorrect. Clear browser cache and try again. If the problem persists please contact web author."

This has been an ongoing problem through CC 2017 and still unresolved in CC 2018. The main problem is this statement shows up when other people access my sites.

When I try the workaround here: Some files on the server may be incorrect or missing

that instructs going to Library > Preferences > Adobe > Adobe Muse CC > 2018 and then Modify the <key>SuppressMissingFileError</key> value from <false/> to <true/> by opening the AppPrefs.xml file, the app Big Bang Tic-Tac-Toe opens??

Screen Shot 2017-11-08 at 11.23.47 AM.png

How can this issue be resolved??

wsyneswhirld​:  Your problem is that simple to solve: As you have evidently no application on your machine, which is dedicated to open „.xml“ files, right click onto the „AppPrefs.xml" file and choose „Open in TextEdit".

imachrischan2​ : First an explanation, why this alert exists:

  • It may appear, when there is a conflict between expected data and existing data. If this is the case, use Muse’s „Publish“ command instead of a third party FTP application. If necessary, choose the export option „All files“ instead of „Only Modified Files“ in the FTP Upload dialog
  • It may also appear, if your browser has cached data, which conflict with data newly uploaded to the server. Normally in this case it helps, to clear the browser cache.
  • Sometimes this alert occurs, if there is a conflict between the data newly uploaded to the server and a caching mechanism provided by the hosting server.

If you don’t get rid of this alert, when you have cleared your browser cache, and you are sure, that really no file is missing, you may edit the file "AppPrefs.xml“:

  • Close Muse (this is important).
  • Find the file „AppPrefs.xml“ on your machine.
  • On Windows go to "C:\Users\(username)\AppData\Roaming\Adobe\Adobe Muse CC Prerelease\2017.0"
  • On a Mac go to the Finder menu „Go/Go to Folder …“ and give in or better copy the following line and paste it into the „Go to Folder“ dialog.

~/Library/Preferences/Adobe/Adobe Muse CC/2018.0/appPrefs.xml

  • Important: Don’t forget the "~" at first place!
  • Important: The folder „2018.0“ is the correct one, if you are using Muse 2018.0. If you use 2017.1, choose the folder „2017.1" and so on.
  • Open “AppPrefs.xml" with a text editor and change

<key>SuppressMissingFileError</key><false/>

to

<key>SuppressMissingFileError</key><true/>

  • Save this file as pure text again.
  • Open Muse again. Muse will now read this new preference data and make sure in its output data, that the browser won’t show the „Missing Files“ alert again, until you revert your changes within „AppPref.xml"
  • Don’t forget to publish your site again.
  • To make sure, that no outdated data are residing in your browser’s cache, clear it a last time.

Now open your site. All should be ok now.

Views

6.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 08, 2017 0
Adobe Community Professional ,
Nov 08, 2017

Copy link to clipboard

Copied

Yes. What´s your issue with that. This helps for sure. Did you do it? Have you been able to change it?

Browser: Einige Dateien auf dem Server sind möglicherweise falsch oder fehlen . . .

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 1
Participant ,
Nov 08, 2017

Copy link to clipboard

Copied

Thanks for the response. I downloaded the Tools Hide Message from WidgetForMuse and am stuck on the installations instruction:

Installation instructions:

After you download the file, look for "WidgetforMuse".zip in your Downloads folder. Double click on the .zip file to decompress it. You will now have a folder named after the widget.Now follow the steps below. OK

1. Launch Muse if it is not already running. OK

2. Click the Import Muse Library button in the bottom left corner of the Library panel. THIS IS WHERE I AM STUCK. I DO NOT SEE WHERE THE IMPORT MUSE LIBRARY BUTTON IS. IT SAYS “in the bottom left corner of the Library panel." WHERE IS THE LIBRARY PANEL in Muse? I see Widgets Library and CC Libraries but I don’t see the Import Muse Library button here.

3. In the Import Library Items dialog box that appears, browse to select the .mulib file in your Downloads folder, then click Open.

4. The imported Widget appears in the Library panel, ready for use in the current file. Drag/drop the widget to your project, set the options and enjoy!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 0
Adobe Community Professional ,
Nov 08, 2017

Copy link to clipboard

Copied

To change the AppPrefs is much more stable. Why did you you choose the workaround? It´s not a real solution.

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 0
Participant ,
Nov 08, 2017

Copy link to clipboard

Copied

Please view my original post to understand why I wasn't able to do that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 0
Adobe Community Professional ,
Nov 08, 2017

Copy link to clipboard

Copied

Where did you struggle? On which OS are you working?

If you are in "Finder" you choose "Go To" and you see this in your language:

Bildschirmfoto 2017-11-08 um 22.43.12.png

From here there are several possibilities. On my OS 12.10.6 Sierra, I have to click ALT and an additional folder – LIBRARY – appears.

In previous OS I had to clicl CMD to get this LIBRARY available.

From here you will have to follow the path as mentioned in your post.

Let me know, if that helps.

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 0
Participant ,
Nov 08, 2017

Copy link to clipboard

Copied

I'm Mac OS 10.13 High Sierra. Hold down Option in Finder>Go for Library. As in my original post above, Library > Preferences > Adobe > Adobe Muse CC > 2018 > AppPrefs.xml. Double click on that and the app Big Bang Tic-Tac-Toe opens (see screen shot in original post) The following code does not appear: <key>SuppressMissingFileError</key> value from <false/> to <true/>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 0
Adobe Community Professional ,
Nov 08, 2017

Copy link to clipboard

Copied

As far as I know, Günter Heißenbüttel​, do you also use High Sierra?

Maybe you could get into this?

Would be great.

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 1
Explorer ,
Nov 08, 2017

Copy link to clipboard

Copied

thanks for the word. I spoke to support and they told me to ask my host to clear server cache. Fatcow said they can't do this, leaving me with no way of fixing this, other than restoring the files back a few days.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 0
Explorer ,
Nov 08, 2017

Copy link to clipboard

Copied

I am getting my site restored back to the day before the High Sierra upgrade. Problem is, I won't be able to make changes...was trying to update our address info. Hope Adobe can make a bug fix for this soon.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 0
LEGEND ,
Nov 08, 2017

Copy link to clipboard

Copied

wsyneswhirld​:  Your problem is that simple to solve: As you have evidently no application on your machine, which is dedicated to open „.xml“ files, right click onto the „AppPrefs.xml" file and choose „Open in TextEdit".

imachrischan2​ : First an explanation, why this alert exists:

  • It may appear, when there is a conflict between expected data and existing data. If this is the case, use Muse’s „Publish“ command instead of a third party FTP application. If necessary, choose the export option „All files“ instead of „Only Modified Files“ in the FTP Upload dialog
  • It may also appear, if your browser has cached data, which conflict with data newly uploaded to the server. Normally in this case it helps, to clear the browser cache.
  • Sometimes this alert occurs, if there is a conflict between the data newly uploaded to the server and a caching mechanism provided by the hosting server.

If you don’t get rid of this alert, when you have cleared your browser cache, and you are sure, that really no file is missing, you may edit the file "AppPrefs.xml“:

  • Close Muse (this is important).
  • Find the file „AppPrefs.xml“ on your machine.
  • On Windows go to "C:\Users\(username)\AppData\Roaming\Adobe\Adobe Muse CC Prerelease\2017.0"
  • On a Mac go to the Finder menu „Go/Go to Folder …“ and give in or better copy the following line and paste it into the „Go to Folder“ dialog.

~/Library/Preferences/Adobe/Adobe Muse CC/2018.0/appPrefs.xml

  • Important: Don’t forget the "~" at first place!
  • Important: The folder „2018.0“ is the correct one, if you are using Muse 2018.0. If you use 2017.1, choose the folder „2017.1" and so on.
  • Open “AppPrefs.xml" with a text editor and change

<key>SuppressMissingFileError</key><false/>

to

<key>SuppressMissingFileError</key><true/>

  • Save this file as pure text again.
  • Open Muse again. Muse will now read this new preference data and make sure in its output data, that the browser won’t show the „Missing Files“ alert again, until you revert your changes within „AppPref.xml"
  • Don’t forget to publish your site again.
  • To make sure, that no outdated data are residing in your browser’s cache, clear it a last time.

Now open your site. All should be ok now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 3
Participant ,
Nov 08, 2017

Copy link to clipboard

Copied

This is very helpful. Opening AppPrefs.xml with TextEdit solved the issue of launching the Big Bang app when double clicked on. However, after I changed false to true, when I tried to save it, I got this:

Screen Shot 2017-11-08 at 5.32.21 PM.png

For now I Reverted. What should I do?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 0
Explorer ,
Nov 09, 2017

Copy link to clipboard

Copied

Thanks to Gunter and fotoroeder. Especially for the very specific and detailed instructions...it worked for me! It's difficult enough to keep people on our site but when they reach a message like that on every page, I assume they leave right away. Luckily, this persisted for only a couple of days. Shutting Muse down and creating a new file instead of editing the original seems to be key to the success.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2017 0
Participant ,
Oct 24, 2018

Copy link to clipboard

Copied

Thank you Günter!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2018 0
Explorer ,
Nov 08, 2017

Copy link to clipboard

Copied

I'm getting the error message "Some files on the server may be missing or incorrect. Clear browser cache and try again. If the problem persists please contact website author."  This is happening even if I upload the entire site again - I'm now running the 2018 version of Muse – problem only happened when I upgraded to this version of Muse…this appears to be an old problem with earlier versions for some people.Why s adobe make the same mistake again? NEED THIS FIXED.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 08, 2017 1
LEGEND ,
Nov 09, 2017

Copy link to clipboard

Copied

  1. First save the file, wherever you want.
  2. Delete the original AppPref.xml (you may keep a backup at a different place).
  3. Move the file, which you have saved in step 1, to the place, where the original file was.

Depending on your user state (admin or normal user), you may have to enter your name and password, when deleting/copying.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2017 2
Participant ,
Nov 09, 2017

Copy link to clipboard

Copied

Thank you Günter and fotoroeder. When I opened AppPref.xml in TextEdit, changed code to <true> andI tried to save it again, this time it just saved without the dialog window popping up. I launched Muse and opened the file and uploaded it. It still showed the "Some files on the server..." pop up. Then I uploaded it again, this time All Files, not Modified Files. The "Some files..." pop up was gone on any page. Hopefully this solves it!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2017 1
LEGEND ,
Nov 09, 2017

Copy link to clipboard

Copied

Fine, when it is working!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2017 1
Explorer ,
Nov 09, 2017

Copy link to clipboard

Copied

I believe this question is now answered!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2017 0
Participant ,
Dec 15, 2017

Copy link to clipboard

Copied

Hi Gunter,

Thanks for your detailed answer on eliminating the "files missing or incorrect" issue. I use a Mac and recently upgraded to High Sierra. I had also updated my Muse to the latest version a couple of weeks ago.

A few days ago I changed a video on one page of my site and uploaded only the modified pages. It actually uploaded everything instead of just the one modified page.

After that upload, I do not receive the error message. However, others that have visited my site previously do receive the message. We've had complaints from employees and customers in just two days.

I followed your directions to modify the .xml file, however, when opening Library > Preferences, I see that there is no Adobe file in Preferences. So, I searched the computer for a folder named "2018.0" and there is none. I also searched for "AppPref.xml" and there is none.

Any ideas on how I can fix this issue?

BTW - It also happened around a year ago when I updated to 2017. Then, the only way I could rectify the issue was to delete all files on our host server and re-upload the entire site. I see from others' comments that this doesn't seem to work for the 2018 version issue.

Anyone's help would be greatly appreciated!

Anita

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2017 0
LEGEND ,
Dec 15, 2017

Copy link to clipboard

Copied

Of course the file is there! Please read post 4 exactly! I m sure, you are searching in the wrong library folder. You are having at least three of them!

Please follow the instruction exactly, and you will find the correct folder. This method definitely works. Here you find a small screencast about this: https://forums.adobe.com/message/9702632#9702632

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2017 1
Participant ,
Dec 15, 2017

Copy link to clipboard

Copied

Hi again Günter,

Thanks for the video. You were correct, the Preferences folder was under my account and hidden.

I found the file and made the correction to the AppPref.xml file. I saved the file, then reopened Muse and uploaded all files to the server. However, now not only do others still get the "missing files" message, I now get it also.

Changing "false" to "true" did not fix the issue for me.

Any other ideas?

Anita

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2017 0
LEGEND ,
Dec 15, 2017

Copy link to clipboard

Copied

Could you give us the link to the site, so we can have a look as well?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 15, 2017 0
Participant ,
Dec 16, 2017

Copy link to clipboard

Copied

www.odulair.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2017 0
LEGEND ,
Dec 16, 2017

Copy link to clipboard

Copied

The site loads here without any „missing files“ alert.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2017 0
Participant ,
Dec 16, 2017

Copy link to clipboard

Copied

Thanks for checking, but then why do we have visitors coming in on live chat telling us about the alert?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2017 0
Participant ,
Dec 16, 2017

Copy link to clipboard

Copied

I had a couple more people check and they did not see the error any longer either. Thanks for your help Günter!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2017 0
Community Beginner ,
Dec 19, 2017

Copy link to clipboard

Copied

I have the same problem.

"... some file are missing.." notice

I am using a 7 days trial version of Muse, switched over from paid..
(I don't want to start a new subscription until next year) site was working fine before that.

I deleted files off of server. --opened up Muse and re-uploaded all.

I have rechecked assets

I followed the above instructions and went into AppPref.xml and changed to true.

I am on Windows 8.

I cleaned the cache, got rid of temp files, turned the computer on and off. AND...

And I kept my fingers crossed when I opened the site up again.

So I saw somewhere, I can just remove that file, delete it?
Would that file ever change itself back? to false?

It prevents the page from loading.

Have replanted twice full.

I just closed out again and am re-uploading one more time.

yale-56.org

I am going to open it one more time...... waiting....for all files upload.

YAHHOOOO!

It worked. Third time was a charm.....

but I tell you, it is a little scary going through the pages now, I am popup shy. such a hassle. wasted hours.

THANKS for the instructions.

One questions.... Can i just delete that file AppPref.xml?

THANKS again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 19, 2017 0
LEGEND ,
Dec 20, 2017

Copy link to clipboard

Copied

No, don’t delete it! Why do you want to do this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 20, 2017 0
New Here ,
Feb 02, 2018

Copy link to clipboard

Copied

When I made the fix to the .xml file, it appears to work on my iMac but still doesn't seem to be working for my ipad and iphone. (Still getting this message on those devices. Any thoughts on how it can be fixed on all devices?)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2018 0
LEGEND ,
Feb 02, 2018

Copy link to clipboard

Copied

Maybe you have cached data on your iPad/iPhone.

Try this:

Open your device‘s „Settings“, scroll down to the „Safari“ category, and tap on „Delete history and browser data“ (or similar. I am using the German iOS).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2018 0