Muse Page loads at first anchor point

New Here ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Hi.

I'm new to Muse so forgive me if this is obvious.

I have uploaded a one page scrolling site (built through a template) which has a static menu at the top (on a master page) . However, when my client views it (through safari on an imac, macbook and iphone) it initially loads at the first anchor point halfway down the page. He has to scroll up the page to see the intro paragraph.

I have checked it in safari, chrome and firefox on my MacPro and it appears fine but I have the same problem on my iphone.

Does anybody have any suggestions for a fix or what is going on.

thanks for any help

Views

368

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

LEGEND , Jan 30, 2018 Jan 30, 2018
I tested your file and made some small changes.Afterwards I uploaded the site test-wise to Businesscatalyst and couldn’t reproduce the issues any more. That does not mean, the issue is fixed, because it was really difficult to reproduce before too.Here what I did: I placed the first anchor „welcome“ onto the layout page and repositioned it I unpinned the header elements (black rectangle, name, menu), because mobile devices don’t like punning at all. Instead of pinning I used „Scroll Effects“. Th...

Likes

Translate

Translate
LEGEND ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

Could you give us a link?

Make sure, that the link, you are using to view the page has nothing like "#anchor“ at the end of the address.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

D Matthew Portfolio Page

Hi Günter

The link for the site is above. When it loads for him, the "About me" section is at the top of the page under the menu and he has to scroll up to see the picture and welcome section in blue.

Any help much appreciated

thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 29, 2018 Jan 29, 2018

Copy link to clipboard

Copied

I see.

Could you please do the following:

Delete everything of your page, except the two first sections „Welcome“ and „About me“. This would considerably save download and analyzing time.

Save this smaller .muse file under a new name and share it with us using Dropbox, CC Files or a similar file sharing service.

You may follow these instructions: Please Provide a .muse File to Help Us Fixing Your Issue!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 30, 2018 Jan 30, 2018

Copy link to clipboard

Copied

Thanks Gunter.

Adobe Creative Cloud

I thinkk i've done what you requested. Hope it helps

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 30, 2018 Jan 30, 2018

Copy link to clipboard

Copied

I tested your file and made some small changes.

Afterwards I uploaded the site test-wise to Businesscatalyst and couldn’t reproduce the issues any more. That does not mean, the issue is fixed, because it was really difficult to reproduce before too.

Here what I did:

  • I placed the first anchor „welcome“ onto the layout page and repositioned itscreen.jpg

  • I unpinned the header elements (black rectangle, name, menu), because mobile devices don’t like punning at all. Instead of pinning I used „Scroll Effects“. These settings have the same effect as pinning, but are much more „mobile friendly“:
    Screen2.jpg

Just try it and look, if it helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2018 Jan 31, 2018

Copy link to clipboard

Copied

LATEST

Hi Gunter

thanks so much for your help so far.

I’ve tried your suggestions which were very neatly explained thank you. As you say it’s hard to tell if it is succesful as I wasn’t seeing the issues in the first place except for on my iPhone. This however is still showing the problem.

I’ll have a go at rebuilding the page with your suggestions from scratch and see if that works

I’ll let you know how it goes. If you have any other suggestions in the meantime please let me know

thanks again

Ian

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines