Highlighted

Muse site slow to load in anything but Chrome

Contributor ,
Mar 03, 2017

Copy link to clipboard

Copied

Hi there (updated with new info)

This site: www.jasoncann.com (a work in progress still) loads fine in Chrome for me and others.

However, in Safari and Firefox, it is incredibly slow, and I'm on a fast connection.

I'm experiencing the same issue on Business Catalyst AND on Bluehost via FTP.

So odd that this is browser specific. Why would Chrome be ok but not the others? Any ideas?

Thank you!

PS. When I try the Google speed test, it suggests something that I have no idea what to do about:

Eliminate render-blocking JavaScript and CSS in above-the-fold content

Your page has 2 blocking script resources and 6 blocking CSS resources. This causes a delay in rendering your page.

None of the above-the-fold content on your page could be rendered without waiting for the following resources to load. Try to defer or asynchronously load blocking resources, or inline the critical portions of those resources directly in the HTML.

Remove render-blocking JavaScript:

thank you!

Views

461

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Muse site slow to load in anything but Chrome

Contributor ,
Mar 03, 2017

Copy link to clipboard

Copied

Hi there (updated with new info)

This site: www.jasoncann.com (a work in progress still) loads fine in Chrome for me and others.

However, in Safari and Firefox, it is incredibly slow, and I'm on a fast connection.

I'm experiencing the same issue on Business Catalyst AND on Bluehost via FTP.

So odd that this is browser specific. Why would Chrome be ok but not the others? Any ideas?

Thank you!

PS. When I try the Google speed test, it suggests something that I have no idea what to do about:

Eliminate render-blocking JavaScript and CSS in above-the-fold content

Your page has 2 blocking script resources and 6 blocking CSS resources. This causes a delay in rendering your page.

None of the above-the-fold content on your page could be rendered without waiting for the following resources to load. Try to defer or asynchronously load blocking resources, or inline the critical portions of those resources directly in the HTML.

Remove render-blocking JavaScript:

thank you!

Views

462

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 03, 2017 0
Explorer ,
Mar 03, 2017

Copy link to clipboard

Copied

Just out of curiosity (b/c I just went through this), have you gone through and optimized all your images to make them as small as possible?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2017 1
shaunPWS LATEST
New Here ,
Mar 16, 2017

Copy link to clipboard

Copied

You will need to defer the load asynchronously. Try using the default embed code as outlined in adobe documentation.

Typekit Help | Embed codes

The default method might still give issues with Page Speed tests, however I found the advanced embed code (also in above link) seems to fix this issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 16, 2017 1