Highlighted

Nested compositions not displaying correctly in mega menu

Community Beginner ,
Jan 29, 2018

Copy link to clipboard

Copied

Hi, I am using nested compositions to create a mega menu.

You can see it at Mutiny Asia

The problem I’m having is with the mega menu under ‘elevate learning’.

It is constructed by having a single trigger/composition on the top menu, and a composition with three triggers nested on the subsequent composition.

Problem 1

First time I reveal it on a page, the mini menu for the 1/3 trigger is showing.

If I then roll off, and trigger it again, on reveal the mini menu for the 1/3 trigger is not showing.

’Hide all’ is NOT checked on either the initial or secondary composition.

Problem 2

On a PC when I roll out of the composition, the mega menu disappears as expected.

On an iPad it does not disappear when I ‘tap’ outside the composition, in fact nothing I can do will get rid of it save a page refresh.

Problem 3

When I try and solve problem 2 by having a ‘close’ button, rolling out of the composition on a PC does not result in the close button disappearing. It sits there like a big fat coding error.

I can’t think of a work around for any of these - any ideas?

Alternative

Should I just use another 3rd party mega menu instead of nested compositions? In which case which one should I use?

Just my 2 cents:

  • Issue 1 – Close button doesn’t disappear: This is a known issue, which is already fixed in the newest prerelease version of Muse.
  • Issue 2 – Content of inner composition isn’t visible, when activated once: Not sure, if this is an „issue“. If you look at the configuration settings, it seems to work as expected.

I tried to modify your composition’s configuration, so that it works, as you may expect. Please have a very close look at the configuration panels of both compositions in this sample file: https://www.dropbox.com/s/6ggzm7iz1n0334y/Mutiny%202018%20Redacted_Mod.muse?dl=0

In addition: You replied Uwe​, "Thanks Uwe, I don’t really want to get too distracted by that issue."

This is one of the reasons, why it makes perfect sense, to reduce a sample file to exactly the issue, which you are dealing with. If you don’t, we have to see, how your layout is done, what happens to this and that element, when this and that element is deleted or configured differently. In short: To avoid „to get distracted“, give us a file, which, doesn’t allow distraction.

Views

431

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Nested compositions not displaying correctly in mega menu

Community Beginner ,
Jan 29, 2018

Copy link to clipboard

Copied

Hi, I am using nested compositions to create a mega menu.

You can see it at Mutiny Asia

The problem I’m having is with the mega menu under ‘elevate learning’.

It is constructed by having a single trigger/composition on the top menu, and a composition with three triggers nested on the subsequent composition.

Problem 1

First time I reveal it on a page, the mini menu for the 1/3 trigger is showing.

If I then roll off, and trigger it again, on reveal the mini menu for the 1/3 trigger is not showing.

’Hide all’ is NOT checked on either the initial or secondary composition.

Problem 2

On a PC when I roll out of the composition, the mega menu disappears as expected.

On an iPad it does not disappear when I ‘tap’ outside the composition, in fact nothing I can do will get rid of it save a page refresh.

Problem 3

When I try and solve problem 2 by having a ‘close’ button, rolling out of the composition on a PC does not result in the close button disappearing. It sits there like a big fat coding error.

I can’t think of a work around for any of these - any ideas?

Alternative

Should I just use another 3rd party mega menu instead of nested compositions? In which case which one should I use?

Just my 2 cents:

  • Issue 1 – Close button doesn’t disappear: This is a known issue, which is already fixed in the newest prerelease version of Muse.
  • Issue 2 – Content of inner composition isn’t visible, when activated once: Not sure, if this is an „issue“. If you look at the configuration settings, it seems to work as expected.

I tried to modify your composition’s configuration, so that it works, as you may expect. Please have a very close look at the configuration panels of both compositions in this sample file: https://www.dropbox.com/s/6ggzm7iz1n0334y/Mutiny%202018%20Redacted_Mod.muse?dl=0

In addition: You replied Uwe​, "Thanks Uwe, I don’t really want to get too distracted by that issue."

This is one of the reasons, why it makes perfect sense, to reduce a sample file to exactly the issue, which you are dealing with. If you don’t, we have to see, how your layout is done, what happens to this and that element, when this and that element is deleted or configured differently. In short: To avoid „to get distracted“, give us a file, which, doesn’t allow distraction.

Views

432

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 29, 2018 0
Adobe Employee ,
Jan 29, 2018

Copy link to clipboard

Copied

I am not sure about how to tackle the first part of your question, because your menu looks pretty complicated compared to the simple ones I am used to. I am hoping that the experts here will weigh in on this bit.

To the second part of your question, I suggest having a look at some of the mega menu widgets here:

https://musewidgets.com/search?q=mega+menu

Thanks,

Preran

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 0
Community Beginner ,
Jan 29, 2018

Copy link to clipboard

Copied

Thanks Preran, I don’t seem to be able to respond to your reply, apologies.

Those Adobe shopping widgets don’t seem to either work from the link, or when they do the deeper links seem to be broken. e.g. demonstration links.

Not close to a solution so far  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 0
Most Valuable Participant ,
Jan 29, 2018

Copy link to clipboard

Copied

problem 1 = i can see the error at my end

as well you have the left border is set wrong for smaller breakpoints

Screenshot (291).png

we need the .muse file to see how you set these menus up... I assume you have a conflict between the master breakpoints and the page breakpoints

reduce the .muse file to just this menu and share it on a dropbox or adobe cloud

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 0
Community Beginner ,
Jan 29, 2018

Copy link to clipboard

Copied

Wow! Thank you - that's incredibly kind.

This download should work (13MB), may be a little slow: SugarSync

Problem 4

I just discovered that although the nested composition links work on the PC, on the iPad it is hyperlinking to 'hidden layer' links.

i.e. I tap on the visible link 'content marketing', and it sends me to 'marketing skills' which is in the same position in the composition, but on a hidden tab.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 0
Most Valuable Participant ,
Jan 29, 2018

Copy link to clipboard

Copied

the first issue = navigate to the sub menu (video insights) and tick the "hide all initally" box in the options

Screenshot (592).png

test page = Home | Mutiny Consulting Asia | Digital Marketing Skills Training and Transformation

the left alignment is because you used text frames to make the menu... I don't know any work arounds unless you want to redesign the site... perhaps one of the other ACPs can think of a fix?

Screenshot (591).png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 0
Community Beginner ,
Jan 29, 2018

Copy link to clipboard

Copied

Thanks for your work Norway.

The challenge with hide all initially is that it does exactly that. It leaves a big empty space on the menu. What I was hoping to do was have it always visible when the menu was triggered.

I corrected the left align issue by pinning the composition and menu to the left of the browser instead of the centre  

Maybe I just need to drop the nested composition entirely.  

The iPad experience is a complete failure - regardless of initial visibility I can’t have the same links taking users to different places almost randomly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 0
Most Valuable Participant ,
Jan 29, 2018

Copy link to clipboard

Copied

https://forums.adobe.com/people/Nick+Fawbert  wrote

The challenge with hide all initially is that it does exactly that. It leaves a big empty space on the menu. What I was hoping to do was have it always visible when the menu was triggered.

you can make a forth one (as focus) that just has blank {perhaps a logo} then hide its trigger

or you can put some design i.e, logo on the main widget under this one... both senarios would work

fyi pin is not really a good option for non-desktop devices

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 0
Community Beginner ,
Jan 29, 2018

Copy link to clipboard

Copied

Agreed on the pin.

I’m kinda of the view that people’s modality on mobile devices is entirely different. That means that the mobile site is completely separate, with both a different design and content.

That means that browser size and responsiveness are only an issue for PC users - and road testing and focus groups have suggested that they will open browsers to full width if they are sufficiently interested.

Hence I used fixed width.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 0
Adobe Community Professional ,
Jan 29, 2018

Copy link to clipboard

Copied

For whatever reason you pinned the "elevation" to the left instead how you pinned the other menu items to to the top.

Bildschirmfoto 2018-01-30 um 08.43.22.png

As soon as you pin this button the same way as the other menu items, it keeps its place to the minimum width of 960. The same happens to the mega menu, as it is part of the button/composition.

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 1
Community Beginner ,
Jan 30, 2018

Copy link to clipboard

Copied

Thanks Uwe, I don’t really want to get too distracted by that issue.

My main issues are:

The content not being visible on second roll over

The ipad composition not ‘tapping off’

The close button not disappearing on mouse roll off

The menu items incorrectly hyperlinking on ipad

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2018 0
Adobe Community Professional ,
Jan 30, 2018

Copy link to clipboard

Copied

I don`t use iPad.

Wrong linking might be because wrong linked? Does it work with the corrected composition?

Roll off on iPad does not work, how should it, reacting on touch?

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2018 0
Community Beginner ,
Jan 30, 2018

Copy link to clipboard

Copied

Hi Uwe, it's iPad causing the problem, it represents around 10% of our user base and is our principle sales tool, so it's important.

Linking is correct. It works correctly on desktop / laptop.

On an ipad a composition should close on tap outside of the composition area. That's the iPad equivalent of 'roll out'.

It seems to me that the code is not being generated accurately for either the desktop or the iPad, hence why I'm looking for advice.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2018 0
LEGEND ,
Jan 30, 2018

Copy link to clipboard

Copied

Just my 2 cents:

  • Issue 1 – Close button doesn’t disappear: This is a known issue, which is already fixed in the newest prerelease version of Muse.
  • Issue 2 – Content of inner composition isn’t visible, when activated once: Not sure, if this is an „issue“. If you look at the configuration settings, it seems to work as expected.

I tried to modify your composition’s configuration, so that it works, as you may expect. Please have a very close look at the configuration panels of both compositions in this sample file: https://www.dropbox.com/s/6ggzm7iz1n0334y/Mutiny%202018%20Redacted_Mod.muse?dl=0

In addition: You replied Uwe​, "Thanks Uwe, I don’t really want to get too distracted by that issue."

This is one of the reasons, why it makes perfect sense, to reduce a sample file to exactly the issue, which you are dealing with. If you don’t, we have to see, how your layout is done, what happens to this and that element, when this and that element is deleted or configured differently. In short: To avoid „to get distracted“, give us a file, which, doesn’t allow distraction.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2018 1
Community Beginner ,
Jan 30, 2018

Copy link to clipboard

Copied

Thanks Gunter I appreciate your efforts. You are very kind.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2018 0
LEGEND ,
Jan 30, 2018

Copy link to clipboard

Copied

And? Did it finally solve your issue?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 30, 2018 0
Community Beginner ,
Jan 31, 2018

Copy link to clipboard

Copied

It did solve the visibility one! Thanks  

There was something in there about which composition controls I was altering (a selection issue when we have nested content at same dimensions). Maybe the trick is to create the nested composition outside the holder composition and only drop it in when complete. Difficult.

Sorry for delay in response, different time zones.

It looks like ‘close’ button issue on ipad will be resolved with next release.

However, transposed links on ipad is still not resolved, so I may have to junk the entire nested solution  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2018 0
LEGEND ,
Jan 31, 2018

Copy link to clipboard

Copied

I bet, this problem is a pure user error!

Give us a sample site, but – please, please – with a very small example link which doesn’t work correctly.

Mostly these link errors are happening, if a link is assigned to a button and the text within.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2018 1
Community Beginner ,
Jan 31, 2018

Copy link to clipboard

Copied

Haha.

No need, we only have one site. The same code you have.

Just access the existing site www.mutiny.asia through PC, and see the links all work.

Then access through iPad.

There is only one mega menu, on only one Master.

Browse around the mega menu on different pages and see that the same links do not link to the same page. When a new trigger composition comes up, clicking on ipad on the link sometimes (but not always) triggers a ‘hidden link’ in the same position below.

And please, although I respect your expertise, continually telling me it is my fault is abrasive.  

I am entirely aware that I may have done something wrong, that is why I am seeking advice. Rubbing my nose in it does not help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2018 0
LEGEND ,
Jan 31, 2018

Copy link to clipboard

Copied

No, I won’t do that.I am sitting here now since  8 hours, trying to answer user questions. I really have no time for „lost and search" games. Tell me exactly which link should lead to which page and I try.

„… telling me it is my fault“. Didn’t say this, but the misbehaving „mega menu“ certainly was a user error, wasn’t it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2018 0
Community Beginner ,
Jan 31, 2018

Copy link to clipboard

Copied

Well, on PC everything for www.mutiny.asia works.

But on ipad...

Clicking on ELEVATE > [mega menu] Workshops > Marketing Skills (under One Day Fast Track) should go to this:

Marketing Skills Workshops | Mutiny Consulting Asia | Digital Marketing Skills Training and Transfor...

But but sometimes it goes to this:

Content Marketing | Mutiny Consulting Asia | Digital Marketing Skills Training and Transformation

And sometimes it goes to this:

The Formula for Success | Mutiny Consulting Asia | Digital Marketing Skills Training and Transformat...

They are are all on the same position, but under different triggers.

None of them are visible at the moment of click. The click is always with the ‘visible’ composition as workshops.

It happens on all the other links with a link in the same position below. Almost like cycling (but it’s not cycling, because they don’t happen in order).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2018 0
LEGEND ,
Jan 31, 2018

Copy link to clipboard

Copied

I tested t on iPad Air, iPad mini, new iPad (2017) and couldn’t reproduce the issue. The link always gos to the correct page.

The only thing I noticed: Evidently not all links are activated. For example „Data Driven Decision Making is „dead“. This is true for all sizes (desktop, iPad)

And: The „mega menu“ still suffers from being blank, when leaving the menu area and coming back. With the solution I provided this doesn’t happen.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2018 0
Community Beginner ,
Jan 31, 2018

Copy link to clipboard

Copied

Thanks Gunter. You’re a dreamboat.

Yes, we didn’t set the team on updating the menu with your amended composition conditions or page breaks when we couldn’t get the links to work. We separated the problems and halted dev.

Not all links are live because we need proof of execution before scaling.

Everything has a cost!

Our sales team work on iPad Pro; we sell video training, and large screens are critical. I appreciate that wasn’t one of your platforms.

It is a clear problem for us. I did it again just now. For us it is consistent and reproducible. We have cleared caches and restarted to no change.

I know you made a point about my use of the word ‘issue’ earlier. This wasn’t with reference to Adobe dev, it was a reflection on our business requirements. It is an ‘issue’ for us. Our business relies on the sales guys demonstrating the quality of our product. Our ‘issues’ matter.

I’m really thankful with your efforts for us, please don’t see our exasperation and change of solution as a signal for wasted effort!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2018 0