Highlighted

Paste this snippet at the end of the form reCAPTCHA

Explorer ,
Mar 21, 2018

Copy link to clipboard

Copied

Hi, after getting spammed, Im trying to get reCAPTCHA 2.0 working in a Contact Form.  It works fine on the BC site I used as a test run, but when I uploaded the same Muse file to my non BC site, the ReCaptcha doesn't work properly.   It doesn't produce any ReCaptcha anti-robot images but the Im not a robot tick box works, and emails get sent OK. 

I had no problems following the Adobe user guide "Using Form widgets in Adobe Muse" except for one thing:  "paste this snippet at the end of the form where you want the reCAPTCHA widget to appear"  How exactly can I do that in muse?  I tried using an AIDBC end body code widget, but I wasnt really sure where or how to include it.  Its in my Muse file on the same page as the form, with the snippet pasted in it but it just generates another "Im not a robot" tick box.  Can anybody tell me how to fix this?  Help would be much appreciated? Cheers

After struggling with same issue for 3 days. This is what worked for me:

1. Get a php.ini file on the server with url_fopen set to ON in your public_html folder (I used the multiPHP INI Editor on cPanel). Or call your tech support to do it!

2. Do Step 1 from your google myreCAPTCHA account directions and paste the following:

<script src='https://www.google.com/recaptcha/api.js'></script> in the Head Field on the Page Properties of your contact page.

3. In the widget contact form set the catcha to NONE (you have to have already entered recaptcha 2.0 info once so MUSE remembers your site and secret key - so do that first and save it and then come back in and set it to NONE).

4. In the space on the form where the recaptcha  graphic used to be: go to Object/Insert HTML and paste the code from your google recaptcha Step 2: <div class="g-recaptcha" data-sitekey="XXXXXXXXXXXXXXXXXXXXXXXXXX"></div> ("XXX" is your site key).

Just wanted to share after hours and HOURS of researching and trying all kinds of combinations! The key was setting reCaptcha to None and inserting your own reCaptcha code vie an html object (which didn't hit me until I got some sleep)!

Views

601

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Paste this snippet at the end of the form reCAPTCHA

Explorer ,
Mar 21, 2018

Copy link to clipboard

Copied

Hi, after getting spammed, Im trying to get reCAPTCHA 2.0 working in a Contact Form.  It works fine on the BC site I used as a test run, but when I uploaded the same Muse file to my non BC site, the ReCaptcha doesn't work properly.   It doesn't produce any ReCaptcha anti-robot images but the Im not a robot tick box works, and emails get sent OK. 

I had no problems following the Adobe user guide "Using Form widgets in Adobe Muse" except for one thing:  "paste this snippet at the end of the form where you want the reCAPTCHA widget to appear"  How exactly can I do that in muse?  I tried using an AIDBC end body code widget, but I wasnt really sure where or how to include it.  Its in my Muse file on the same page as the form, with the snippet pasted in it but it just generates another "Im not a robot" tick box.  Can anybody tell me how to fix this?  Help would be much appreciated? Cheers

After struggling with same issue for 3 days. This is what worked for me:

1. Get a php.ini file on the server with url_fopen set to ON in your public_html folder (I used the multiPHP INI Editor on cPanel). Or call your tech support to do it!

2. Do Step 1 from your google myreCAPTCHA account directions and paste the following:

<script src='https://www.google.com/recaptcha/api.js'></script> in the Head Field on the Page Properties of your contact page.

3. In the widget contact form set the catcha to NONE (you have to have already entered recaptcha 2.0 info once so MUSE remembers your site and secret key - so do that first and save it and then come back in and set it to NONE).

4. In the space on the form where the recaptcha  graphic used to be: go to Object/Insert HTML and paste the code from your google recaptcha Step 2: <div class="g-recaptcha" data-sitekey="XXXXXXXXXXXXXXXXXXXXXXXXXX"></div> ("XXX" is your site key).

Just wanted to share after hours and HOURS of researching and trying all kinds of combinations! The key was setting reCaptcha to None and inserting your own reCaptcha code vie an html object (which didn't hit me until I got some sleep)!

Views

602

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 21, 2018 0
Mar 22, 2018

Copy link to clipboard

Copied

Hey Malcom,

Try adding it here, and see if works for you!

ad14f86cc9.png

Also can you please share the link from where you got the above info?

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2018 1
Explorer ,
Mar 22, 2018

Copy link to clipboard

Copied

Thanks Ankush, your suggestion works for the head but not for the end body code. But on the bright side... the recaptcha is now working fine!  I pasted the snippet into the AIDBC end body code widget, but previously (for some unknown reason) I had a random image placed underneath that widget.  Once I deleted that image the recaptcha started working properly. I also had to right click the widget and choose Hide in Breakpoint .  Anyway, it might not be the textbook method but it worked for me. No more spam. Happy Days!

By the way the link of the original article is: Add contact forms and style form widgets in Adobe Muse.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2018 0
New Here ,
May 17, 2018

Copy link to clipboard

Copied

After struggling with same issue for 3 days. This is what worked for me:

1. Get a php.ini file on the server with url_fopen set to ON in your public_html folder (I used the multiPHP INI Editor on cPanel). Or call your tech support to do it!

2. Do Step 1 from your google myreCAPTCHA account directions and paste the following:

<script src='https://www.google.com/recaptcha/api.js'></script> in the Head Field on the Page Properties of your contact page.

3. In the widget contact form set the catcha to NONE (you have to have already entered recaptcha 2.0 info once so MUSE remembers your site and secret key - so do that first and save it and then come back in and set it to NONE).

4. In the space on the form where the recaptcha  graphic used to be: go to Object/Insert HTML and paste the code from your google recaptcha Step 2: <div class="g-recaptcha" data-sitekey="XXXXXXXXXXXXXXXXXXXXXXXXXX"></div> ("XXX" is your site key).

Just wanted to share after hours and HOURS of researching and trying all kinds of combinations! The key was setting reCaptcha to None and inserting your own reCaptcha code vie an html object (which didn't hit me until I got some sleep)!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 17, 2018 2