PHP 7

New Here ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

What do I have to do with my older sites? My provider told me to use PHP 7.0 oder 7.1.

Will the site automatically update when I delete the old contact forms and put in a new one vom the updated Muse?

Views

626

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Oct 20, 2017 Oct 20, 2017
PHP is a server processing adjunct. It has nothing to do with HTML and therefore Muse. If your provider opts to not support certain PHP functions, then that's his decisison, but on a general level all standard Forms Muse spits out should run just fine, being that they don't use complicated version-specific code. Most PHP failures come down to misconfigured or all too restrictive server policies, anyway...Mylenium

Likes

Translate

Translate
Adobe Community Professional ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

PHP is a server processing adjunct. It has nothing to do with HTML and therefore Muse. If your provider opts to not support certain PHP functions, then that's his decisison, but on a general level all standard Forms Muse spits out should run just fine, being that they don't use complicated version-specific code. Most PHP failures come down to misconfigured or all too restrictive server policies, anyway...

Mylenium

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

What do you meen by older sites?

If you are talking none muse sites, or sites that use a database via server-side code, then that depend. If you used say the old Dreamweaver server behaviours, then your site will fail, as any code that used the old mysql database connections will no longer work, and there is no easy way to update the code, short of a full re-write.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

That all sounds very technical. I am old talking about Muse.

Muse uses php for the Contact-form.

The question is - what will happen to the contact-forms?

Wil they run with  the new php-versions ? Or do I have to delete or replace them?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Werbepaula  wrote

The question is - what will happen to the contact-forms?

Wil they run with  the new php-versions ?

if the host server turns off their php support then yes the Muse email forms will stop working

Werbepaula  wrote

Or do I have to delete or replace them?

if the host server i.e, GoDaddy, Bluehost or whomever it is turns off their php then I would move to another host server that does support php emails (most of them do) and be sure to fill out the survey question that tells them why you don't want their business when you go.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

LATEST

Thank you for all answers, but they still do not solve my problem: My provider told me the host server turns off their php support for older Versions of PHP and told me to use PHP 7.0 oder 7.1.

Will the Muse-contactform still work? I don´t know which version php is in the forms.

Is this only a problem in Germany? I got this Information from three different providers/host servers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines