reCAPTCHA 2.0 server error -- SOLVED

Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Hi all,

The below doc was made with help of one of our contributors John Blaustein who was facing issue with his form using ReCaptcha 2.0.

Below is what his diagnosis was and looks like it should help other users as well facing the similar issues.

This will also help us in further researching on this issue and completely eliminate it.

"For those of you having problems using reCAPTCHA 2.0, my web hosting service solved the problem for me.  I had a contact form that was working perfectly until I added the reCAPTCHA 2.0 field.  When clicking Submit, I got an error: "The server encountered an error."  It is now fixed and working perfectly."

Here is what their tech support person said:

"I've figured out what was causing the error. The PHP option for ‘url_fopen’ was not getting set correctly. It was set to ‘Off’, when it needed to be ‘On’ in order for the form to be submitted successfully. To set it to ‘On’, I added a custom php.ini to your account in the public_html folder (just a copy of the server's php.ini file) and change the variable for ‘url_fopen’ to ‘On’."

The php.ini file is on the server side, not the user side. I did not create or edit the php.ini file--Muse didn't either.  My web hosting tech support person edited the file on the server to correct the setting which allowed the captcha to work.

My advice would be to contact your web hosting service and tell them exactly what my tech said, quote in my initial message above.  Let's hope that works for you.

This document was generated from the following discussion: reCAPTCHA 2.0 server error -- SOLVED

I once again thank John Blaustein and   for putting their time and effort in addressing this issue.

Cheers,

Ankush

Views

12.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Thanks Ankush!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 18, 2017 Jan 18, 2017

Copy link to clipboard

Copied

Thank you, Ankush!  Glad to help.

John

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 22, 2017 Mar 22, 2017

Copy link to clipboard

Copied

I too had this problem and struggled with it for hours yesterday. Tried this today and it worked like a charm with iPage.  Thanks for posting Q & A!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 26, 2017 Apr 26, 2017

Copy link to clipboard

Copied

I'm still struggling with it unfortunately. I set up the reCATCHA 2 with the widget in Muse and I uploaded a php.ini file to my client's public html folder and its still giving me the error. Also, I tried adding the script code produced by Google to the <head> section and the site to see if that was the problem and the reCAPTCHA option doesn't generate once the script is added. So I removed it and it shows but it still generates the "the server encountered an error" message.

The client is using 1and1.com and is using a shared server option so initially there is no php.ini file that I have access to so I'm not sure if it's 1.) the script code not being added or 2.) if its the fact that it's a shared server. Any help provided is greatly appreciated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 23, 2017 May 23, 2017

Copy link to clipboard

Copied

After trying all the options commented, the recaptcha image was still not appearing in my form.

The solution for me, check your HTML at the page properties, maybe you have a <script> line from google recaptcha.

I deleted it and everything started working fine. I left it there from the previous recaptcha v1 and forgot about it.

Another possible problem. Check the .htaccess file in the public_html folder of your website. It should point to your PHP.ini file

I found this

(links removed by moderator)

SuPHP (Single user PHP) is a php handler which executes PHP scripts with the permissions of their owners. It is installed on all our shared servers. Using this option, you can make settings from the chosen php.ini file global for the entire account.

If php.ini is located in public_html folder, to enable it globally for the hosting account, you should add the following configuration directive to the .htaccess file:

<IfModule mod_suphp.c>
suPHP_ConfigPath /home/USER/public_html
</IfModule>

NOTE: Make sure you replace USER with your cPanel username.

This option tells mod_suphp which path to pass on to the PHP-interpreter and which folder to execute php.ini from.

Good luck!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 05, 2017 Jun 05, 2017

Copy link to clipboard

Copied

I just ran into this exact problem with a site I hosted on Register.com. After 4 support calls, they kept telling me "there' something wrong with your code." After checking with a support rep at Adobe (Saurabh) he found the problem with the url_fopen PHP option. I then called up Register.com support to tell one of their reps about this. Instead of helping me by turning on the url_fopen option, the rep told me to go into the php.ini file and "add it to the ini file" as if I understood what to do.

I don't know the exact line of code to enter into the php.ini file, so I still have the problem of the form not working.

He took absolutely no responsibility for the problem, and expected me to know what to do. I'm not a coder and I don't know what to do to fix this. Five calls to Register.com's support has convinced me that they have the most abysmal tech support staff I've ever run across. His attitude was "we don't debug your code", and he refused to accept that PHP server options had anything to do with him. I highly recommend avoiding hosting on register.com or their parent company web.com. After 5 days and 5 phone calls, the problem still exists, so Register.com is NOT a good place to host Muse sites. As a result I'll need to move the site to GoDaddy so that the form will work. I never have problems with Muse forms on GoDaddy.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 17, 2017 Aug 17, 2017

Copy link to clipboard

Copied

After reading through the posts here I believe I am to conclude that basically this issue is Not Resolved.

This same issue is discussed in:  reCaptcha 2.0 not showing up from Muse 2017

As Christ-Fowel noted on May 30, 2017

"Lots of forums here are having an issue with Adobe Muses 2017 Recaptcha. The way Adobe is asking people to "fix" it is by turning on the allow_url_fopen on your server. For most people, this has fixed there issue. For me it still didn't work, which isn't the point here. BUT even if it did, I wouldn't use it... BECAUSE...

The fix Adobe is asking people to do is counteractive. As we use Recaptcha to reduce spammers/hackers and improve security, what Adobe is asking is to reduce our security for this feature to work. Enabling this feature would actually put you in a more venerable situation then before when you didn't have the recaptcha in my opinion."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

For those working in CPanel and have had a problem finding the PHP.ini file. There is a tool:

1: Go into your root cPanel.

2: Under "Software" select "MultiPHP INI Editor" - (or type that in the Search)

3: Dropdown on the multiple versions of PHP and edit the top line's ON/OFF Toggle.

4: Hit Apply each time you update a PHP Version.

Test your form, it should work now. In all of the sites under that cPanel host.

- Greg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 22, 2018 May 22, 2018

Copy link to clipboard

Copied

thanks - worked for me after I asked UK2.net to make this update

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 28, 2020 Apr 28, 2020

Copy link to clipboard

Copied

When I wanted to sign up z shadow error for site domain

Invalid domain for site key please solve 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

LATEST

You need to register for the site key and secret key with each specific domain name.  Using a different site's key will give you this error.  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines