reCAPTCHA 2.0 server error -- SOLVED

Advocate ,
Jan 16, 2017 Jan 16, 2017

Copy link to clipboard

Copied

Hi all,

For those of you having problems using reCAPTCHA 2.0, my web hosting service solved the problem for me.  I had a contact form that was working perfectly until I added the reCAPTCHA 2.0 field.  When clicking Submit, I got an error: "The server encountered an error."  It is now fixed and working perfectly.

Here is what their tech support person said:

"I've figured out what was causing the error. The PHP option for ‘url_fopen’ was not getting set correctly. It was set to ‘Off’, when it needed to be ‘On’ in order for the form to be submitted successfully. To set it to ‘On’, I added a custom php.ini to your account in the public_html folder (just a copy of the server's php.ini file) and change the variable for ‘url_fopen’ to ‘On’."

I hope this helps others here.

John

Views

7.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Thank you for this wonderful solution, John.

I will share this with other user's as well and see if this can be documented in our KB.

Many Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Hi Ankush,

Over the years, I have received enormous amount of help for Muse, DW, LR and PS, so it's nice I can contribute something once in a while that may help others.  The credit really goes to the tech support woman at my hosting service who had to dig deeply to find this solution.

Best,

John

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 06, 2017 Jun 06, 2017

Copy link to clipboard

Copied

Hi Anush,

I am encountering an error that says: The server encountered an error

May you please help with getting the contact form captcha 2.0 working properly?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Aug 23, 2017 Aug 23, 2017

Copy link to clipboard

Copied

Hey guys,

Sorry for the long wait.The latest update of Muse has done a lot of rectifications in the working of form along with Google ReCaptcha 2.0

However, here is the good news which we all were waiting for so long.

The latest update of Muse has done a lot of rectifications in the working of form along with Google ReCaptcha 2.0

The best this is forms along with composition and slideshow widgets are now responsive.

Could you all please test the new update and let us know if the Reaptacha issue is fixed?

Please see the following release summary for detailed info - New features summary for the 2017 release of Adobe Muse CC

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2017 Nov 10, 2017

Copy link to clipboard

Copied

Unfortunately, this problem seems to still exist as of the 2018 Muse release. You can see the issue on this contact page: https://ishof.org/contact.html

It also seems that we do not have access to modify the php.ini file as we are on a shared server. Any ideas?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2017 Nov 14, 2017

Copy link to clipboard

Copied

I just tried your form, I get the same error on mine! http://uscbs.org

Dang! Why can't they get this thing right?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

John,

I'm having this issue too, where do I find that php.ini file?  I don't see it in my uploaded files... Let me know, thanks!

B

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Hi Bryant,

The php.ini file is on the server side, not the user side.  I did not create or edit the php.ini file--Muse didn't either.  My web hosting tech support person edited the file on the server to correct the setting which allowed the captcha to work. 

My advice would be to contact your web hosting service and tell them exactly what my tech said, quote in my initial message above.  Let's hope that works for you.

John

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Got it, thanks John, totally worked for me!  Just took a while to figure out how to modify my hosting providers php.ini file.  Thanks again!

B

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Bryant,

That was fast!  I didn't know I could have edited that file on the server, but I wouldn't have known what to do anyway.  Glad you got it working.

John

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Thanks John, took some serious research to get into the php.ini file.  FatCow has it hosted inside of the CGI and Scripted Language Support section of their Control Panel.  I appreciate your help, you got me down the right path. 

For those of you using FatCow to host your Muse Sites, here's their knowledgebase article:  FatCow Knowledgebase - Scripting: How to Disable PHP Functions  

Thanks Again!

B

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Jan 17, 2017 Jan 17, 2017

Copy link to clipboard

Copied

Well Bryant, you piqued my interest so I went into my own Control Panel on my hosting site--westhost.com.  They use cPanel.  I scrolled down to the Software section and clicked on the PHP INI editor.  There is was!  So, if I'd known which option I was looking for, I could have changed it.  But of course, I didn't.

John

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 21, 2017 Mar 21, 2017

Copy link to clipboard

Copied

I've had an issue; the reCaptcha just won't show up. I've found that little bit of code in the public.html and also the root directory, I've changed it to "On"... in both... no change. Pics show muse site, keys were copied and pasted so I can't type them wrong... I get an error.. any further ideas, my client is getting spammed to bits and google isn't giving me access to the old Captcha that I can find.

whatsiteshows.png

Screenshot 2017-03-22 17.47.15.png

phpini.png

firefox inspect.png

error.png

Images show : Form on the site, form with fields added in muse, php ini file (edited), firefox inspector, and the google php error...

Would appreciate any knowledge...???? I can be contacted at viv@ivivid.co.nz also. Help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2017 Nov 14, 2017

Copy link to clipboard

Copied

Thanks for the fatcow info.. I was able to go in and change the OFF to ON. But I'm not sure if that makes my site less secure, which is troubling. But the form worked no problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
May 16, 2017 May 16, 2017

Copy link to clipboard

Copied

I've come across a lot of forms like this one where a lot of people are talking about turning on the "allow_url_fopen". BUT, this doesn't make any sense to me as we are trying to implement a security feature (reCaptcha 2.0) and lowering the security by allowing url_fopen?!?!

My Host Says:

allow_url_fopenDisable this directive to deny attackers the ability to open remote files from your server through file inclusion vulnerabilities.

What is the right way of doing this?! I can't find any other answers...? Please help! Thanks!

Below is what my form looks like? Missing image?!

Screen Shot 2017-05-16 at 10.40.02 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 22, 2018 Jan 22, 2018

Copy link to clipboard

Copied

Well, I was hopeful.  Like others, I get a spinning ball on the Captcha 2.0 option - it times out and does not submit the form.

I am hosting with Media Temple. There is a PHP INI settings control panel for each domain. 

See screen shots of settings below. Unfortunately, the "AllowURL FOPEN" setting was already ON - Any other ideas on how to resolve this?

THE PROBLEM ONLY SEEMS TO PERSIST WHEN THERE IS A FORM INSIDE OF A POP-UP SUCH AS A LIGHTBOX or TOOLTIP PRESENTATION. A TEMPORARY WORKAROUND IS TO REDIRECT TO ANOTHER PAGE TO COMPLETE THE FORM- NOT GREAT.

screenshots of PLEASK server settings on Media Temple:

Screen Shot 2018-01-22 at 1.37.39 PM.png

Screen Shot 2018-01-22 at 1.37.26 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jun 08, 2018 Jun 08, 2018

Copy link to clipboard

Copied

LATEST

This worked for me!   My company's current web host is Network Solutions.  Through their provided "file manager" I located the existing default "php.ini" file (which was completely blank).  I added the following line of text:

allow_url_fopen = On

I clicked "save", navigated to my website's contact form and voila--ReCaptcha 2.0 worked!  The form was submitted.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines