reCAPTCHA 2.0

Explorer ,
Mar 20, 2018 Mar 20, 2018

Copy link to clipboard

Copied

Hi,

I am currently using an old version of reCAPTCHA and want to upgrade to 2.0.

I have changed my form to be reCAPTCHA 2.0 and I have generated the new public and private keys from Google and I have copied them over in my form in the correct places.  However, after copying the private key in the key will disappear after I click away from the form (though the public key remains).  The key is correct and is the one generated by Google.

Any idea why this is happening? 

Thanks.

Views

903

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Mar 21, 2018 Mar 21, 2018
Hey TedMau,Quite tedious but can you please try putting the key manually in that box?Or else firsts copy the key in a notepad, look if you find any spaces or special characters and delete them.Now copy this key from notepad and paste it into Muse widget.Let me know how it goes!Regards,Ankush

Likes

Translate

Translate
Mar 21, 2018 Mar 21, 2018

Copy link to clipboard

Copied

Hey TedMau,

Quite tedious but can you please try putting the key manually in that box?

Or else firsts copy the key in a notepad, look if you find any spaces or special characters and delete them.

Now copy this key from notepad and paste it into Muse widget.

Let me know how it goes!

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 21, 2018 Mar 21, 2018

Copy link to clipboard

Copied

Hi Ankush,

I copied the secret key into TextEdit and then copied it again from there into Muse and yes, it appears to have worked - many thanks!

That said I have exported the site as HTML and had a look locally and there is a message on the Recaptcha  box that says "ERROR for site owner: Invalid domain for site key".  Though I'm not sure whether that's because I have not properly uploaded it yet? From memory I don't think I have to copy the server side code from recaptcha into the header tag in Muse?

I'm only trying to get recaptcha2 working properly before it expires at the end of the month (the website is quite old and I need to re-do it really).

Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mar 22, 2018 Mar 22, 2018

Copy link to clipboard

Copied

Glad, it worked.

Yes, the error is because you didn't upload the site yet, and you don't have to add any external code into the header to make it work.

Once uploading the site to the server it should work fine.

Let me know how it goes!

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2018 Aug 24, 2018

Copy link to clipboard

Copied

I tried all of these that were mentioned. None have helped. My repapture V2 still says, "ERROR for site owner: Invalid site key".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2019 Mar 15, 2019

Copy link to clipboard

Copied

Nothing of what has been mentioned above seems to work. I'm at a loss and unable to fix this problem. My site is uploaded, I generated new keys multiple times, I copied - pasted into notes and then into Muse, typed directly into Muse. NOTHING! I need a solution other than dumping Adobe... which I'm just about there. HELP NOW!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 15, 2019 Mar 15, 2019

Copy link to clipboard

Copied

#1  Muse is EOL and no longer being updated.  As web technologies change,  some Muse widgets will stop working. 

#2  The  latest Google reCaptcha is version 3, not 2.

reCAPTCHA: Easy on Humans, Hard on Bots

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2019 Mar 20, 2019

Copy link to clipboard

Copied

LATEST

Hey Nancy, version 2 still seems to work for now. I guess we'll see. Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 15, 2019 Mar 15, 2019

Copy link to clipboard

Copied

Nancy isn’t right! reCaptcha 2 works fine and without issues together with Muse.

Did you exactly(!) follow these advices: https://helpx.adobe.com/muse/using/form-widgets.html#Generate_public_and_private_keys

I have no chance to do it wrong!

Please be aware, that the correct (not preview) functionality only works after uploading your site to the server and that it is absolutely necessary that your URL is the same as the one, you entered in Google’s Admin Console.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 20, 2019 Mar 20, 2019

Copy link to clipboard

Copied

Gunter thank you so much. I went back and checked the domain registration and you were correct. I've been dealing with this for 2 weeks and was pretty frustrated. Thank you so much for your insight.

Best,

dario

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines