Highlighted

Responsive footer

Explorer ,
Jan 10, 2018

Copy link to clipboard

Copied

Hi god people. How can I move footer content up with page content? You can see in Muse file, at 572px image start to be responsive and content below it moves up together with the picture as well as needed, but footer stays in place. I try every combination, but no luck. Do I have to create brakepoint between 572 and 320? Every help is welcome, thanks!

https://www.dropbox.com/s/kz1hvf8grqpyhan/Test.muse?dl=0

Of course this works! Just be a little bit careful when following suggestions.

What exactly are you looking for?

  • The footer should be placed directly under the page content (–> deselect „sticky Footer“).
  • The footer should be at the bottom of the browser window , if the page length is shorter than the window height. (–> select „sticky footer)

There is no third option – not logically and not in Muse.

Go to every single breakpoint on layout page and master page and set the „Minimal Height" for example to 500 px and deselect „Sticky Footer“ Now you have no space at all between page content and footer.

Don’t believe? Ok, here is your modified file: https://www.dropbox.com/s/gnu0h8pp619im7h/Ljubivoje_Lazic_Mod.muse?dl=0

As I said: Since footers react dynamically you can set very small minimal page heights. If you add elements on layout page, the length of your page adapts automatically.

Views

424

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Responsive footer

Explorer ,
Jan 10, 2018

Copy link to clipboard

Copied

Hi god people. How can I move footer content up with page content? You can see in Muse file, at 572px image start to be responsive and content below it moves up together with the picture as well as needed, but footer stays in place. I try every combination, but no luck. Do I have to create brakepoint between 572 and 320? Every help is welcome, thanks!

https://www.dropbox.com/s/kz1hvf8grqpyhan/Test.muse?dl=0

Of course this works! Just be a little bit careful when following suggestions.

What exactly are you looking for?

  • The footer should be placed directly under the page content (–> deselect „sticky Footer“).
  • The footer should be at the bottom of the browser window , if the page length is shorter than the window height. (–> select „sticky footer)

There is no third option – not logically and not in Muse.

Go to every single breakpoint on layout page and master page and set the „Minimal Height" for example to 500 px and deselect „Sticky Footer“ Now you have no space at all between page content and footer.

Don’t believe? Ok, here is your modified file: https://www.dropbox.com/s/gnu0h8pp619im7h/Ljubivoje_Lazic_Mod.muse?dl=0

As I said: Since footers react dynamically you can set very small minimal page heights. If you add elements on layout page, the length of your page adapts automatically.

Views

425

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 10, 2018 0
LEGEND ,
Jan 10, 2018

Copy link to clipboard

Copied

Deselect „Sticky Footer“ i every breakpoint in "Page Properties".

If there is still to much space between content and footer, reduce page size in every breakpoint. Normally, a very small page height is enough, because element, placed at the page bottom dynamically shift down the footer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2018 0
Explorer ,
Jan 10, 2018

Copy link to clipboard

Copied

Already try, but on some pages I have less content and on larger resolution, footer is not at the bottom. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2018 0
LEGEND ,
Jan 10, 2018

Copy link to clipboard

Copied

Of course this works! Just be a little bit careful when following suggestions.

What exactly are you looking for?

  • The footer should be placed directly under the page content (–> deselect „sticky Footer“).
  • The footer should be at the bottom of the browser window , if the page length is shorter than the window height. (–> select „sticky footer)

There is no third option – not logically and not in Muse.

Go to every single breakpoint on layout page and master page and set the „Minimal Height" for example to 500 px and deselect „Sticky Footer“ Now you have no space at all between page content and footer.

Don’t believe? Ok, here is your modified file: https://www.dropbox.com/s/gnu0h8pp619im7h/Ljubivoje_Lazic_Mod.muse?dl=0

As I said: Since footers react dynamically you can set very small minimal page heights. If you add elements on layout page, the length of your page adapts automatically.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2018 1
Explorer ,
Jan 10, 2018

Copy link to clipboard

Copied

My minimum high was 1050 px. That was the problem! With 500 px and deselected sticky footer, everything works like a charm! Thank you Günter and God bless you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2018 0
LEGEND ,
Jan 10, 2018

Copy link to clipboard

Copied

Fine!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2018 0