Highlighted

Single webpage scrolling to anchors. 5 anchors present, 1 & 2 alone jumping, instead of scrolling !

Community Beginner ,
Feb 23, 2020

Copy link to clipboard

Copied

I made a single webpage which has 5 anchor points. Like 5 pages single page scrolling website. 1 & 2 alone keeps on misbehaving. Tried deleting them and recreating the anchors several times to no avail.

 

Also after 5 tries or so, suddenly it will work ONCE, and then again flits between 1 & 2, more like no scrolling but behaves just like a normal link to another page (changes in a flash). Theres only 1 page and a master in my design. All anchors are on the main page (not master). Master & Main page both are fixed width only.

 

The remaining 3 anchors work like a charm with no hiccups at all.

What am i missing here.

 

Thanks & Regards

TOPICS
Bugs, How to

Views

915

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Single webpage scrolling to anchors. 5 anchors present, 1 & 2 alone jumping, instead of scrolling !

Community Beginner ,
Feb 23, 2020

Copy link to clipboard

Copied

I made a single webpage which has 5 anchor points. Like 5 pages single page scrolling website. 1 & 2 alone keeps on misbehaving. Tried deleting them and recreating the anchors several times to no avail.

 

Also after 5 tries or so, suddenly it will work ONCE, and then again flits between 1 & 2, more like no scrolling but behaves just like a normal link to another page (changes in a flash). Theres only 1 page and a master in my design. All anchors are on the main page (not master). Master & Main page both are fixed width only.

 

The remaining 3 anchors work like a charm with no hiccups at all.

What am i missing here.

 

Thanks & Regards

TOPICS
Bugs, How to

Views

916

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 23, 2020 0
Adobe Community Professional ,
Feb 23, 2020

Copy link to clipboard

Copied

No chance for any of us to help without any link.

1) Even better, please reduce your site/page to only the menu, leading to the anchors, the anchors itself and maybe some graphics/colored boxes/rectangles or headlines to identify the specified different areas.

2) Save that file with a new name into your CC-folder and …

3) … share that link with us (thanks Guenter, to remind of that cool "trick")

 

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2020 0
Community Beginner ,
Feb 23, 2020

Copy link to clipboard

Copied

Greetings Uwe,

 

I do understand for this you'll need to see the file. I can surely share it. Its is already barebones and has nothing but some lorem ipsum text. And 5 coloured rectangles to signify and demarcate each page. And the 5 anchors with the 5 corresponding buttons for them. Theres nothign else on the page. I will upload it right now (going to my google drive to do the needful) and post the link here.

 

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2020 0
Community Beginner ,
Feb 23, 2020

Copy link to clipboard

Copied

Hi,

 

Here is the link to my simple one page attempt...

 

https://drive.google.com/file/d/1qrNZI3v_oCR7FaSZ2z2iCHVMTlAkeUeQ/view?usp=sharing

 

Please give it a look and see if you can help me. The anchors 1 & 2 are the problem, the rest seem to work fine.

 

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2020 0
Adobe Community Professional ,
Feb 24, 2020

Copy link to clipboard

Copied

I don`t need the html but the muse file to help.

 

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2020 0
Community Beginner ,
Feb 24, 2020

Copy link to clipboard

Copied

Very sorry for the mix up.

 

Plz find the link to the .muse file here...

https://drive.google.com/open?id=1-sd-qKWRa5nInijXEy3EBHDgNWfNBXHW

 

Thanks & Regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2020 0
Adobe Community Professional ,
Feb 24, 2020

Copy link to clipboard

Copied

All anchors should be in x-value = 0 instead of (for example -7125)

Bildschirmfoto 2020-02-24 um 14.52.29.png

So all other breakpoints should be as well in x-value = 0 - in your actual file they are just freely floating outside the canvas in every breakpoint.

These are your least problems. Your breakpoints are set up weird, to be polite.

Almost elements are not setup correct in any way.

I did some quick and dirty here:  https://adobe.ly/3c4sjYo

Take care that all elements, including the anchors inside the thin blue lines:

Bildschirmfoto 2020-02-24 um 16.04.43.png

I did not all breakpoints, as the mobile needs some additional set ups. And I did only page 1 and 2, just to show the idea behind it.

 

Hope that helps,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2020 0
Community Beginner ,
Feb 24, 2020

Copy link to clipboard

Copied

Hi,

 

I just downloaded your file (thanks). But it doesnt work either. Same problem. I didnt touch the page or modify anything. Same jump and if i keep on refreshing the page and try in all permutations n combination. Like clicking 2 times on page 1 then page 2, it scorlls once, back to page 1, jumps, back to page 2 jumps. Not even jumps. Its acting like when i design a stand alone page and hyperlink. Just instantly the next page shows.

 

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2020 0
Adobe Community Professional ,
Feb 25, 2020

Copy link to clipboard

Copied

That sounds really strange as I checked on my side as well, before uploading. May I ask for your OS and browser?

 

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 0
LEGEND ,
Feb 25, 2020

Copy link to clipboard

Copied

  • Please check all your breakpoints and look, where your anchors are placed! They are scattered all around the page, and never at the place they should be placed!
  • Additionally check your page width. I think you are confusing page width and browser width.
  • Check yor elements and site configurations. Site, pages and (most of) the elements are defined responsive, but your breakpoints are defined fixed width.

Don’t expect this site working correct. There are tons(!) of crucial design issues.

I recommend: Correct your site, and, when ready set up the anchors.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 0
Adobe Community Professional ,
Feb 25, 2020

Copy link to clipboard

Copied

I sent/uploaded my file/version of his and "repaired" it for only two menu-items except the mobile breakpoint. In my file/with my file everything worked fine on my side but as the OP has downloaded my file, even that one doesnt´t work as intended.

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 0
LEGEND ,
Feb 25, 2020

Copy link to clipboard

Copied

Don’t think, your modified file is the problem. It indeed works without any issue.

He is talking about page refresh. And of course: If you refresh, it, well, refreshes and loads the page completely new. This looks like a flash. But who would refresh a page in this case. I wouldn’t.

Perhaps Plainman is a litte bit petty in these kind of cases. In a different thread he complained about web fonts which, when loaded show for a twinkle of an eye the initial fallback fonts, which is normal, but …

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 0
Adobe Community Professional ,
Feb 25, 2020

Copy link to clipboard

Copied

Yep. I missed the "refreshing" part. The original issue, named "scrolling" issue is solved I guess.

 

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 0
Community Beginner ,
Feb 25, 2020

Copy link to clipboard

Copied

Gunter > You assume things a little too fast. And please dont grumble even though your trying to help. Making bland accusations to berate me that im FINICKY and COMPLAINING is baseless. Neither did i complain nor demean the software, please point out on which thread i have done so ?.

 

Im not so stupid as your trying to portray me, that im refreshing the file.

UWE got it correct, you didnt. Theres nothing here to do with page refresh and your going on saying "IF YOU REFRESH THE PAGE > WELL IT REFRESHES". But your trying to color his perpective of this post and confuse him further to make it look like im stupid.

 

Are you ignoring the fact that Uwe saw my muse file and didnt find any scattering and the very file he made and sent jumps, instantly, instead of smooth scrolling.

 

You seem to be highly irritable and want to berate people ?. Even though ive been nothing but polite.

 

Ive never complained but only tried to understand how things work, which arent explained in the help documentation. I didnt say this is my site. I said its a webpage im just attempting. Its for practice / or just a tryout. And im just trying to understand the erratic jump.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 0
LEGEND ,
Feb 26, 2020

Copy link to clipboard

Copied

You say:

"Theres nothing here to do with page refresh", but one post before you said: 

"Same jump and if i keep on refreshing the page and try in all permutations n combination."

Perhaps I misunderstood. But be aware, that you are writing in an international forum. So keep your contribution simple and clear. Your sentence isn’t clear at all, because it is grammatically incomplete and therefore not really understandable. ("if" needs a "then", what is missing).

You say: 

"Are you ignoring the fact that Uwe saw my muse file and didnt find any scattering". I bet for my life, that Uwe found the "scattering" in your file too. Therefore he deleted in his sample file all breakpoint but one. Just ask him! 🙂 And, by the way, not only Uwe – I saw your file too. 🙂

You say:

"UWE got it correct, you didnt." Of course Uwe got it correct (he is a very skilled Muse user), because he deleted the misconstucted breakpoints.

What is the essence?

If you open a page in a browser, the browser detects the correct breakpoint. Assuming you are using a desktop brower, it will probably use your 3000 px (1000 – 3000 px) breakpoint. (As a side note: A 3000 px breakpoint is quite pointless; Just inform yourself about browser display techniques and "physical" and "logical" pixels). At this breakpoint, your anchor ("page2") is placed vertically in the middle of the green area. Therefore the anchor link seems(!) to work incorrect. But it is acting as expected.

Screen_01.jpg

 

When I said, I assume, you are a little bit "petty", I refered to a quite longish conversation, where you are irritated by fallback fonts which (inevitably!) appear for "a fraction of a second" before the webfonts are displayed: https://community.adobe.com/t5/muse/muse-eol-fonts-will-stop-working-on-my-already-designed-webpage/... 

But: All seems to work as expected for you now, so back to work! 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2020 0
Plainman LATEST
Community Beginner ,
Feb 26, 2020

Copy link to clipboard

Copied

Hi Uwe,

 

There was no refreshing part etc. You didnt miss anything. Its just that Gunter wants to be nitpicky and discuss semantics. The issue was simple and you understoood correct that the file you sent also showed the same erratic jumping. In fact your final suggestion was the correct hint. The browser (Firefox, which unfortunately is the default one i use) !. Your version and even my version runs smooth on all other browsers.

 

When i said i refreshed multiple times. I just meant i tried page refreshing before attempting the anchor scrolling, in hopes of clearing the cache (if it even does that). It doesnt mean i was refreshing the page as part of page operation.

 

Not for once did Gunter suggest trying a different browser instead a lot of evasion and semantic. Ive seen a major of posts with worse grammar/language. But all was clear and you understood every, except for his assumption that everything was wrong everywhere else.

 

When it performs correctly on all browsers but firefox, i dont know how to overcome that problem. However this is just a tryout and i was trying to understand anchor scrolling. So i think this kind of error cant be corrected right ?

 

Thanks

 

PS : Gunter i guess blocked me so i cant reply to him. Very brave indeed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2020 0