Site is shifting horizontally with my portfolio in place

Explorer ,
Dec 30, 2017 Dec 30, 2017

Copy link to clipboard

Copied

nummer64.businesscatalyst.com for the link.


The Muse File -

Adobe Creative Cloud

The main problem has been located: I have a portfolio on my site. And no matter what breakpoint I choose, on mobile devices I can zoom out way to much, which gives tons of white space I don't want. And on my computer I get a white empty space next to the site.

As it seems, there must be some sort of "outline" how large the portfolio should be which is to large? As you understand what I'm trying to say?

Deleting the box gets rid of the problems. But, I want, and need the portfolio

I would have loved to be more specific, and do everything on my own. However: I am absolutely new to Muse, or webdesign at all. I have no idea what is happening at the moment. My first guess would be that their would be boundries for how large the portfolio-boxes can be? And perhaps those sizes are out of place?
But.... (sorry) checking the individually tells me all the green marker lines stay within the breakpoints. So, that kinda got me lost.

Het bericht is bewerkt door: christiaan hendrik

Views

394

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

LEGEND , Dec 31, 2017 Dec 31, 2017
Your issue definitely is solvable, but, believe me, it is very(!) laborious! I assume (what means: I don’t know for sure!), that there is a glitch within your document, which causes this odd behaviour.But now, here is, what I did:At first some glitches which may not be related to the behaviour, you found, but you should correct it anyway: You have a fluid breakpoint at 320 px. This is not necessary. Or do you know devices, which have a smaller screen width? In Addition, the „minimal width“ of th...

Likes

Translate

Translate
LEGEND ,
Dec 31, 2017 Dec 31, 2017

Copy link to clipboard

Copied

Your download link doesn’t work, christiaanh31469224

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 31, 2017 Dec 31, 2017

Copy link to clipboard

Copied

Thank you for the warning. I seemed to have copies the wrong link...

Adobe Creative Cloud

All three checkboxes are checked. So I hope everything should be fine now?

In advance: best wishes for 2018!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 31, 2017 Dec 31, 2017

Copy link to clipboard

Copied

Your issue definitely is solvable, but, believe me, it is very(!) laborious! I assume (what means: I don’t know for sure!), that there is a glitch within your document, which causes this odd behaviour.

But now, here is, what I did:

At first some glitches which may not be related to the behaviour, you found, but you should correct it anyway:

  • You have a fluid breakpoint at 320 px. This is not necessary. Or do you know devices, which have a smaller screen width? In Addition, the „minimal width“ of this breakpoint is defined as 320 px too! What means, that this breakpoint is completely clueless: You tell the browser to use this breakpoint, if the browser width is smaller than 320 px, but you forbid the browser at the same time, to do anything, because this width is defined as minimal width too.
  • Your slideshow widgets are set to be "freeform thumbnails“, what is absolutely unnecessary in this case. Deselect this option and re-organise your thumbnails in the „standard" way, using the appropriate amount of columns. (This may solve your issue with wrongly sorted thumbnails on the fly)
  • Set your thumbnails and all widget parts to responsive behaviour. They aren’t for now. Be aware, that this has to be done in every single breakpoint for every single widget part.)
  • Place all lightbox parts (hero, captions, next, precious, …) to the left of your canvas. This also has to be done for every single breakpoint. Placing the lightbox parts „on“ the page as you did, sometimes(!) causes strange issues in browser view.

These were the standard modifications, I performed and which may (or may not) affect your issue.

Now I reduced your site further by deleting unrelated elements and breakpoints, to track down the problem. Here you find your site with only a few remaining elements. Just note: Your issue is still present:

https://www.dropbox.com/s/9jybj6axbq85o12/Nummer64_online_korr.muse?dl=0

Open this .muse file and check, if you still see the issue (you should see it), Now do the following:

  • Go to the master page and unpin the following elements:
    • • the logo top left • the menu • the copyright line at the bottom and, in the smaller breakpoints, the three little lines, forming the hamburger icon. In other words: Unpin all elements, which can be unpinned on the master, except the „BEL ONS …“ text line.

If you now check your „Home“ page, you will see, that the shifting is gone and the page displays correct, although the pinnings are deleted.

Is this a bug? May be, may be not. Could be as well, that your document is slightly corrupted.

Please note: When you try to reproduce this with your complete site, the problem may return, because there are many other pinned elements. If this is the case, try unpinning one element after the other to see, if you can get it to work. Unfortunately, I actually haven’t the time to do this for you.

christiaanh31469224​: I wrote you a personal message!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 31, 2017 Dec 31, 2017

Copy link to clipboard

Copied

I would also move the Het-Park anchor a bit to the left so it is (just) off canvas in all breakpoints

Screenshot (221).png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 01, 2018 Jan 01, 2018

Copy link to clipboard

Copied

Thank you for the time to take a look and give me this feedback.
At the moment I'll try to apply the suggestions.

I'll  get back!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 03, 2018 Jan 03, 2018

Copy link to clipboard

Copied

With behind the scenes help, and the decision to start all over again, all my problems have disappeared.
All is working like a charm at the moment. At most I have to place a vertical menu instead of the regular menu on top since on my phone, it is getting to crowded.

But, the main issue has been solved. Thank you Gunter!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 03, 2018 Jan 03, 2018

Copy link to clipboard

Copied

LATEST

Behind the scenes help too I really should say.
I am offcourse gratefull for the help given in the topic itself!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines