State Button Issue - Bottom Layer Mysteriously Concealing Upper Layers

Community Beginner ,
Jan 02, 2018 Jan 02, 2018

Copy link to clipboard

Copied

Hello all! Your help would be much appreciated. I am a newbie and just discovered the magic of state buttons. I am frustrated though because it does not seem to be working the way it should. In the attached video you can see that the portfolio image is visible when in Normal State and transparent when in Rollover. The social icons "underneath" it are transparent in Normal and visible in Rollover.

Yet, when I preview the site it doesn't work correctly. I am able to click the social icons if they have links, but they are invisible. If I remove the Portfolio image ("PF Button" is it's name in the screenshot) from the State Button the social icons correctly appear and disappear so it seems to be the "PF Button" layer that is causing the issue.

LayersStates.JPG

NOTE: screen recorder is buggy, it recorded Muse's main window but not the Layer and State panels which I was clicking on.

Views

741

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Jan 03, 2018 Jan 03, 2018
Just as I was about to do this I realized the issue fixed itself. It works perfectly fine in Chrome now.I went back to an old project file and re-did some of the work I did last night and it seems that making the items in the state button (and the other adjacent objects Resume, etc) Responsive to Height and Width seemed to fix the issue. How very strange!

Likes

Translate

Translate
LEGEND ,
Jan 02, 2018 Jan 02, 2018

Copy link to clipboard

Copied

rule 1 = a state button is ALWAYS there... even if you set the transparently to zero and make it look like it is gone so it still covers | blocks clicks + it is possible to click a zero transparently hyperlink

yes the 2018 build state button is different to the 2017 build state button and yes ther are two known bugs in it

rule 2 = preview is not as good as publish... it is just a guide

looking at your layers the Instaram is above the vimeo | yourtube and the pf button is at the bottom so to click the pf buffon you would need a design that allows some space to show past the other 3... remember that fuild designs change so don't assume it looks the same in a 1024 desktop as it does on a 350 phone screen and fingers are bigger than mouse icons

rule 3 = all parts of a state button are the same object... that means a mouse hovering over the Instagram will also set the pf button to rollover (see last rule for the exception)

thejonmitchell  wrote

LayersStates.JPG

last rule that mucks people up is states... if you add a link to "home" page and place this state button on the home page (or on a Master that effects the home page) then this state button will be in its "active" state... not normal or rollover

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 03, 2018 Jan 03, 2018

Copy link to clipboard

Copied

Ussnorway, so you're saying that if I publish it it will work correctly? I was previewing in Chrome, not in Muse. Does it get "more accurate" when I publish it?

By the way, I am not intending for "pf button" to be clicked. In this case I only want it to disappear and reveal the clickable icons underneath.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 03, 2018 Jan 03, 2018

Copy link to clipboard

Copied

Would be quite easy to solve, I think, if you place only one(!!) of these state buttons onto a newly created, empty document and share this .muse file with us (–>Dropbox, CC Files, …).

You may follow these instructions: https://forums.adobe.com/docs/DOC-8652

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 03, 2018 Jan 03, 2018

Copy link to clipboard

Copied

Just as I was about to do this I realized the issue fixed itself. It works perfectly fine in Chrome now.

I went back to an old project file and re-did some of the work I did last night and it seems that making the items in the state button (and the other adjacent objects Resume, etc) Responsive to Height and Width seemed to fix the issue. How very strange!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 03, 2018 Jan 03, 2018

Copy link to clipboard

Copied

LATEST

Vimeo Password: muse

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines