Highlighted

Struggling with breakpoints in Muse

New Here ,
Oct 20, 2017

Copy link to clipboard

Copied

Struggling With Breakpoints in Adobe Muse

Every time I amend the breakpoint at 787px it changes the 960px. I’ve updated to Muse 2018, hoping that breakpoints that I was struggling with in 2017 version may be easier to add (unless it’s just me).

At the 960px RollOver State ABOUT US is Bold, red and Capitalised

Diagram 1

 

At the 787 px Rollover I’ve taken off the Capitalization

Diagram 2

At the 960 BP Rollover the capitalization has been taken off which can be seen in Diagram 1

Diagram 3

it will be deeply appreciated if anyone could resolved this problem

Thanks

Dave

[Here is the list of all Adobe forums... https://forums.adobe.com/welcome]

[Moved from CS6 & earlier forum to specific Program forum... Mod]

I see your problem. Not really sure, if it is a bug or an expected restriction. As far as I see, there is no viable workaround for this in your layout, because the text elements are part of a composition. In this case, you can’t use the commands „Hide in Breakpoint“/"Hide in other Breakpoints".

I reported this in the prerelease forum:

"The behaviour of text attributes is buggy or at least inconsistent in different states:

  • I am allowed to change the attributes, provided in the „Text“ panel breakpoint-wise as long as the „Normal“ state is affected: For example I can change text size, colour, uppercase in normal state from breakpoint to breakpoint.
  • If I try this in „Rollover State“ or „Mouse Down State", different text formatting from breakpoint to breakpoint isn’t possible any more: Every format change in one breakpoint will be taken over to all others.

You may test this with the attached .muse file „Text-Attributes-States".

  • Annotation: This is not a heavy restriction, if we are dealing with single text elements, because these can be hidden in one breakpoint and replaced by another one. But as soon as these text elements are parts of a widget (text in a composition) we are lost: Single elements within a widget can’t be „hidden in breakpoint“.

Views

512

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Struggling with breakpoints in Muse

New Here ,
Oct 20, 2017

Copy link to clipboard

Copied

Struggling With Breakpoints in Adobe Muse

Every time I amend the breakpoint at 787px it changes the 960px. I’ve updated to Muse 2018, hoping that breakpoints that I was struggling with in 2017 version may be easier to add (unless it’s just me).

At the 960px RollOver State ABOUT US is Bold, red and Capitalised

Diagram 1

 

At the 787 px Rollover I’ve taken off the Capitalization

Diagram 2

At the 960 BP Rollover the capitalization has been taken off which can be seen in Diagram 1

Diagram 3

it will be deeply appreciated if anyone could resolved this problem

Thanks

Dave

[Here is the list of all Adobe forums... https://forums.adobe.com/welcome]

[Moved from CS6 & earlier forum to specific Program forum... Mod]

I see your problem. Not really sure, if it is a bug or an expected restriction. As far as I see, there is no viable workaround for this in your layout, because the text elements are part of a composition. In this case, you can’t use the commands „Hide in Breakpoint“/"Hide in other Breakpoints".

I reported this in the prerelease forum:

"The behaviour of text attributes is buggy or at least inconsistent in different states:

  • I am allowed to change the attributes, provided in the „Text“ panel breakpoint-wise as long as the „Normal“ state is affected: For example I can change text size, colour, uppercase in normal state from breakpoint to breakpoint.
  • If I try this in „Rollover State“ or „Mouse Down State", different text formatting from breakpoint to breakpoint isn’t possible any more: Every format change in one breakpoint will be taken over to all others.

You may test this with the attached .muse file „Text-Attributes-States".

  • Annotation: This is not a heavy restriction, if we are dealing with single text elements, because these can be hidden in one breakpoint and replaced by another one. But as soon as these text elements are parts of a widget (text in a composition) we are lost: Single elements within a widget can’t be „hidden in breakpoint“.

Views

513

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 20, 2017 0
Adobe Community Professional ,
Oct 20, 2017

Copy link to clipboard

Copied

Could you provide a link?

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 20, 2017 0
Contributor ,
Oct 22, 2017

Copy link to clipboard

Copied

You see on the left tool panel on the bottom,

the 4-T symbol is selected. That means the text (style) you are changing in one breakpoint will effect every breakpoints.

To solve this: Click on the icon left-panel bottom to switch to instead of four T

and then edit the styling of  your text, that will not effect on the other breakpoints.

Toufic Nabi

Adobe Muse Expert

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 22, 2017 0
New Here ,
Oct 23, 2017

Copy link to clipboard

Copied

Sorry for the delay but I've tried your solution but it still changing the Text in the other breakpoints

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
LEGEND ,
Oct 23, 2017

Copy link to clipboard

Copied

Yes, of course it does. I bet, you typed the text newly in capital respective small letters.

But you only can change text attributes, not wording breakpoint-wise

Try this:

1. Set the tool to the correct functionality:

Text-formatting-breakpoints.jpg

2. Don’t type the words newly, but use the attribute „Uppercase“:

Screen.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
New Here ,
Oct 23, 2017

Copy link to clipboard

Copied

Hi Gunter thanks for your reply, however, if you looked at diagram 1 you will see that I've used the Uppercase Attribute.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
LEGEND ,
Oct 23, 2017

Copy link to clipboard

Copied

Please, give us one of these element (only one, please!) in a newly created .muse file and share this document with us. Please follow these instructions: https://forums.adobe.com/docs/DOC-8652

As far as I can see, this works here flawlessly:

As you use state buttons, there is one more option to achieve, what you want:

Place two text frames one over the other and set one of them to „Opacity: 100%“ and the other to „Opacity: 0%“. In normal state. In rollover state apply the contrary attributes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
New Here ,
Oct 23, 2017

Copy link to clipboard

Copied

Hi Gunter, here's the link thanks

Adobe Creative Cloud

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
LEGEND ,
Oct 23, 2017

Copy link to clipboard

Copied

I see your problem. Not really sure, if it is a bug or an expected restriction. As far as I see, there is no viable workaround for this in your layout, because the text elements are part of a composition. In this case, you can’t use the commands „Hide in Breakpoint“/"Hide in other Breakpoints".

I reported this in the prerelease forum:

"The behaviour of text attributes is buggy or at least inconsistent in different states:

  • I am allowed to change the attributes, provided in the „Text“ panel breakpoint-wise as long as the „Normal“ state is affected: For example I can change text size, colour, uppercase in normal state from breakpoint to breakpoint.
  • If I try this in „Rollover State“ or „Mouse Down State", different text formatting from breakpoint to breakpoint isn’t possible any more: Every format change in one breakpoint will be taken over to all others.

You may test this with the attached .muse file „Text-Attributes-States".

  • Annotation: This is not a heavy restriction, if we are dealing with single text elements, because these can be hidden in one breakpoint and replaced by another one. But as soon as these text elements are parts of a widget (text in a composition) we are lost: Single elements within a widget can’t be „hidden in breakpoint“.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2017 0
New Here ,
Oct 24, 2017

Copy link to clipboard

Copied

thanks again for the reply even though I'm not too sure what you are saying. Am I right in saying that it cant be done because i use a composition for the navigation? if so the best thing for me to do is to 'Hide in other breakpoints from the 960 Breakpoint' and redo another menu in the other breakpoints.

I supposed the time that I've spent trying to sort out this issue I could have made several menus but I don't like being defeated and I really want to understand Muse as I'm a beginner.

Thanks again

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2017 0