Highlighted

Tablet Layout Not Registering/Nagivation problems

Community Beginner ,
Aug 31, 2017

Copy link to clipboard

Copied

So I have now made layouts for all three devices (desktop, tablet, phone) and used many different breakpoints on all to make sure they fit the appropriate device. Desktop and Mobile are working fine, however for some reason whenever I open up the link on a tablet (iPad specifically), it uses the mobile layout or switches to the desktop layout.

At one point I had it fixed when I rerouted the Business Catalyst website to export as a Business Catalyst redirect, but my navigation menu at the top prevented it from having the layout look correct. Plus, that doesn't work as once I fix all the bugs I need to export it via HTML to the proper domain.

Here is the current website:

Home (business catalyst)

Home (exported HTML)

I have looked at countless forms to see what is wrong. The box that says "Redirect from Desktop" is checked, I have done various breakpoints, nothing seems to be working.

Hey hannaht,

I have checked your site and found that your tablet layout is not getting redirected properly to tablet layout.

However, the Business catalyst URL works fine.

Therefore I suspect that the files which you are putting as HTML on your server are causing the problem.

I suggest you ask your host for deleting all the files from their server or Cpanel and re-upload a fresh clean site, which could help you get the issue fixed.

Regards,

Ankush

Views

299

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Tablet Layout Not Registering/Nagivation problems

Community Beginner ,
Aug 31, 2017

Copy link to clipboard

Copied

So I have now made layouts for all three devices (desktop, tablet, phone) and used many different breakpoints on all to make sure they fit the appropriate device. Desktop and Mobile are working fine, however for some reason whenever I open up the link on a tablet (iPad specifically), it uses the mobile layout or switches to the desktop layout.

At one point I had it fixed when I rerouted the Business Catalyst website to export as a Business Catalyst redirect, but my navigation menu at the top prevented it from having the layout look correct. Plus, that doesn't work as once I fix all the bugs I need to export it via HTML to the proper domain.

Here is the current website:

Home (business catalyst)

Home (exported HTML)

I have looked at countless forms to see what is wrong. The box that says "Redirect from Desktop" is checked, I have done various breakpoints, nothing seems to be working.

Hey hannaht,

I have checked your site and found that your tablet layout is not getting redirected properly to tablet layout.

However, the Business catalyst URL works fine.

Therefore I suspect that the files which you are putting as HTML on your server are causing the problem.

I suggest you ask your host for deleting all the files from their server or Cpanel and re-upload a fresh clean site, which could help you get the issue fixed.

Regards,

Ankush

Views

300

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 31, 2017 0
Adobe Employee ,
Sep 01, 2017

Copy link to clipboard

Copied

I don't have an iPad to test, and I am asking a colleague to verify.

Meanwhile, I tried resizing the browser to test your site, and everything works just fine. My guess is that a third-party widget or HTML code, if you have used them, are probably causing this issue.

Thanks,

Preran

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2017 0
Sep 01, 2017

Copy link to clipboard

Copied

Hey hannaht,

I have checked your site and found that your tablet layout is not getting redirected properly to tablet layout.

However, the Business catalyst URL works fine.

Therefore I suspect that the files which you are putting as HTML on your server are causing the problem.

I suggest you ask your host for deleting all the files from their server or Cpanel and re-upload a fresh clean site, which could help you get the issue fixed.

Regards,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2017 0
New Here ,
Jan 04, 2018

Copy link to clipboard

Copied

Hello all, I'm having the same problem.  Desktop and Mobile layouts are working fine, but when I try to load my website on my iPad Pro, it comes up as the desktop version.  Can anyone help me?

The url is levitaylormusic.com/test/index.html

Thanks,

Levi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 04, 2018 0
New Here ,
Feb 26, 2018

Copy link to clipboard

Copied

Mine is doing the same thing, except it directs to mobile and that is just awful So frustrating.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0
LEGEND ,
Feb 27, 2018

Copy link to clipboard

Copied

Instead of being frustrated: As a first step to fix the issue, give us a link to your site, and describe exactly, when and where "it directs to  mobile“.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0
New Here ,
Feb 27, 2018

Copy link to clipboard

Copied

I was able to fix it, my home page directed to the right format, the other pages did not.

I was able to fix the problem by adding scroll effects into the header? I'm not sure why that fixed it, but it did so I'm happy.

Thank you for your response.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2018 0