Highlighted

The Chrome Mobile now cannot load any of My Muse Website pages. How to fix it?

Community Beginner ,
Jun 16, 2019

Copy link to clipboard

Copied

The Muse Website that i created suddenly not showing on Chrome Mobile now. It became

an empty white screen which appears on my android (using Chrome) smartphone.

The Muse Website pages cannot load any text, any photo, any javascript which means the entire website cannot be viewed if using Chrome Mobile.

Safari and Windows Mobile are not having problems. They are working just as normal when to view the Muse Website pages.

Please note this happened to Muse Website Page only. Later i browse to Muse Mobile Site page is also fine which the link is ended with phone/index.html.

The Chrome Mobile now cannot load any of My Muse Website pages. How to fix it?

Thank you.

SOLVED    FIXED     WORKS

ADD (copy) This code below,  to the master page properties (under Metadata tab) in the HTML for Head Text Area

<script type="text/javascript"><!--

var checkBrowser=navigator.userAgent.toLowerCase();var isAndroid=checkBrowser.indexOf('android')>-1;var isiPhone=checkBrowser.indexOf('iphone')>-1;var isiPod=checkBrowser.indexOf('ipod')>-1;var isiPad=checkBrowser.indexOf('ipad')>-1;var isMobile=checkBrowser.indexOf('mobile')>-1;if(isiPhone||isiPod){document.location="phone/index.html";}

if(isiPad){document.location="phone/index.html";}

if(isAndroid&&!isMobile){document.location="phone/index.html";}

if(isAndroid&&isMobile){document.location="phone/index.html";}

if(blackberry||opera||mini||palm||smartphone||iemobile){document.location="phone/index.htm l";}

if(xoom||playbook||tablet||kindle){document.location="phone/index.html";}</script>

THEN in the Main File goto File menu then Site Properties. under layout tab, use the layout drop down to go to the phone layout, then UNCHECK Redirect From Desktop checkbox. this gets rid of muse's redirect code and uses the javascript (above) on the master page. to do the redirect. WORKS!!!

In this line of code it had a space between the / and index if(isiPhone||isiPod){document.location="phone/ index.html";} 

Recopy the code above (It is Now Fixed) and Try Again,

Views

3.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

The Chrome Mobile now cannot load any of My Muse Website pages. How to fix it?

Community Beginner ,
Jun 16, 2019

Copy link to clipboard

Copied

The Muse Website that i created suddenly not showing on Chrome Mobile now. It became

an empty white screen which appears on my android (using Chrome) smartphone.

The Muse Website pages cannot load any text, any photo, any javascript which means the entire website cannot be viewed if using Chrome Mobile.

Safari and Windows Mobile are not having problems. They are working just as normal when to view the Muse Website pages.

Please note this happened to Muse Website Page only. Later i browse to Muse Mobile Site page is also fine which the link is ended with phone/index.html.

The Chrome Mobile now cannot load any of My Muse Website pages. How to fix it?

Thank you.

SOLVED    FIXED     WORKS

ADD (copy) This code below,  to the master page properties (under Metadata tab) in the HTML for Head Text Area

<script type="text/javascript"><!--

var checkBrowser=navigator.userAgent.toLowerCase();var isAndroid=checkBrowser.indexOf('android')>-1;var isiPhone=checkBrowser.indexOf('iphone')>-1;var isiPod=checkBrowser.indexOf('ipod')>-1;var isiPad=checkBrowser.indexOf('ipad')>-1;var isMobile=checkBrowser.indexOf('mobile')>-1;if(isiPhone||isiPod){document.location="phone/index.html";}

if(isiPad){document.location="phone/index.html";}

if(isAndroid&&!isMobile){document.location="phone/index.html";}

if(isAndroid&&isMobile){document.location="phone/index.html";}

if(blackberry||opera||mini||palm||smartphone||iemobile){document.location="phone/index.htm l";}

if(xoom||playbook||tablet||kindle){document.location="phone/index.html";}</script>

THEN in the Main File goto File menu then Site Properties. under layout tab, use the layout drop down to go to the phone layout, then UNCHECK Redirect From Desktop checkbox. this gets rid of muse's redirect code and uses the javascript (above) on the master page. to do the redirect. WORKS!!!

In this line of code it had a space between the / and index if(isiPhone||isiPod){document.location="phone/ index.html";} 

Recopy the code above (It is Now Fixed) and Try Again,

Views

3.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 16, 2019 0
Adobe Community Professional ,
Jun 16, 2019

Copy link to clipboard

Copied

As my muse websites all load fine on chrome it would be nice to get a link to check and see and search somehow kind of deeper about your issue. Did you create responsive or adaptive sites? And so on …

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 16, 2019 0
Community Beginner ,
Jun 17, 2019

Copy link to clipboard

Copied

Adobe Muse version 2018.1 Release

2018.1.0.266

Hi Uwe,

The website is made responsive with fluid width has different set points for various screen sizes.

There is no problem to use a laptop and Chrome PC browsing the site. Everything works like normal.

When browse the site with Android phone and Chrome Mobile, the website index.html does not show anything

but completely blank which never happened before. It does not run the javascript like this basic.

<script type="text/javascript">

<!--

if (screen.width <=600) {

window.location="http://mysite.com/phone/index.html";

}

//-->

</script>

So it just stops working. It does want going to website index page. It will not be redirected to the mobile site index page

whatsoever.

But when i type into browser with url address which ends with phone/index.html, Chrome Mobile loads the page and opens like normal.

I have tried site settings on Chrome Mobile, and switched to desktop version. It is still completely blank.

Thank you for taking time to answer my question.

Screen Shot 2019-06-17 at 11.30.36 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2019 0
Adobe Community Professional ,
Jun 17, 2019

Copy link to clipboard

Copied

As it seems to be the same question here:

Muse Websites Not Displaying on Chrome (Mobile)

I have no idea about, how I could help here. Muse does the code for you. It works on my mobile only when adding that …/phone - it does not work in its expected way. That seems to be a question for those coders out there.

Did you use any 3rd party widgets for some reason?

Sorry, but anyway

Kind Regards,

Uwe 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2019 0
LEGEND ,
Jun 17, 2019

Copy link to clipboard

Copied

Don't know how relevant this is, or how Muse users will get around the problem, (have not seen the code Muse generates, and have no intentions of doing so, because I wish to retain my sanity).

Chrome, and by default MS Edge in future, are now incorporating, (enforcing) more secure page redirect methods to prevent end users being 'hi-jacked' to 'other' sites/or sections of. This is probably to force developers to use server redirects which can be better indexed by search engines.

Sorry, I know the info is not much use to Muse users, but it may help to explain what is happening, (though I have to ask myself, if it is working for tablet devices, why not phones ).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2019 0
Explorer ,
Jun 17, 2019

Copy link to clipboard

Copied

Help Help I am serious problem because I get white mobile in google chorme android is the only one that is not working because before if they worked super well and now the latest version google chrome android mobile was updated until there was that affection nothing is seen all this is the most serious but very serious in the world because most of them I did a lot of web clients large companies, small and user, now they called me to inform me that they do not see anything in mobile and now that I am going to do with big problem but very big I need who solves me update the javascript code for mobile redirect is urgently urgent urgently please look for adobe engineer muse to solve urgent is massive global please help help who can update the code to redirect mobile in javascript.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2019 0
Adobe Community Professional ,
Jun 18, 2019

Copy link to clipboard

Copied

Simply re-build your site responsively and you won't have these problems.

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2019 0
Community Beginner ,
Jun 20, 2019

Copy link to clipboard

Copied

Hi there,

Just had the same problem understand that its best to build your site in a responsive design. However I have built a few sites using the DESKTOP | TABLET | PHONE options (www.stormflame.co.uk).

But found this js code that may help you out go to the following link to redirect your sites to mobile and tablet versions: Redirect to Mobile Website - SUPER Easy Tutorial - BJD.

I just opened the index code (desktop copy) in dreamweaver and replace this part of the code seen near the top of the page:

<script type="text/javascript">

   // Redirect to phone/tablet as necessary

......... ("desktop","tablet/index.html","phone/index.html");


with the code mentioned above in the link, along with the js script file thats connected to it.

It seems to work for me so i have a bit of time to re-build this site in a responsive format or choose something else to build it in. Let us know if this works for you?       

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2019 0
Adobe Community Professional ,
Jun 20, 2019

Copy link to clipboard

Copied

Make sure to test in all browsers and devices.  Unless you specifically disable it in your security settings, redirect scripts are ignored by Android Chrome.   It probably won't be long before other browsers do the same thing.

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2019 0
Explorer ,
Jun 23, 2019

Copy link to clipboard

Copied

SOLVED    FIXED     WORKS

ADD (copy) This code below,  to the master page properties (under Metadata tab) in the HTML for Head Text Area

<script type="text/javascript"><!--

var checkBrowser=navigator.userAgent.toLowerCase();var isAndroid=checkBrowser.indexOf('android')>-1;var isiPhone=checkBrowser.indexOf('iphone')>-1;var isiPod=checkBrowser.indexOf('ipod')>-1;var isiPad=checkBrowser.indexOf('ipad')>-1;var isMobile=checkBrowser.indexOf('mobile')>-1;if(isiPhone||isiPod){document.location="phone/index.html";}

if(isiPad){document.location="phone/index.html";}

if(isAndroid&&!isMobile){document.location="phone/index.html";}

if(isAndroid&&isMobile){document.location="phone/index.html";}

if(blackberry||opera||mini||palm||smartphone||iemobile){document.location="phone/index.html";}

if(xoom||playbook||tablet||kindle){document.location="phone/index.html";}</script>

THEN in the Main File goto File menu then Site Properties. under layout tab, use the layout drop down to go to the phone layout, then UNCHECK Redirect From Desktop checkbox. this gets rid of muse's redirect code and uses the javascript (above) on the master page. to do the redirect. WORKS!!!  yea........Boooooyyyy....!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2019 2
Community Beginner ,
Jun 25, 2019

Copy link to clipboard

Copied

Thanks!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2019 0
Community Beginner ,
Jun 26, 2019

Copy link to clipboard

Copied

Hi John,

Same as amplan1213, the solution in Android works well but in iphone won't, no matter if it's safari or chrome.

Thanks!!

error iphone.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2019 0
Explorer ,
Jun 26, 2019

Copy link to clipboard

Copied

SOLVED    FIXED     WORKS

ADD (copy) This code below,  to the master page properties (under Metadata tab) in the HTML for Head Text Area

<script type="text/javascript"><!--

var checkBrowser=navigator.userAgent.toLowerCase();var isAndroid=checkBrowser.indexOf('android')>-1;var isiPhone=checkBrowser.indexOf('iphone')>-1;var isiPod=checkBrowser.indexOf('ipod')>-1;var isiPad=checkBrowser.indexOf('ipad')>-1;var isMobile=checkBrowser.indexOf('mobile')>-1;if(isiPhone||isiPod){document.location="phone/index.html";}

if(isiPad){document.location="phone/index.html";}

if(isAndroid&&!isMobile){document.location="phone/index.html";}

if(isAndroid&&isMobile){document.location="phone/index.html";}

if(blackberry||opera||mini||palm||smartphone||iemobile){document.location="phone/index.htm l";}

if(xoom||playbook||tablet||kindle){document.location="phone/index.html";}</script>

THEN in the Main File goto File menu then Site Properties. under layout tab, use the layout drop down to go to the phone layout, then UNCHECK Redirect From Desktop checkbox. this gets rid of muse's redirect code and uses the javascript (above) on the master page. to do the redirect. WORKS!!!

In this line of code it had a space between the / and index if(isiPhone||isiPod){document.location="phone/ index.html";} 

Recopy the code above (It is Now Fixed) and Try Again,

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2019 2
Explorer ,
Jun 26, 2019

Copy link to clipboard

Copied

ALSO, that other code is just for Muse Desktop/Phone websites, If you are using Muse Desktop/Tablet/Phone websites.

This code below may be helpful. Use it INSTEAD of the other code.

<script type="text/javascript"><!--

var checkBrowser=navigator.userAgent.toLowerCase();var isAndroid=checkBrowser.indexOf('android')>-1;var isiPhone=checkBrowser.indexOf('iphone')>-1;var isiPod=checkBrowser.indexOf('ipod')>-1;var isiPad=checkBrowser.indexOf('ipad')>-1;var isMobile=checkBrowser.indexOf('mobile')>-1;if(isiPhone||isiPod){document.location="phone/index.html";}

if(isiPad){document.location="tablet/index.html";}

if(isAndroid&&!isMobile){document.location="tablet/index.html";}

if(isAndroid&&isMobile){document.location="phone/index.html";}

if(blackberry||opera||mini||palm||smartphone||iemobile){document.location="phone/index.htm l";}

if(xoom||playbook||tablet||kindle){document.location="tablet/index.html";}</script>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2019 2
Contributor ,
Jul 09, 2019

Copy link to clipboard

Copied

John, this worked for me! I had to uncheck the redirects on both phone and tablet for this to function properly.

Thanks for the code!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2019 0
Community Beginner ,
Jun 23, 2019

Copy link to clipboard

Copied

Now using John Vandervlugt's provided script as above, and it brings me back the Muse website on Chrome Mobile.

The site shows up again on the Android Phone and redirects to site.com/phone/index.html

Thank you so much for the solution you provide my Muse site. It is sincerely appreciated.

Muse had been an awesome journey.

Just getting started Webflow few days ago.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2019 0