Highlighted

Third party hosting rejects PHP 5.6

Community Beginner ,
Sep 17, 2018

Copy link to clipboard

Copied

A hosting party of a Muse website I made for a client 2 years ago (I recently updated it to the latest Muse version), has sent a warning that the website is using PHP 5.6 and that it should be updated to at least PHP 7.1.

Or else the website will not be supported anymore.

Is there anything I can do in Muse to update the PHP?

Thanks in advance.

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Winterbloesem  wrote

Is there anything I can do in Muse to update the PHP?

Unfortunately, no.    Muse is End of Life now.  It's no longer being updated.   You would have to change web hosts or downgrade your PHP to 5.6.   Given the large number of legacy sites that are still relying on older PHP code,  it should be an option for you.

Views

244

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Third party hosting rejects PHP 5.6

Community Beginner ,
Sep 17, 2018

Copy link to clipboard

Copied

A hosting party of a Muse website I made for a client 2 years ago (I recently updated it to the latest Muse version), has sent a warning that the website is using PHP 5.6 and that it should be updated to at least PHP 7.1.

Or else the website will not be supported anymore.

Is there anything I can do in Muse to update the PHP?

Thanks in advance.

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Winterbloesem  wrote

Is there anything I can do in Muse to update the PHP?

Unfortunately, no.    Muse is End of Life now.  It's no longer being updated.   You would have to change web hosts or downgrade your PHP to 5.6.   Given the large number of legacy sites that are still relying on older PHP code,  it should be an option for you.

Views

245

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 17, 2018 0
Adobe Community Professional ,
Sep 17, 2018

Copy link to clipboard

Copied

Winterbloesem  wrote

Is there anything I can do in Muse to update the PHP?

Unfortunately, no.    Muse is End of Life now.  It's no longer being updated.   You would have to change web hosts or downgrade your PHP to 5.6.   Given the large number of legacy sites that are still relying on older PHP code,  it should be an option for you.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2018 1
Adobe Community Professional ,
Sep 17, 2018

Copy link to clipboard

Copied

You don`t have to do anything in Muse. Simply upload the file once more if even necessary.

PHP is done from server side, on my side, having some sites from clients at 1&1 with php 7 or higher, there´s no issue at all with it.

No idea, why the answer from Nancy is marked as correct. Muse never had to be set up with php or anything-

It is more an overall warning from host companies, nothing special for muse sites.

Yes, muse is under EOL but not dead from one day to the other, even if some can`t wait to see it happen.

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2018 0
Community Beginner ,
Sep 17, 2018

Copy link to clipboard

Copied

Zo te zien bent u Nederlands- of -Vlaamstalig. Ik schakel even over. Het hostingbedrijf (mijnDomein) dreigt deze specifieke site offline te halen. Zie kopie van het bericht:

_______________________________________

Beste **,

Uit een scan blijkt dat je nog PHP 5.6 gebruikt voor je website(s). De ontwikkelaars van PHP 5.6 brengen geen updates meer uit voor deze versie. Je website(s) worden daardoor onveilig en dat heeft gevolgen voor jouw bezoekers en het webhostingplatform van Mijndomein. Daarom stopt de ondersteuning per 1 november 2018 voor PHP 5.6 bij Mijndomein.

Deze domein(en) van jou draaien nog op PHP 5.6:

www.coachgalerij.nl

Doe je niets, dan werken je websites na 1 november 2018 niet meer.

Zet daarom zo snel mogelijk jouw website(s) om naar PHP 7.1. Werkt je website op PHP 7.1 dan kan je proberen of je website ook werkt op PHP 7.2. Hoe nieuwer de versie, hoe sneller hij namelijk werkt.

In het artikel Overstappen van PHP 5.6 naar PHP 7.1 lees je precies hoe je overstapt.

_______________________________________

Zou het kunnen dat ze iets anders gevonden hebben wat onveilig is? Een andere 'third party hosting' waarschuwde mij eens voor onveilige formulieren. Blijkbaar zijn hosts niet blij met Muse sites.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2018 0
Adobe Community Professional ,
Sep 18, 2018

Copy link to clipboard

Copied

Now we need some coders here. As I said previously, there´s no way I know, how to handle php from MUSE side.

No setting in my mind to change. PHP is set from hosting company (I´m from Germany, BTW ).

1&1 for example, sets its server to php means, in the account settings, I change manually the php from 5 to 7 or higher.

I check the website, if everything is still in good shape and you should be pretty much done, I hope.

May I ask who´s the hosting company?

Some recommendations, try to change your hosting to get/use/setup from http to https in order to tell also google that your site is safe.

This has nothing to do with the php issue.

I also recommend to change your adaptive site to a responsive site. You could quite easily stick with the layout and still use fixed width breakpoints. Like this it may take little time for each page to add one breakpoint for tablet – copy and paste in place the content from tablet page to responsive page and do the same for mobile breakpoint. This simply for SEO reasons. This has nothing to do with the php issue.

Kind Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2018 1
Community Beginner ,
Sep 18, 2018

Copy link to clipboard

Copied

Thanks for your advices! The hosting company is mijndomein.nl, a Dutch one. Not my favourite, so I think all my clients who choose this host will have to move. Already found a host who wants to support my Muse websites 🙂

I am offering my clients new websites, made in a Dutch online webbuilder system for professionals. Easier for me than Muse, and with better support. So making their Muse websites better responsive with breakpoints is not my priority.

With kind regards,

Natasja

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2018 1
Adobe Community Professional ,
Sep 18, 2018

Copy link to clipboard

Copied

PHP 5.6 is Approaching its End of Life this Year.  

December 31, 2018 marks the official end of security support for PHP 5.6, this means there will be no further updates to the software. 

Script written in older PHP 5.6 may continue to work.  But owing to the deprecated features in PHP 7x, some scripts will fail.   The only way to know for sure is to test them.   If  your contact forms stop working, you would need to find other contact form scripts that are compatible with your server's PHP version.

PHP: Migrating from PHP 5.6.x to PHP 7.0.x - Manual

As far as I know, Muse is not updating contact form scripts to run on newer servers. 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2018 1
Community Beginner ,
Sep 19, 2018

Copy link to clipboard

Copied

Ok, so the Muse forms have PHP 5.6 script?

And If I delete the Muse forms, and use something like Jotform, there is no 5.6 script to be found in the website?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2018 0
Adobe Community Professional ,
Sep 19, 2018

Copy link to clipboard

Copied

I don't use Jotforms so I don't know what scripts they use.  But if you choose a 3rd party form service like Wufoo.com, all form processing is performed on their servers, not yours. 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 19, 2018 0