Highlighted

Trying to solve a problem with a 3rd party audio playlist widget

Explorer ,
Jun 24, 2017

Copy link to clipboard

Copied

Bought an audio playlist widget off the Adobe widgets directory from MuseTemplatesPro.com.

MuseTemplatesPro has no discussion forum.   They only have a support email address which I've contacted twice and received no reply after a month.

It appears that the problem may be related to the operating system.  On my mac desktop OS 10.11.6 the widget works fine. 

You click on a song and when that song is finished, the cursor moves to the next song, the image changes to the next song and the next song plays.  Each song plays consecutively and then the playlist starts from the top and continues.  This is the expected playlist behavior.

However on my mobile devices (iOS and a couple of Android devices) you click a song and when that song is finished, the cursor moves to the next song, the image changes to the next BUT the play progress bar immediately positions itself at the END of the song and the playlist stalls. 

As you can imagine this is an unacceptable experience for people who visit my site.  They want to start the playlist and not have to MANUALLY start each song in the list. 

I've tested this problem on both my hosted site and on business catalyst and the behavior is the same. 

Here is a page with one of my playlists if you want to try it out.

Everything Under the Sun

Anyone have any ideas or thoughts about what I might do to solve this?  Thanks.

Views

178

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Trying to solve a problem with a 3rd party audio playlist widget

Explorer ,
Jun 24, 2017

Copy link to clipboard

Copied

Bought an audio playlist widget off the Adobe widgets directory from MuseTemplatesPro.com.

MuseTemplatesPro has no discussion forum.   They only have a support email address which I've contacted twice and received no reply after a month.

It appears that the problem may be related to the operating system.  On my mac desktop OS 10.11.6 the widget works fine. 

You click on a song and when that song is finished, the cursor moves to the next song, the image changes to the next song and the next song plays.  Each song plays consecutively and then the playlist starts from the top and continues.  This is the expected playlist behavior.

However on my mobile devices (iOS and a couple of Android devices) you click a song and when that song is finished, the cursor moves to the next song, the image changes to the next BUT the play progress bar immediately positions itself at the END of the song and the playlist stalls. 

As you can imagine this is an unacceptable experience for people who visit my site.  They want to start the playlist and not have to MANUALLY start each song in the list. 

I've tested this problem on both my hosted site and on business catalyst and the behavior is the same. 

Here is a page with one of my playlists if you want to try it out.

Everything Under the Sun

Anyone have any ideas or thoughts about what I might do to solve this?  Thanks.

Views

179

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 24, 2017 0
Most Valuable Participant ,
Jun 24, 2017

Copy link to clipboard

Copied

my; windows 8.1 and 10 desktop + windows 8 and 8.1 phones = works as expected

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 24, 2017 1
Explorer ,
Jun 25, 2017

Copy link to clipboard

Copied

Thank you for checking. Glad to know it's not universal.

I've tested it on iPod Touch, iPhone 6, iPad mini3, and one of the newer LG phones and it fails to playout the list as described in OP.

I appreciate you taking the time to check it on your devices. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2017 0
Adobe Community Professional ,
Jun 25, 2017

Copy link to clipboard

Copied

On my Fairphone, Android works as intended and expected.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2017 1
Most Valuable Participant ,
Jun 25, 2017

Copy link to clipboard

Copied

starting to sound like its a device issue... ipads are notorious for blocking auto-download of mp3 files

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 25, 2017 1
Explorer ,
Jun 27, 2017

Copy link to clipboard

Copied

Looks like I'm going to have to hope that MuseTemplatesPro updates their code so it works with the Apple universe and other major Android phone manufacturers as well (such as the new LG I tested it on).

The MuseTemplatesPro website FAQ states:

Yes, all of our Templates are customized to look great on any screen (desktop, tablet or phone). All the Widgets work great with all the devices as well.

Very disappointing. 

I may have to look for a widget developer that provides better support. 

Thanks to all who took the time to check this issue on their device.  Glad to know that it's working on some of them.  Hope this discussion helps others who may be looking for a audio playlist widget.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 27, 2017 0