Highlighted

URGENT HELP: javaScript exception: Error calling selector function: SecurityError: Failed to read the 'rules' property from 'CSSStyleSheet': Cannot access rules

Community Beginner ,
Jan 28, 2018

Copy link to clipboard

Copied

Hi,

I have built a website with Muse.

It has been working well for the last month or so.

Have been updating it once in every 3 days.

I export the website as an HTML and use the AWS S3 for hosting.

After making a few changes today and adding a couple of inbuilt widgets like the "Simple Form" & "Thumbnail Slideshow."

I am receiving the error "javaScript exception: Error calling selector function: SecurityError: Failed to read the 'rules' property from 'CSSStyleSheet': Cannot access rules."

Please help me the website is live and the changes & additions are urgent.

I am a designer & using Muse for the first time.

Regards,

Nikhil

Correct answer by nikhil1161 | Community Beginner

Hi Guys,

Thank you so muc for the help.

Tried troubleshooting the site.
For some strange reason my inbuilt horizontal menu that i had been using for a while now, was causing this issue.Had to then remove it and create the menu manully.

I really feel, that Adobe Muse is not that finished a product and nit ready for commercial use at the moment.

There are way to many unnecessary bugs and random issues that pop up.

Views

13.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

URGENT HELP: javaScript exception: Error calling selector function: SecurityError: Failed to read the 'rules' property from 'CSSStyleSheet': Cannot access rules

Community Beginner ,
Jan 28, 2018

Copy link to clipboard

Copied

Hi,

I have built a website with Muse.

It has been working well for the last month or so.

Have been updating it once in every 3 days.

I export the website as an HTML and use the AWS S3 for hosting.

After making a few changes today and adding a couple of inbuilt widgets like the "Simple Form" & "Thumbnail Slideshow."

I am receiving the error "javaScript exception: Error calling selector function: SecurityError: Failed to read the 'rules' property from 'CSSStyleSheet': Cannot access rules."

Please help me the website is live and the changes & additions are urgent.

I am a designer & using Muse for the first time.

Regards,

Nikhil

Correct answer by nikhil1161 | Community Beginner

Hi Guys,

Thank you so muc for the help.

Tried troubleshooting the site.
For some strange reason my inbuilt horizontal menu that i had been using for a while now, was causing this issue.Had to then remove it and create the menu manully.

I really feel, that Adobe Muse is not that finished a product and nit ready for commercial use at the moment.

There are way to many unnecessary bugs and random issues that pop up.

Views

13.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 28, 2018 0
Participant ,
Jan 28, 2018

Copy link to clipboard

Copied

Hey, i also came across this issue today as well. I did realize that this was only happening when i open page from the exported files. Once you upload it to your hosting i didn't get that error any more.

weird.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2018 0
Most Valuable Participant ,
Jan 28, 2018

Copy link to clipboard

Copied

remove one form as a test

does the issue go away?

yes = post the site to Adobe bc (with the form) and test if the error happens there as well?

no = contact your host service and ask them to look at your settings

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2018 1
Community Beginner ,
Jan 28, 2018

Copy link to clipboard

Copied

Hi,

I am new to muse and to the coding bit of websites, therefore please pardon me if i do not understand any of your suggestions.

I have already published the website with Adobe BC, it works perfectly well.

This issue only occurs when i export the website as an HTML. This was working perfectly well till Friday.

I havent uploaded this website on to my server and checked, as the website is already live.

Also could you please elaborate on "remove one form as a test."

Regards,

Nikhil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2018 0
Adobe Employee ,
Jan 29, 2018

Copy link to clipboard

Copied

If you have a contact form on your site, try removing it, and then test it by uploading it to businesscatalyst. I think that is what was meant here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 0
New Here ,
Feb 07, 2018

Copy link to clipboard

Copied

I have restored a backup to our school site sturtstcs.sa.edu.au and still having the same problem.

JavaScript exception: Error calling selector function: SecurityError: Failed to read the 'rules' property from 'CSSStyleSheet': Cannot access rules.

We cannot use the IBE at all, although noticed that the phone pages can be modified.

There has been only text changes over the past few months to the site only via IBE nothing changed in the pages themselves via Muse.

What can be done to rectify this issue?

Could this be that because of a JavaScript update that the IBE now does not work as it did.

We have a Windows 7/ 10 platforms, use to work like a charm on Chrome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2018 0
Community Beginner ,
Feb 07, 2018

Copy link to clipboard

Copied

Hi,

I am an amateur to Muse.

But I think one of the widgets that you must have used might be causing this issue.

Previously the widgets might have worked properly, but somehow they must have gotten corrupted.

The same issue happened with me too.

For the first 2 months the site was perfectly exporting, one sudden day after making a few changes I had this error.

I would suggest, just delete each widget one by one and then priview the website in the browser.

Start with the menu widget, if you have one. In my case the menu widget was the culprit.

Hope this helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2018 0
Community Beginner ,
Jan 29, 2018

Copy link to clipboard

Copied

Hi Guys,

Thank you so muc for the help.

Tried troubleshooting the site.
For some strange reason my inbuilt horizontal menu that i had been using for a while now, was causing this issue.Had to then remove it and create the menu manully.

I really feel, that Adobe Muse is not that finished a product and nit ready for commercial use at the moment.

There are way to many unnecessary bugs and random issues that pop up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2018 1
Guide ,
Feb 07, 2018

Copy link to clipboard

Copied

After making a few changes today and adding a couple of inbuilt widgets like the "Simple Form" & "Thumbnail Slideshow."

I am receiving the error "javaScript exception: Error calling selector function: SecurityError: Failed to read the 'rules' property from 'CSSStyleSheet': Cannot access rules."

To be sure:

1) Do you get this error when adding a widget inside design mod in the Muse?

2) Is Windows your operating system?

If the answer to both questions is "Yes", just update the Internet Explorer to version 11

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2018 0
New Here ,
Feb 07, 2018

Copy link to clipboard

Copied

Hi Pavel,

Thanks for responding.

It is Windows 7 & 10 this is happening, it works with no issues on a MacBook Pro, I can edit and update and view and publish with no problems, this is happening only on a Windows environment at the school, where only a few days ago it was working fine.

I have done no mods or inserted widgets.

As mentioned when this happened we restored from backup when it was last working correctly and did not make any difference.

The browser is on the latest update of V11.

I hope that helps to resolve an answer.

Thank you.

Regards

Chris H.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2018 0
Guide ,
Feb 07, 2018

Copy link to clipboard

Copied

Hi, Chris. For you, I think the only solution can be if you provide the detailed characteristics of the machine on which the error occurs and the project file muse in Adobe support (for clarity - I'm not an Adobe support worker).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2018 0
Explorer ,
Feb 28, 2018

Copy link to clipboard

Copied

If you rename the index.html file to any other file name so index2.html, the web page loads fine

no idea why!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 28, 2018 2
Guide ,
Feb 28, 2018

Copy link to clipboard

Copied

The reason must be, that before you uploaded the site to the hosting, you did not remove the standard stub, which has the same name index.html.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 28, 2018 0
Explorer ,
Feb 28, 2018

Copy link to clipboard

Copied

There was no other file called index where it was exported from Muse. If I rename to index2 it works but as soon as it is renamed index, it fails to load and displays the error.

Never used to do this, is a very recent problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 28, 2018 1
New Here ,
Mar 01, 2018

Copy link to clipboard

Copied

This solves my problem too. Don't know what happens with the latest version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2018 0
Community Beginner ,
Mar 05, 2018

Copy link to clipboard

Copied

Dear Adobe,

Do you have any news regarding this issue? When it could be solbved?
I have the issue not with Chrom only, but with Opera as well.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 05, 2018 1