Web Font not Displaying

New Here ,
Mar 08, 2018 Mar 08, 2018

Copy link to clipboard

Copied

We have tested our website via business catalyst here> ABOUT and then we have uploaded on the back of our existing site to work out any bugs that we may have on the local host here>  ABOUT​. Please take a look at the fonts on both sites, the business catalyst is displaying as it should with web fonts roboto slab and open sans while the site on the local host is not and it is substituting fonts.  What am I missing here?

Thank you,

  Amy

Views

142

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Mar 09, 2018 Mar 09, 2018
Hey Amyw,I'm sorry you ran into trouble here.Typekit can be used locally, however, there are some necessary steps that if left out, will cause the fonts not to render.In order to use Typekit locally, you've got to: Be running a local server when testing your site in the browser. You can tell if you're running a local server by the URL of the local site. If it starts with: file:// then you are just viewing the local file in a browser and not running it from a local server.If the local URL starts ...

Likes

Translate

Translate
Adobe Community Professional ,
Mar 08, 2018 Mar 08, 2018

Copy link to clipboard

Copied

On your BC-site there´s code like this:

Bildschirmfoto 2018-03-08 um 21.59.15.png

The local host shows:

Bildschirmfoto 2018-03-08 um 21.59.46.png

Are you sure to have uploaded everything and the same on both hosts?

You could also delete the complete content from the local host (you may have a copy from it first) and reupload everything once more.

Best Regards,

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mar 09, 2018 Mar 09, 2018

Copy link to clipboard

Copied

LATEST

Hey Amyw,

I'm sorry you ran into trouble here.

Typekit can be used locally, however, there are some necessary steps that if left out, will cause the fonts not to render.

In order to use Typekit locally, you've got to:

  • Be running a local server when testing your site in the browser. You can tell if you're running a local server by the URL of the local site. If it starts with: file:// then you are just viewing the local file in a browser and not running it from a local server.

If the local URL starts with: http:// then you're running a local server.

  • The domain of your local server has to be part of the domain list in your Kit. So, if your local server uses: localhost, you'll need to add this to your Kit's domains.

I hope this helps. If you have any further questions, feel free to reach out to Typekit team directly: support@typekit.com

Cheers,

Ankush

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines