Highlighted

When using link to anchor point, site isn't centered in browser

Community Beginner ,
Oct 30, 2018

Copy link to clipboard

Copied

Hello,

I know this is something that has been asked before, but none of the offered solutions seemed to work for me. (centralizing the anchorpoints, sticking them to the lift of the width, X = 0, seperate layer, ... )

When I load my page just with a direct link, all is fine. But when i use a link to an anchorpoint on that page, it shifts to the left.

Because of the fact that my page loads perfectly when the anchorpoints aren't being used, I don't think anything on the page itself is wrong: nothing is out of the standard width, ...

The only I can imagine is the anchorpoints interacting with something that isn't right. And when the page is loaded from the top, the thing that isn't right has no influence on it. I really don't know.

Michiel​ If you load the page like this. It looks all fine.

Michiel If you load the page with the anchorpoint, it goes to the left of the browser.

On the page itself I have several lightbox widgets. When you open them to edit, they are out of my set width, but they all are closed when uploaded. (I don't know if this could be something).

Please help.

Thank you in advance!

Views

324

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

When using link to anchor point, site isn't centered in browser

Community Beginner ,
Oct 30, 2018

Copy link to clipboard

Copied

Hello,

I know this is something that has been asked before, but none of the offered solutions seemed to work for me. (centralizing the anchorpoints, sticking them to the lift of the width, X = 0, seperate layer, ... )

When I load my page just with a direct link, all is fine. But when i use a link to an anchorpoint on that page, it shifts to the left.

Because of the fact that my page loads perfectly when the anchorpoints aren't being used, I don't think anything on the page itself is wrong: nothing is out of the standard width, ...

The only I can imagine is the anchorpoints interacting with something that isn't right. And when the page is loaded from the top, the thing that isn't right has no influence on it. I really don't know.

Michiel​ If you load the page like this. It looks all fine.

Michiel If you load the page with the anchorpoint, it goes to the left of the browser.

On the page itself I have several lightbox widgets. When you open them to edit, they are out of my set width, but they all are closed when uploaded. (I don't know if this could be something).

Please help.

Thank you in advance!

Views

325

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 30, 2018 0
Community Beginner ,
Oct 31, 2018

Copy link to clipboard

Copied

So I have opened up every single lightbox widget and made sure that the big lightbox (the one that pops up when you click the button) of every widget is within the borders of my site. This does actually make a difference. My site loads as it should be, even when using anchor points.

My conclusion (for now): lightbox widgets their pop-up need to be within borders when using anchor points. They load perfectly fine when loading the page from the top.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 1
Community Beginner ,
Oct 31, 2018

Copy link to clipboard

Copied

I was wrong, it only helped on my big monitor. When I view the website on my laptop or half of my regular monitor, the problem is all back again. 😕

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 0
LEGEND ,
Oct 31, 2018

Copy link to clipboard

Copied

Browsers alway try, to position an anchor top left in the browser window, when you are jumping to it.

If the anchor isn’t placed at the left edge of your page, jumping to an anchor will cause the browser to shift.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 0
Community Beginner ,
Oct 31, 2018

Copy link to clipboard

Copied

Even when the anchor point is on the left edge at x=0 it doesn't work.

I've tried putting them in the center of the page. On the left against the egde, just outside attached to the left of the page. All had the same result.

I've blocked horizontal scrolling using html code and now it looks fine. I don't know what disadvantage this blocking will have.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 0
LEGEND ,
Oct 31, 2018

Copy link to clipboard

Copied

If this happens, the culprit is clearly your HTML code.

If your page is shifting horizontally, there is a layout issue, which you shouldn’t „cure“ by HTML code. Please refer to this document: https://forums.adobe.com/docs/DOC-8953

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 0
Adobe Community Professional ,
Oct 31, 2018

Copy link to clipboard

Copied

Hi michielb4020271 ,
can you please double check if you have any element outside of your page?  (maybe even a hidden one or something on a not visible layer perhaps).

Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 0
Community Beginner ,
Oct 31, 2018

Copy link to clipboard

Copied

Hi,

Thank you for your help.

I've checked using "select all", if something is out of bounce of every page and every master. I've opened every single lightbox and made sure that it is within the borders.

I only have one layer so nothing can be invisible due to a layer being unchecked.

I really don't know.

The things is that the misplacement only happens when using anchorpoint links and not when loading a page from the top.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 0
LEGEND ,
Oct 31, 2018

Copy link to clipboard

Copied

A „Select All“ isn’t enough by far! Did you look at the screencast I linked above?

And: Does your site shift horizontally  You only told us to use a HTML snippet, to avoid it.

Could you please

  • delete all pages of your site except one, which demonstrates your issue,
  • delete all unrelated page elements,
  • save this small(!!) .muse file under a new name,
  • upload it to Dropbox or a similar file sharing service and
  • post the download link here.

Then we will have a closer look.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 1
Community Beginner ,
Oct 31, 2018

Copy link to clipboard

Copied

Hi,

Thank you for your interest in my issue. I’ll have another look at the thread you provided one more time and I’ll inspect my file again. If this does not help, i’ll share a file using dropbox. It will probably be Friday when I respond.

Thank you in advance and again

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 0