Highlighted

Why is my Contact Form not sending emails?

Community Beginner ,
Jun 17, 2017

Copy link to clipboard

Copied

Hi, having trouble with an Adobe Muse Contact Form – as seems to be common on the forums – but not yet seen a solution. Please don't direct me to the trouble shooting page which seems to be the default and unhelpful answer.

My form is on a site, obviously built in Muse, and the form created from the Contact Form Widget. I've included a reCAPTCHA form also (although have tested without this included so know this is not causing any issues). The email address I'm trying to have form submissions sent to ends the same as my website address e.g. 'eaxmple@mysite.com' and 'ww.mysite.com'. The site itself is hosted by 123-reg.co.uk.

Everything enters into the form OK, and I have a form submitted conformation but no email is ever received. As per other posts I have tried adding an extra forwarding email address and this also doesn't work. I have even tried using an outlook address and again no joy. Plus nothing in any junk/spam folders.

I'd really like to find a solution to this so proper contact forms can be added to my own and my clients websites in future.

Thanks in advance for any help.

Thanks for the offer.

Just uploaded to BC for free and form works there. So I'm guessing that means it's a conflict with my host 123-reg.

Views

831

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Why is my Contact Form not sending emails?

Community Beginner ,
Jun 17, 2017

Copy link to clipboard

Copied

Hi, having trouble with an Adobe Muse Contact Form – as seems to be common on the forums – but not yet seen a solution. Please don't direct me to the trouble shooting page which seems to be the default and unhelpful answer.

My form is on a site, obviously built in Muse, and the form created from the Contact Form Widget. I've included a reCAPTCHA form also (although have tested without this included so know this is not causing any issues). The email address I'm trying to have form submissions sent to ends the same as my website address e.g. 'eaxmple@mysite.com' and 'ww.mysite.com'. The site itself is hosted by 123-reg.co.uk.

Everything enters into the form OK, and I have a form submitted conformation but no email is ever received. As per other posts I have tried adding an extra forwarding email address and this also doesn't work. I have even tried using an outlook address and again no joy. Plus nothing in any junk/spam folders.

I'd really like to find a solution to this so proper contact forms can be added to my own and my clients websites in future.

Thanks in advance for any help.

Thanks for the offer.

Just uploaded to BC for free and form works there. So I'm guessing that means it's a conflict with my host 123-reg.

Views

832

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 17, 2017 0
Adobe Community Professional ,
Jun 17, 2017

Copy link to clipboard

Copied

Re: muse form not sending mail to 123-reg email address (e.g. name@mydomain.co.uk)???

Did you already check with this:  http://my-site.com/scripts/form_check.php

This was an advice from Gaurav.SharmaGaurav.SharmaGaurav.SharmaGaurav.Sharma in this thread.

I read something, that 123 is not really the best with forms-support-sending emails correctly.

But maybe in the meantime this changed to the better?

Uwe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2017 1
Community Beginner ,
Jun 17, 2017

Copy link to clipboard

Copied

Hi, yes I have tried the script check mentioned above and it says all is fine on that front

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2017 0
Most Valuable Participant ,
Jun 17, 2017

Copy link to clipboard

Copied

if you don't want to give us details then thats your choice however we cann't help without them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2017 0
Community Beginner ,
Jun 17, 2017

Copy link to clipboard

Copied

Ussnoreay what other details do you need?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2017 0
Most Valuable Participant ,
Jun 19, 2017

Copy link to clipboard

Copied

sorry i missed this somehow... the first step I would try now is adding | using an email address I know works so something@hotmail.com then I would change the CAPTCHA to CAPTCHA 2 so google is happy with it.

if that fails your next step is to comfirm it is the host server making the issue and that is done by hosting the site elsewhere... I use Adobe BC but you would really need to launch the site fully for this test and give it a day or so the catch up

p.s, hotmail is US based so 'name' 'email' and 'message' are all required fields

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2017 1
Community Beginner ,
Jun 19, 2017

Copy link to clipboard

Copied

Thanks for reply. Already tried working email addresses and on CAPTCHA v2.

Will have to try your host suggestion. Will I have to pay to use Adobe BC even just to test?

Cheers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2017 0
Most Valuable Participant ,
Jun 19, 2017

Copy link to clipboard

Copied

riche39467331  wrote

Will I have to pay to use Adobe BC even just to test?

Cheers

a test site on Adobe BC is free for people with an Adobe id linked to Muse... however test sites don't allow google or certain email options and you have to launch a site for that.

If you would like me to see a copy of your .muse file for testing... strip it back to just the email form or whatever needs fixing and share it

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2017 0
Community Beginner ,
Jun 20, 2017

Copy link to clipboard

Copied

Thanks for the offer.

Just uploaded to BC for free and form works there. So I'm guessing that means it's a conflict with my host 123-reg.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2017 0
Most Valuable Participant ,
Jun 20, 2017

Copy link to clipboard

Copied

mystery sloved

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2017 0
Adobe Employee ,
Jun 20, 2017

Copy link to clipboard

Copied

Please contact your hosting provider to resolve the issue. Verify that they have the correct version of PHP required for Muse.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 20, 2017 0
Community Beginner ,
Jun 21, 2017

Copy link to clipboard

Copied

Ok so I have had this from my hosting provider...

"I have added a mailtest.php file at http://richevansdesign.co.uk/mailtest.php with the 'from' address test@richevansdesign.co.uk and the 'to' address our testing mailbox (noreply@webcup.co.uk).

All test emails are successfully sent when the http://richevansdesign.co.uk/mailtest.php link is accessed, you can test this yourself by replacing the 'to' address with one that you have access to and test the file yourself."

So can anyone tell me how I go about amended my Muse file for it to work? Please  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2017 0
Community Beginner ,
Jun 21, 2017

Copy link to clipboard

Copied

What I mean below is why is their php file working but the Muse created one not? Is this to do with their PHP settings?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2017 0