Highlighted

Can't install the build on iOS (iPhone)

Community Beginner ,
Dec 22, 2016

Copy link to clipboard

Copied

I was going to test some changes on the iPhone, and I used my standard approach:

- uploaded the archive with the code to build.phonegap.com

- built the app

- used the QR code to install the app

However, the app was not installed (with no specific error, just "can't install the app" or something like that).

I rolled back to the previous config.xml and the previous app code, but it still doesn't work.

Any idea on what can cause that? And how to debug that?

It runs just fine on Android.

OK, I found the solution here: cordova iOS. how to change minimum deployment version? - Stack Overflow

This setting worked for me:

<preference name="deployment-target" value="7.1.2" />

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Can't install the build on iOS (iPhone)

Community Beginner ,
Dec 22, 2016

Copy link to clipboard

Copied

I was going to test some changes on the iPhone, and I used my standard approach:

- uploaded the archive with the code to build.phonegap.com

- built the app

- used the QR code to install the app

However, the app was not installed (with no specific error, just "can't install the app" or something like that).

I rolled back to the previous config.xml and the previous app code, but it still doesn't work.

Any idea on what can cause that? And how to debug that?

It runs just fine on Android.

OK, I found the solution here: cordova iOS. how to change minimum deployment version? - Stack Overflow

This setting worked for me:

<preference name="deployment-target" value="7.1.2" />

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Advisor ,
Dec 22, 2016

Copy link to clipboard

Copied

Did you sign it with a development certificate? And was that cert still valid (not expired)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 22, 2016

Copy link to clipboard

Copied

Yes, it's signed with the dev certificate (the same that I used before, when it worked). And yes, it's still valid.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Dec 22, 2016

Copy link to clipboard

Copied

Sorry, have to ask: is it a device which is included in the mobileprovision file?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 22, 2016

Copy link to clipboard

Copied

Yes. As I wrote - it worked before with the same cert. So everything seems to be the same, except for the build.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Dec 22, 2016

Copy link to clipboard

Copied

In that case I would suggest trying to install the ipa file using iTunes. Perhaps something is going wrong when scanning the QR code.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 22, 2016

Copy link to clipboard

Copied

Tried that. iTunes says that newer version of iOS is required to install the app.

What exactly does affect this on PhoneGap Build end? How can I specify the minimal supported version?

On the app page I see the following info:

PhoneGap (iOS / Android / Windows)
cli-6.3.0 (4.2.0 / 5.2.1 / 4.4.1)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advisor ,
Dec 22, 2016

Copy link to clipboard

Copied

Since Nov. 2015(!) you need at least iOS 8.0 on your device.

What iOS version are you running?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 22, 2016

Copy link to clipboard

Copied

I think it's iOS 7.0 (iPhone 4), and it worked perfectly with the build from a couple of weeks ago.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 22, 2016

Copy link to clipboard

Copied

OK, I found the solution here: cordova iOS. how to change minimum deployment version? - Stack Overflow

This setting worked for me:

<preference name="deployment-target" value="7.1.2" />

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Great news! 🙂 So it means we can still use our iPhone 4 for testing apps built with Phonegap Build? 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...