• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
4

P: "Program Error" when duplicating layer.

Explorer ,
Apr 30, 2024 Apr 30, 2024

Copy link to clipboard

Copied

When I select "duplicate" layer I get "

Could not complete your request because of a program error."  In fact when I right click to select anything in that right column I get that.   Happened after the Beta updated last night.

Bug Acknowledged
TOPICS
Desktop-macOS

Views

159

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , May 02, 2024 May 02, 2024

Thank you all, we have passed this on to the team to investigate.

 

Thanks,

Cory - Photoshop Product Manager

Status Acknowledged

Votes

Translate

Translate
12 Comments
Explorer ,
Apr 30, 2024 Apr 30, 2024

Copy link to clipboard

Copied

If anyone resolves this let me know, I'm going over to PS 24 until an update happens.  @CoryShubert I'm looking at you!  And I miss talking to you!  -tracy

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 01, 2024 May 01, 2024

Copy link to clipboard

Copied

After uploading an image (jpg) from Bridge to PS Beta (latest version), before editing I usually duplicate the background layer and work on that. However, when I right click on the background layer to enable me to duplicate it I get the message 'Could not complete your request because of a background error'. There is a button to click on to find a fix but the methods are far to complex for me. The problem is only with Beta.  I have sorted my own fix which is to select all (i.e. the background layer) and copy to a new layer and hey presto everything works fine again, I can now right click on the background layer as normal.  I shouldn't have to fix it, it needs sorting.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 01, 2024 May 01, 2024

Copy link to clipboard

Copied

Hi @Shy Radar 

 

Try resetting Prefs for the Beta:
/Users/yourname/Library/Preferences/ Photoshop Beta Settings (Mac Ventura)
/Users/yourname/Library/Preferences/Adobe\ Photoshop\ \(Beta\)\ Settings (Mac)


C:\Users\user name\AppData\Roaming\Adobe\Adobe Photoshop (Beta)\Adobe Photoshop (Beta) Settings )Win)
Launch BETA Photoshop While Pressing The Keyboard Shortcut
With Photoshop closed, press and hold Shift+Ctrl+Alt (Win) / Shift+Command+Option (Mac) on your keyboard and then Launch Photoshop the way you normally would.
https://helpx.adobe.com/photoshop/using/preferences.html#Manually  

 

Thanks,

Cory - Photoshop Product Manager

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 01, 2024 May 01, 2024

Copy link to clipboard

Copied

Ha ha @tracypage you found me!!!  We are seeing some issues and the team is looking into it. Was the error you saw a 142 one?

 

And to be sure, you have the latest Ps beta: Adobe Photoshop Version: 25.9.0 20240428.m.2603 2d135fa arm64?

 

Thanks,

Cory - Photoshop Product Manager

Votes

Translate

Translate

Report

Report
Explorer ,
May 01, 2024 May 01, 2024

Copy link to clipboard

Copied

Hi Cory!  Yes, I just checked the version number and it was 25.9 m2603 that updated overnight 2 nights ago now and it says it is the most current version. It doesn't say 142, I'm attaching it.  Screen Shot 2024-05-01 at 8.14.18 PM.png

Votes

Translate

Translate

Report

Report
Explorer ,
May 01, 2024 May 01, 2024

Copy link to clipboard

Copied

I thought at first it was because it was an image from a prototype lens so I opened other images with known lenses, closed PS Beta and reopened and then tried rebooting still using other images, all with the same result. 

Votes

Translate

Translate

Report

Report
Community Beginner ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

[Photoshop (Beta) 25.9.0] Cannot open layer context menu when more than one locally-stored images is open

 

Seems to only happen when I have multiple locally-stored images open at the same time.

 

  • When only one image is open, error does not happen.
  • When images are stored in the cloud, error does not happen.
  • Images must be flattened.  Does not appear to affect multi-layered images.

 

To reproduce:

1 - Open Photoshop (Beta) 25.9.0

2 - Open 2 or more locally-stored images in PS

3 - In either image, right click on the Background layer in the Layers panel

 

Expected resut:  Layers context menu is displayed

 

Actual result:  "Could not complete your request because of a program error.  OK/Learn how to fix" dialog box is displayed.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

Thank you all, we have passed this on to the team to investigate.

 

Thanks,

Cory - Photoshop Product Manager

Status Acknowledged

Votes

Translate

Translate

Report

Report
Explorer ,
May 02, 2024 May 02, 2024

Copy link to clipboard

Copied

Cory - good point, my images are stored locally on my drive and not on the cloud.  In case that makes a difference when they are investigating this and trying to duplicate the error.  

Votes

Translate

Translate

Report

Report
New Here ,
May 04, 2024 May 04, 2024

Copy link to clipboard

Copied

I am having the same issue with Photoshop Beta.  I keep getting the Program Error message when right-clicking to duplicate layer.  The only workaround I have found is to make a new layer with the little icon.  Then I can duplicate background and trash the extra layer.   As said above, I shouldn't have to do this workaround - I never have until today, and it upgraded at logon, so I'm assuming it's in the last update.  Very annoying.

Votes

Translate

Translate

Report

Report
Engaged ,
May 05, 2024 May 05, 2024

Copy link to clipboard

Copied

Have the same problem. Tried your solution - which works fine, without having to go through all the trouble od resetting preferences 

Votes

Translate

Translate

Report

Report
New Here ,
May 06, 2024 May 06, 2024

Copy link to clipboard

Copied

LATEST

Same issue here. Just use Ctrl + J to duplicate background layer and skip the problem. Saves you having to delete extra layer.

Votes

Translate

Translate

Report

Report