• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
8

Files saved for web have the temporary attribute (Ps beta)

Explorer ,
Aug 26, 2023 Aug 26, 2023

Copy link to clipboard

Copied

I'm using Photoshop Beta 25.0 on Windows. When I export an image for web I usually do this by using the "web sharpen" feature of Tony Kuypers TK9 panel. No issues in the latest non-beta version. Was the plugin does is basically a bit of resizing and sharpening and then savin as jpeg. 

 

When I use this feature in the latest Beta 25.0 the exported jpeg seems to be always saved with two file system attributes A and T. The "T" attribute means "temporary" and makes problems. Because of the "temporary" attribute my NAS drive sync client ignores the file because it doesn't sync temporary files. This breaks my export workflow.

 

This didn't ever happen in the past productive versions so I think it might be a problem with  the beta.

TOPICS
Desktop-Windows

Views

1.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Nov 09, 2023 Nov 09, 2023

A current workaround is to use “Legacy Export As
It does not seem to apply that attribute in Export As or Quick Export.

Capture.JPG

 

Votes

Translate

Translate
Explorer ,
Oct 11, 2023 Oct 11, 2023

Copy link to clipboard

Copied

So we have noticed this happen to our JPEGs too. These were saved using "Save As A Copy", on the full release of Photoshop 25.0

It's completely random whether it happens or not, and it's totally infuriating when it does, as it means the files aren't picked up by Microsoft's DFS for relicating between  our servers.

Anybody at Adobe that knows why this is happening?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 24, 2023 Oct 24, 2023

Copy link to clipboard

Copied

We also have this problem. Users save images as JPGs and most (but also randomly) are saved with unsearchable AT attributes. Cannot figure out why, but this is a HUGE pain. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 25, 2023 Oct 25, 2023

Copy link to clipboard

Copied

Encountered this problem today and also found it to be totally random on it happening. First thought was photoshop AI generated content being placed into the image was the cause, but not proven. 

Easiest fix was to download a small utility named bulkfilechanger which allows amending the file attributes from "AT" back to "A". The files then became included in search results. Drop all the files in and it will show a list of the attributes which can then be changed en masse.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 06, 2023 Nov 06, 2023

Copy link to clipboard

Copied

I already reported this for the beta version of 25.0 but got no response from Adobe. The problem is now in the productive version of photoshop 2024 (25.1) and also in the beta version (25.2)

 

When I export an image for web it seems to be always saved with two file system attributes A and T. The "T" attribute means "temporary" and makes problems. Because of the "temporary" attribute my NAS drive sync client ignores the file because it doesn't sync temporary files. This breaks my export workflow.

 

Since the issue is now in beta and productive version I can't export images the way I used to. This is critical.

 

I tested this with "export as" and "Save for web (legacy). Both resulted in the faulty T attribute on the exported jpgs.

 

nicokaiser_0-1699297155138.png

 

 

Hier is the link to the original report in the beta discussion.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

I only just saw this now, aopolgies for creating a duplicate report here: https://community.adobe.com/t5/photoshop-ecosystem-bugs/some-files-saved-as-jpeg-have-temporary-attr...

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

Recently, I have found that some JPEG files generated by Photoshop - generally all those with AI-generated content - are saved with the Windows "Temporary" attribute set. This is a major issue as it inhibits some types of "cloud sync" and can even result in the files not being listed in directory searches, also it is not easy to clear this attribute. Please correct this as soon as possible.

 

Steps to reproduce:

1. Open the attached file below (NB not specific to this file, just an example) with Photoshop (25.1.0 release)

2. Select a rectangular area somewhere

3. Click "Generative Fill", type "Radio", click "Generate" and choose the first option

4. Select File->Export and save in JPG format. (File->Save as copy exhibits the same behaviour)

5. Navigate to where the file is stored in Windows Explorer, right-click and select "Properties". Scroll down to see "Attributes" and observe that these include "T".

 

Filter_Narrow.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

Not sure it's a bug.

 

All AI-generated content is automatically tagged to ensure it's traceable, so that you cannot pass AI content off as authentic photographs or artwork. This tagging is tamper proof.

 

https://helpx.adobe.com/creative-cloud/help/content-credentials.html 

"Content Credentials indicating the use of generative AI tools will be included with all content generated with Adobe Firefly to help promote transparency around the use of generative AI".

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

@nigelh72856175 @glasscanvas1 This isnt a bug. Photoshop workflows do not support saving directly to a network or cloud-sync service. The issue is your cloud sync service is trying to sync while PS is saving or creating temp files so it's syncing the temp files. Work locally then transfer to your cloud service of choice for backup.

https://helpx.adobe.com/photoshop/kb/networks-removable-media-photoshop.html

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Photoshop does not not support saving to a network? Really? Even though it's been doing that absolutely fine for 30 plus years? It's clearly a bug as it's only just recently started to happen. It is also just happening to JPEGs, no other format. The PSD files can be enormous, the JPEGs tiny, they take fractions of a second to save.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

@glasscanvas1 it hasnt been doing fine for 30 years contrary to your assertion. If this is a recent issue, check with your IT and other configs to see if something has changed externally. There is nothing you can change/control on the Photoshop side of things to prevent this from happening with servers or synced cloud storage.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Had you bothered to read either https://community.adobe.com/t5/photoshop-ecosystem-bugs/save-for-web-writes-file-with-at-attributes-... or https://community.adobe.com/t5/photoshop-ecosystem-bugs/some-files-saved-as-jpeg-have-temporary-attr... you would see that it first started to happen with the beta of PS v25.0, and carried over into the full release and 25.1 too.

This is nothing to do with the file saving incorrectly, it's to do with JPEGs being actively tagged with a Tempoary file attribute (also covered in these posts).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

@glasscanvas1 I merged those posts and sent to the team for review. More details make the difference. Your issue is similar but the other posters mention using Save for Web while you are using Save As features.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

Excellent, thank-you! Hopefully we'll all hear back from a developer why they added this behaviour, I'm guessing it was inadvertent.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 08, 2023 Nov 08, 2023

Copy link to clipboard

Copied

@glasscanvas1 at this point unsure but the common denominator is every poster is saving to a Windows server directly. What happens if you save direct to local do you still get the same "T" issue?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

@kevin stohlmeyerSaving locally also randomly adds the temporary attribute causind the same issue. It all started with the latest stable update.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

@CilentCipha Did you see the response from Daniel? Set your export to use legacy.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2023 Nov 14, 2023

Copy link to clipboard

Copied

Yes, I saw it and we're doing it at the moment, but it's really important Adobe fixes this asap. we have a lot of automations relying on save for web function.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 09, 2023 Nov 09, 2023

Copy link to clipboard

Copied

A current workaround is to use “Legacy Export As
It does not seem to apply that attribute in Export As or Quick Export.

Capture.JPG

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 11, 2023 Dec 11, 2023

Copy link to clipboard

Copied

@Daniel Presedo 

Can you pin your post?

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 13, 2023 Dec 13, 2023

Copy link to clipboard

Copied

Hi Daniel,

Any progress on getting this fixed?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

I've made a post concerning this in the full release bug forums here: https://community.adobe.com/t5/photoshop-ecosystem-bugs/some-files-saved-as-jpeg-have-temporary-attr...

Perhaps everyone could go and upvote/bump it so Adobe sees?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 07, 2023 Nov 07, 2023

Copy link to clipboard

Copied

I already created such a bug report yesterday. Please upvote this instead (and maybe delete the duplicate then?)


 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines