Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Image Processor won't close images

0 Votes
New Here ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Photoshop CC2022 Image Processor won't close images after completing action

Bug Unresolved
TOPICS
Actions and scripting, Windows

Views

102

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
13 Comments
Adobe Employee ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Can you attach a screen a screen shot of your image processor settings? Are you running an action within Image Processor? Does it leave all images open or only some images?


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

IP settings.jpgScript Alert.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

I do run an action within Image Processor. It saves files to the destination folder but leaves all the images open

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Does it happen for all images you run on? (do you have the same problem with JPEG or TIFF as you do with DNG) If you run Image Processor without the action, do the images close normally? 

 

I'm trying to determine if it's the action or something about these files that it causing the problem, or a combination of both.

Might need a copy of the action and/or the a few of the files to reproduce and debug.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

I'm opening JPEGs and saving to JPEGs
Image Processor runs normally without any actions and with different actions. This particular action contains 2 java scripts

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

It used to work fine running the same action (with 2 scripts) in CC2021

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Ok. We'll probably need the action + javascripts to debug.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

https://we.tl/t-Ywkf9G0BtQ 

Link to the action. I've deleted steps with jascripts and the behavior is still the same (it doesn't close files when Image p[rocessr runs this action)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Ok, I've tried running Image Processor with this Action in PS 2022, 2021 and 2019 and they all give an error that I couldn't process the selected files and leaves the files open. Do you recall what version you were running this action in prior where the files weren't left open and you didn't get an error?


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

CC 2021 latest update if I recall correctly

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

https://we.tl/t-sOXiC1jlUp 

I've checked my actions archive I was using different one. It runs just fine (I've attached the link). I modified it at the end a bit

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

Are you saying it's now working fine for you? (e.g. no issue?)


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2021 Nov 22, 2021

Copy link to clipboard

Copied

LATEST

No the bug still persits.
I used to run shorter version of the action in Image Processor (IP) it was fine. Then I modified the action and the bug appeared
Could it be there's a limit for length of the action in IP? Or creation of additional alpha channels? Or you're not suppose to use some functions like apply image in the action run in IP?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines