P: Advance Blending mode causes Crashing

1 Vote
LEGEND ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

If I set Advanced Blending mode to Knockout: Shallow or Deep, then set the layer fill to 0% it causes the program to crash. I updated to 21.0.3 and the same issue occurs.

I was following this tutorial: https://clicks.aweber.com/y/ct/?l=Bln2a&m=3hbVhYaHjsxrHbi&b=76PRgZMW1A2uuZhqpZIQfw

Bug Fixed
TOPICS
macOS , Windows

Views

198

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 26, 2021 Nov 26, 2021
This was fixed in 21.2.1.

Votes

Translate

Translate
8 Comments
Adobe Community Professional ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

What have you done for trouble-shooting so far? 

Restoring Preferences after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved might be a good starting point:

https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html


Does turning off »Use Graphics Processor« in the Performance Preferences (Photoshop > Preferences > Performance > Graphic Processor Settings) and restarting Photoshop have any bearing on the issue? 
And the same for turning on Photoshop > Preferences > Performance > Legacy Compositing? 

Votes

Translate

Translate

Report

Report
LEGEND ,
Feb 04, 2020 Feb 04, 2020

Copy link to clipboard

Copied

It might also help if you said what OS you're using. I'm on Mac running Mojave, and I'm unable with several efforts to get it to crash. If what Christoph says doesn't help any,  if you also include a screenshot of your layers before you use Advanced Blending, with the layer targeted, it might help us spot if anything isn't quite right.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 05, 2020 Feb 05, 2020

Copy link to clipboard

Copied

I found your crash log. Thanks for submitting. I may have some additional questions after discussing with engineering.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Feb 05, 2020 Feb 05, 2020

Copy link to clipboard

Copied

If you go to Preferences > Performance... and check "Legacy Compositing" does it work without crash?

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
New Here ,
Feb 05, 2020 Feb 05, 2020

Copy link to clipboard

Copied

Hi Elizabeth,
I am trying to reproduce the crash you are describing.  Can I email you the file I'm work with, and you can try opening this file and changing the "Knockout" layer fill opacity from 100% to 0%?

Andrew

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 26, 2020 Jun 26, 2020

Copy link to clipboard

Copied

Just wanted to let you all know that I had the same problem.  I use Windows 10 on a PC. When I changed the preferences to 'Legacy Compositing' as described above, the crash was eliminated. 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 26, 2020 Jun 26, 2020

Copy link to clipboard

Copied

Hi Anna, Can you please submit your Crash Reports along with your email address: https://helpx.adobe.com/photoshop/kb/submit-crash-reports.html We're trying to confirm you're seeing the same issue with 21.2

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 26, 2021 Nov 26, 2021

Copy link to clipboard

Copied

LATEST

This was fixed in 21.2.1.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report