P: After latest update, "select and mask" tool gives program error

15 Votes
Community Beginner ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

After the Photoshop CC 2018 update, I am getting "Could not apply the workspace because of a program error" after clicking "select and mask" button. Before update, it worked perfectly. Have somebody same problem?
RackMultipart201710193961114lx-df92a4eb-48da-4b49-89e7-b941e95d674a-1292889587.pngRackMultipart201710193961114lx-df92a4eb-48da-4b49-89e7-b941e95d674a-1292889587.png

Bug Fixed
TOPICS
macOS

Views

13

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 22, 2018 Jan 22, 2018
This issue should be fixed by the Photoshop CC 2018 (19.1) update that was released today.

Votes

Translate

Translate
59 Comments
Adobe Employee ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Hi David,

Sorry for the Program Error with Select and Mask. Program errors can be finicky, and at times restoring the preferences to the default state can be a fix for errors like this. Have you tried that yet?

Reset Photoshop preferences: https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html#prefs

Give that a try and let us know if it resolves it for you. 

Regards
Pete

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Hi Pete, thank you for quick reply. I tried reseting preferences and it helped. Now it seems select and mask is working again 🙂 Thank you!

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Its happened by me too, but only effects big files, like tiff, small ones , like jpeg are working normal. tryed with and without graphicprocessor

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Awesome, thanks for the update David -- Glad that worked, and I hope it sticks. Let us know if it comes back!

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Does the preference reset (mentioned above) help for your larger images Andi?

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

yes , just i tried, and now it looks fine, thanks a lot from Germany 😉

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

Bad luck, today morning after Restart the problem appear again, same like before 😞

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 21, 2017 Oct 21, 2017

Copy link to clipboard

Copied

After editing few photos, I get same error message 😞 I must find a way how to install older version which worked perfectly

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Hi David,

Do you have a channel selected when you attempt the Select and Mask?

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Hello Hannah, yes I have selected channel. Now it seems error occurs only sometimes.

At first, I selected object with quick selection tool. Then I clicked "select and mask" button and get error "Could not apply the workspace because of a program error".

Then I tried to select object manually with lasso tool and now "select and mask" works even with combination with quick selection tool.

Is there any way to get more specific information about errors in photoshop? I want to give more information, but don't know how 😞

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

And sometimes error occurs every time 😞 I have lot of photos to edit, so I am forced to use older version of Photoshop, which works fine.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

We have had other user reports of program errors related to selecting channels and then getting a program error with select and mask. If a channel is selected in the channels panel, the command "Select and Mask" should be grayed out because one cannot do anything to a channel with this command. We're aware of it and engineering is looking into it, but in the meanwhile you will likely run into program errors if you attempt to use select and mask with channels.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

As far as getting more information, thanks for the help! It's always nice to receive error reports so if you are prompted we appreciate you sending them.

You can also download the log collector here: 
https://helpx.adobe.com/creative-cloud/kb/cc-log-collector.html

That will create a file that helps us troubleshoot your problem.

Thanks! 🙂 
Hannah

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 24, 2017 Oct 24, 2017

Copy link to clipboard

Copied

It has happened to me as well. If I do a select all, I do not get the error, but anything less gives this error. I tried using different selection tools and the same. I upgraded my Graphics Driver and reset preferences. I tried turning off Graphics Acceleration to no avail. The OpenCL was unchecked which what some on the web were saying to do. 

Also, I do not have any channels selected. It seems to work OK on JPEG's but not on Tiffs or PSD or Raw files (Canon CR2 or Nikon NEF). 

I am running Windows 10

Tom

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

If I switch to 8-bit it works OK, but not 16 or 32-bit

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Getting same error, on my sony raw files, switched to 8bit as mentioned above and it works... cc 17 worked great

macbook pro

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Which version of Photoshop are you running, Thomas?

Votes

Translate

Translate

Report

Report
Contributor ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Same error here.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Same error here plus weird mask patterned artifacting

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Same error here. Last version worked fine

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

We're trying to reproduce the error on our end but it isn't happening with the test files we have used.

Anyone who is getting this error, would you share a file that is encountering the error? It would also be helpful to include the steps you took before it happened.

Thank you!
Hannah

Votes

Translate

Translate

Report

Report
Contributor ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

This happens on start of the program with every file, whether opened from a raw Lightroom export, or a new document when initiating select & mask via shortcut or file menu on a selection.
Select & mask works as expected when initiated from an existing mask.

Votes

Translate

Translate

Report

Report
Contributor ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Think I found a solve literally right after I posted....
For kicks I unchecked "remember settings" in the select & mask dialogue, hit ok, now it appears to be functioning normally. I turned "remember settings" back on and it is still continuing to function normally.
So, for me, "remember settings" was causing the issue, but works after unchecking, hitting ok, and reapplying.

Votes

Translate

Translate

Report

Report
Contributor ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Think I found a solve literally right after I posted....


For kicks I unchecked "remember settings" in the select & mask dialogue, hit ok, now it appears to be functioning normally. I turned "remember settings" back on and it is still continuing to function normally.
So, for me, "remember settings" was causing the issue, but works after unchecking, hitting ok, and reapplying.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Same here, my very first run after the update I opened a raw file from lightroom export, used the select and mask tool loaded right up and worked fine. Finished that file opened up a second raw file from the same session and upon my second attempt to run the select and mask tool it threw the error and continued to do so there after. Switch to 8bit it works, or uncheck remember settings it works.  

Votes

Translate

Translate

Report

Report