Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Blend If functionality on Groups is broken / missing

2 Votes
Participant ,
Jan 03, 2021 Jan 03, 2021

Copy link to clipboard

Copied

As of Photoshop 21.x, attempting to use Blend If on a Group caused Photoshop to crash. A"fix" in 21.2.1 stopped the app crashing in this scenario, HOWEVER, the Blend If on a Group still doesn't work as it did prior to 21.x.

 

It may not crash, but the Blend If effect isn't functioning. Blend If on the Group, using the Underlying Layer slider, just toggles the effect of the group on and off. It doesn't apply a blend based on luminosity. It is just on or off, same as using the layer visibility eyeball. This is on Windows 10, to be clear.

 

These pictures hopefully demonstrate. The "Dodge" group comprises a Curves layer with a simple luminosity midtone lift and a Hue/Sat layer with just -10 Saturation applied. Both have a blank mask but the Group has a negative mask, with painting on the Group mask to apply the combined effect. 

 

Picture 1shows no blend and the dodge effect fully applied in the selected area, on the group mask. Pic 2 shows that by merely raising the Group Blend If Underlying Layer slider by 1 level, the effect totally vanishes whereas prior to 21.x the effect should apply across the luminosity gradient. Splitting the sliders to feather also has no impact on the fault. The effect just disappears as if the group had been hidden.

 

noblend-ceac37fc-d53d-40ca-b1fd-1f9e954f2dbd-460353571.jpgnoblend-ceac37fc-d53d-40ca-b1fd-1f9e954f2dbd-460353571.jpg
failedblend-99a62cc8-1390-493b-9cd4-af04143079ff-714902233.jpgfailedblend-99a62cc8-1390-493b-9cd4-af04143079ff-714902233.jpg

To repeat myself for sake of total clarity, the app no longer crashes but Blend If on a Group still doesn't do anything.

 

I am starting a new issue because of confusion on the existing thread and because I don't consider this fixed until it works again as expected.

 

 

 
Bug Investigating
TOPICS
macOS, Windows

Views

21

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 12, 2021 Jan 12, 2021
Looks like this was never fully implemented. It's on the team backlog to see if they can hook it up.

Votes

Translate

Translate
13 Comments
Adobe Employee ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Hay Matt, would it be possible to share the PSD file you used above to reproduce the problem you're reporting?


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Sure, where do I send it?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Easiest way is to use CC Files or Dropbox and share a link.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

https://shared-assets.adobe.com/link/0781c8fa-388b-4538-6598-30b3cb63e506

Perhaps it's easier to use with the posterize layer turned off. Using Blend If on the "Brighten" layer in the "Dodge" group produces the desired effect, but using Blend If on the "Dodge" GROUP does NOT. That's fine in this monochrome example but if I wanted the effect of the Hue / Sat layer to work, as I would in a real dodge and burn, I need the Blend If to work at group level like it used to.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Appreciated. I wanted to make sure I had exactly your setup to reproduce for the engineers.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Cheers, look forward to the feedback!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 11, 2021 Jan 11, 2021

Copy link to clipboard

Copied

The same exact thing is happening on Mac OS Catalina. But here is the weird part.

I've tried the group blend/if with multiple adjustment layers inside a group and get the same result as mattstix when working on Nikon, Canon, and Fuji images. Whenever you attempt to adjust the blend/if on a group it is either ON or OFF.

But tonight I created a file from scratch in photoshop and placed a black to white gradient on the background layer. Then added three or four adjustments and placed them inside a group. Then adjusted the blend/if on the group and it worked. This was a group that had levels, curves, and solid color adjustment layers. But when I added the Black&White Adjustment layer or a gradient map and tried to blend if it was either on or off.

Makes no Sense.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

Looks like this was never fully implemented. It's on the team backlog to see if they can hook it up.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

Thanks for the reply.  Really hoping this gets sorted out.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

Yes thanks for acknowledging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

Thank you guys for creating a separate thread from the crasher.  I noticed we have this logged in our internal To Do list already.  Has this issue been around for previous versions like Photoshop CC 2019 or older?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

Eiyhrr Since ver 20 or 21 for me on mac os. Would have go back and look but I think ver 21

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

LATEST

No. I only noticed it in June I think, 21.2 release from memory. I couldn't swear that 21.0 didn't bring it in by I do know it certainly used to work and was fine until not long before June

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines