P: Blend modes doesn't work (Win10)

1 Vote
Community Beginner ,
Apr 01, 2020 Apr 01, 2020

Copy link to clipboard

Copied

Hi, I found a bug when blend modes don't work if a new layer is created in a double nested group and at the same time the top group has a clipping layer. It even doesn't work when the clipping layer is hidden. See attached PSD.
https://www.dropbox.com/s/fk36x5vsumn3nde/blendingbug.psd?dl=0

Roman

Bug Fixed
TOPICS
Windows

Views

98

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jul 15, 2020 Jul 15, 2020
This should be fixed in 21.2

Votes

Translate

Translate
7 Comments
Adobe Employee ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

I am not able to see a difference in how Photoshop rendered this file previously compared to the current version: Can you take a screen shot to show me the state of the layers panel and the canvas that shows the difference?

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

Here is a short video https://www.dropbox.com/s/z69grahogtremc5/blending.mp4?dl=0
I also updated the PSD file on the link above (deleted 2nd layer in the nested group)

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Apr 02, 2020 Apr 02, 2020

Copy link to clipboard

Copied

Does turning on Photoshop > Preferences > Performance > Legacy Compositing and restarting Photoshop have any bearing on the issue? 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 03, 2020 Apr 03, 2020

Copy link to clipboard

Copied

It does. If you enable legacy compositing it works.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Apr 03, 2020 Apr 03, 2020

Copy link to clipboard

Copied

Thanks the video and new file have helped me understand/reproduce the issue. The workaround is to turn on Legacy Compositing. I've asked engineering to take a look. Thanks!

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 15, 2020 Jul 15, 2020

Copy link to clipboard

Copied

This should be fixed in 21.2

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Explorer ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

LATEST

Just a quick question: the solution to a lot of these issues is to turn on Legacy Compositing. BUT that feature has been removed from current versions of Photoshop. Did the engineers view it as a crutch and decide to fix forward? I still have a ton of issues with blend modes, using the most current version. Very unpredictable results ('Color' was the most useful to me, doing colorizing work - but now it's useless). I've posted about this, but no responses.

Votes

Translate

Translate

Report

Report