P: Changing Maximize Compatibility doesn't affect files saved without it

6 Votes
LEGEND ,
Dec 18, 2014 Dec 18, 2014

Copy link to clipboard

Copied

Once a file has been saved without a merged compatibility layer (via the file-save option Maximize PSD And PSB File Compatibility = Never), File > Save will never re-save the file with a compatibility layer, regardless of the setting of Maximize Compatibility. The only way to add the compatibility layer is to ensure Maximize Compatibility = Always and then do File > Save As to save a copy.

One noticeable impact of this is that people trying to get OS X Quick Look to display thumbnails and previews by changing Maximize Compatibility could get confused and believe that the option is having no effect.

To reproduce the bug:

1. Start Photoshop CC 2014 on OS X 10.9.5.

2. In Photoshop > Preferences > File Handling, set Maximize PSD And PSB File Compatibility to Never.

3. Restart Photoshop.

4. Create a new RGB 8-bit document with two layers and visible edits on each layer (e.g. with the pencil tool).

5. Save the document as "test.psd".

6. In the Finder, view the folder containing "test.psd", select "test.psd", and do File > Quick Look. Observe that the preview is all white, indicating that the merged compatibility image has not been saved (as expected).

7. Now change Maximize PSD And PSB File Compatibility to Always, and restart Photoshop.

8. Make another edit to one of the layers.

9. Do File > Save.

10. In the Finder, do File > Quick Look and observe that the preview is still all white (not expected -- BUG).

11. In a Terminal window, give the following command to flush the Quick Look and Finder caching and restart Quick Look and the Finder:qlmanage -r; qlmanage -r cache; killall FinderObserve the preview is still white.

12. In Photoshop, do File > Save As to save a copy of the file as "test copy.psd".

13. In the Finder, observe that File > Quick Look properly displays a preview of "test copy.psd".

I have verified that when Quick Look is displaying "test.psd" as all white, the Boolean "hasRealMergedData" in image-resource block 1057 is 0, and the merged compatibility layer consists of all white pixels. This indicates that Photoshop hasn't saved an actual merged compatibility layer.

Bug Fixed
TOPICS
macOS

Views

198

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 25, 2018 Jan 25, 2018
This was marked fixed a while back. It should work correctly in the current version of Photoshop.

Votes

Translate

Translate
15 Comments
Adobe Employee ,
Dec 18, 2014 Dec 18, 2014

Copy link to clipboard

Copied

Thanks. We're looking into this.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 18, 2015 Jun 18, 2015

Copy link to clipboard

Copied

This bug still exists in Photoshop CC 2015.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 18, 2015 Jun 18, 2015

Copy link to clipboard

Copied

This was actually fixed in Photoshop CC 2015, so changing the setting does apply to re-saved files.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 18, 2015 Jun 18, 2015

Copy link to clipboard

Copied

I just repeated steps 1-13 and got the same results as in Photoshop CC 2014. I've gathered together the files saved by steps 9 and 12, along with dumps of their file structures:

https://dl.dropboxusercontent.com/u/2...

When you do steps 1-13, what happens?

Votes

Translate

Translate

Report

Report
New Here ,
Jun 21, 2017 Jun 21, 2017

Copy link to clipboard

Copied

It's not fixed yet
What's going on Adobe?  I can't work like this.  

Votes

Translate

Translate

Report

Report
New Here ,
Jun 21, 2017 Jun 21, 2017

Copy link to clipboard

Copied

This is nonsense and it's been going on for years.  You guys should be ashamed of yourselves.  I can't imagine having to go through over 5,000 photos that I want to use Lightroom as an editor for.  I'm paying for the "suite" of products and it turns out they are not compatible with the native file extension that their flagship product produces.  Unbelievable and it leaves me with the only option of not using Lightroom to edit the photos.  I'll use 3rd party.  Please let me know when you guys get a fix for this.

Votes

Translate

Translate

Report

Report
New Here ,
Jun 21, 2017 Jun 21, 2017

Copy link to clipboard

Copied

All I'm trying to do is import my photos in Lightroom so I can get started editing a massive amount of photos to get them ready.  I'm getting the error message on every .pdf file I have to import which is all of them. Over 5,000 photos!  Now I'm told that I have to open them up individually and save as a new file name with the compatibility option checked.  Sorry, this is unacceptable.  Photoshop is a Adobe flagship product and Lightworks needs to be compatible with the native file format that it produces without screwing around with it.  I'm paying for the so-call suite of Creative so they need to work together so we can all be so-called Creative.  I've been using Photoshop for over 20 years and this is causing my business to have a huge interruption.  
WTF?

Votes

Translate

Translate

Report

Report
Guide ,
Jun 21, 2017 Jun 21, 2017

Copy link to clipboard

Copied

are you trying to bring .pdf or .psd into Lightroom? Also, it sounds like this is your fault and not Photoshop. If you've been a Ps user for 20 years, then you should be aware that you can automate the MaxCompat using Image Processor Pro.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

This was marked fixed a while back. It should work correctly in the current version of Photoshop.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

Hi Jeffrey,

I retested the recipe in Photoshop CC 2018 (19.1.0) 2017.1.3 / MacOS 10.13.2, and the bug is still there: Once a file has been saved without a merged compatibility layer, File > Save will never re-save the file with a compatibility layer, regardless of the setting of Maximize Compatibility. The only way to add the compatibility layer is to ensure Maximize Compatibility = Always and then do File > Save As to save a copy.

Mac Quick Look has changed its previews for PSDs, so steps 6 and 10 now produce somewhat different results. Rather than producing an all-white preview for files missing a compatibility layer, Quick Look now seems to display just one of the layers (the top layer?).   But if you take the file from steps 6 and 10 and try to import it into LR, LR will confirm it's missing the compatibility layer:



The main impact of this bug is that it confuses many people and wastes a lot of time, as seen on these forums.  They're told they need to set Maximize Compatibility to use their PSDs/PSBs with other programs and see thumbnails in Finder; but when they set the option, it seemingly has no impact, and then there's a lot of discussion with more heat than light.

Votes

Translate

Translate

Report

Report
Guide ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

John, why would someone still be using 17.1.3? There are tons of bugs with older versions which i doubt will ever be patched...

Votes

Translate

Translate

Report

Report
People's Champ ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

How can this be marked solved when it's never been fixed?
I don't know what version of cc 2015 that it was supposed to be fixed in, but in cc 2015.1.2
it is not fixed.

Still not fixed in photoshop cc 2018 (19.1) on a macOS 10.13.3.


In fact, as far as we can tell. the last mac version of photoshop that worked the way John R Ellis is talking about is photoshop 6 from 2001.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

Oops, I got confused about which version I was running. I retested with 2018 (19.1.0) and the recipe gives the same negative results.  Thanks for catching that.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

Thanks John. OK. There was a note I missed. The fix was only for Save As. We may have to revisit this.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

LATEST
OK, thanks.

Votes

Translate

Translate

Report

Report