Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Content aware tool not working

2 Votes
LEGEND ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

I'm trying to extend an image and when using the crop tool with the content aware box checked, it does nothing. I just used this tool yesterday with no problems. I'm assuming an update bug broke it. Any ideas??

Bug Won't fix
TOPICS
macOS, Windows

Views

753

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
12 Comments
Explorer ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

Not sure if this is the same issue, but I've caught it misbehaving like that until I changed the Background layer to a regular layer. Only happens sometimes; maybe that's worth a try?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 08, 2018 Dec 08, 2018

Copy link to clipboard

Copied

The Content Aware checkbox is not activated in your screenshot...
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2018 Dec 08, 2018

Copy link to clipboard

Copied

I have tried to replicate your issue with no success...but I DID notice that the Content Aware box is NOT checked in your screen capture here...?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 10, 2018 Dec 10, 2018

Copy link to clipboard

Copied

It just happened to me again. What happens is you check the box, and as soon as you manipulate the crop frame, it unchecks itself. If you don't notice that happening, you get the above results. If you check it again just before you commit, it unchecks itself. Sometimes the check box is greyed out.

It's intermittent and I don't know what causes it. Once it starts I can't stop it by changing tools and changing back to the crop tool, only turning the background layer into layer 0 makes it work again.


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 26, 2019 Sep 26, 2019

Copy link to clipboard

Copied

Hi Jody,

Do you recall when you started seeing this? What was the last version you recall using of Photoshop where Content-Aware Scale worked? I'm trying to determine the version where it first broke.

Thank you,
Hannah

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 27, 2019 Sep 27, 2019

Copy link to clipboard

Copied

I think I may have figured it out. Seems to happen when there’s multiple layers and a Background layer. Turning the Background into a regular layer makes it work.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 29, 2020 Feb 29, 2020

Copy link to clipboard

Copied

Hannah - same problem with me now. Started happening this month. Before, when I used crop tool the content aware button was available whether a smart object or not. Now it's not there. I have two computers - one with Mac OS Catalina (no problems with that) and one with Mojave (where the problems lie). I don't want to update the Mojave due to its issues with other software that won't run on it. So - is it OS that's the problem, or something else? Thanks.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 03, 2020 Mar 03, 2020

Copy link to clipboard

Copied

I've been using both Edit>Fill>Content Aware and the Edit>Content Aware Fill approaches with no problem.  Not until just now, that is.  And they both worked fine a few days ago.  When the suggestions offered here didn't work, I decided to bang my head against it with something else.  My selection had been made by Ctrl-clicking an old mask and inverting it.  (I'm reworking an image I'd done probably about five years ago.)  I replaced that selection with one made with the Lasso tool, and Edit>Content Aware Fill worked just like it's supposed to.  Trouble is, I have no idea why.  You'd hope it wouldn't matter how the selection was made.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 03, 2020 Mar 03, 2020

Copy link to clipboard

Copied

Thanks for letting us know Paul. I'm looking into it and I'll update when I know more. Offhand I wouldn't think your OS would be related, but thanks for including that information. 

Hannah

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

Make sure your layer isn’t locked. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 06, 2021 Jan 06, 2021

Copy link to clipboard

Copied

Make sure your layer isn’t locked 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 28, 2021 Jul 28, 2021

Copy link to clipboard

Copied

LATEST

@Johan_Elzenga

Thanks Johan, I did activated the screenshot for the menu bar, now is working. Great tool.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines