P: Cursor stuttering & screen flickering in Photoshop on high refresh rate G-sync monitors

10 Votes
Guide ,
Jul 15, 2020 Jul 15, 2020

Copy link to clipboard

Copied

If you're a nvidia gsync user and experiencing mouse stuttering in Ps (and all Adobe apps), try turning off gsync to see if that resolves the issue. 
Basically what happens is that any activity in an Adobe app will result in 2-3 seconds of micro-cursor stuttering (looks like frame rate dropping) and the occasional 3-4 seconds of cursor freeze. Disabling gsync fixes the issue. This behavior appears only in Adobe apps and none other.

 

 

{Thread title edited by moderator}

Bug Investigating
TOPICS
Windows

Views

12.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 5 Correct answers

Explorer , May 10, 2022 May 10, 2022

I turnet G-Sync off and the problem was solved. Thx

Votes

Translate

Translate
Adobe Community Professional , May 10, 2022 May 10, 2022

First, try disabling GPU in the Lightroom Preferences (Performance tab). Any better?

If not, recalibrate and build a new ICC display profile, the old one might be corrupted.

If you are using software/hardware for this task, be sure the software is set to build a matrix not LUT profile, Version 2 not Version 4 profile.

If turning OFF GPU works, it's a GPU bug and you need to contact the manufacturer or find out if there's an updated driver for it. On the Mac, that's part of the OS update(s) so if

...

Votes

Translate

Translate
Adobe Employee , Jan 11, 2022 Jan 11, 2022
Adobe Community Professional , Jan 11, 2022 Jan 11, 2022

Make sure you go to PS prefs and turn on HDR display suppor under Technology Previewst. Screen Shot 2022-01-11 at 10.44.12 AM.png

Votes

Translate

Translate
Adobe Community Professional , Sep 15, 2021 Sep 15, 2021

Hello, IIRC, in the past some customers reported fixing some display issues by deactivating G-Sync in their drivers.

 

I would also  try to check "Deactivate Native Canvas" in the menu Edit/Preferences/Technology preview (Pc) or Photoshop/Preferences/Technology preview (Mac) .
This is not a fix, but rather a way to check if the issue appears only with the new technology, and should be reported to the Ps team.

Votes

Translate

Translate
replies 114 Replies 114
114 Comments
Contributor ,
Oct 24, 2019 Oct 24, 2019

Copy link to clipboard

Copied

OMG, OMG! G-sync is now working in photoshop!!!! Yes! OpenGL and G-sync! P.S. Did not see the indicator first! https://photos.app.goo.gl/6uUw4svfkz1FqjJa6

So, thanks to nvidia we now have 30 bit color AND G-sync in windowed Vulkan and OpenGL (while OpenCL, Directx 12, 11, 9, 8 and UWP apps worked before). That is just great! If only Nvidia solved that bug with indirect instancing which blender suffers from! https://developer.blender.org/T70011

P.S. was fixed!

 

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 06, 2019 Nov 06, 2019

Copy link to clipboard

Copied

Hey lads,

I have an nvidia graphics card and a gsync screen. Adobe Photoshop CC and all other Adobe programs, for that matter, somehow trigger Gsync.

 

Whenever I launch an Adobe programme and perform a simple action like dragging an image in Photoshop, Illustrator or a video in Premiere, the refresh rate starts jumping around from 165 all the way to 17 and back. As soon as I stop the action I was performing, my refresh rate jumps back to its default (which is 165 in my case).

 

All my drivers, obviously including my graphics card's drivers, are up to date.

 

I have an Asus Gsync screen and an nvidia 2070 Super, but this problem also occurred on my previous graphics card.

 

Somehow Adobe software triggers the variable refresh rate, which should only be the case in video games.

 

Does anyone know of a fix, besides disabling Gsync every time?

 

Thanks!

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 07, 2019 Nov 07, 2019

Copy link to clipboard

Copied

No one? Seriously?

 

Are there any Adobe customer service people available?

Votes

Translate

Translate

Report

Report
New Here ,
Nov 10, 2019 Nov 10, 2019

Copy link to clipboard

Copied

Hey, 

i have the same Problem since updating my GPU from GTX 980ti to RTX 2070 Super.
FPS drops low to 17, struggeling around 50ths and coming back to 120 after doing not more action in adobe creative products.

Looking for a solution, but cant find this problem at the internet.

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 11, 2019 Nov 11, 2019

Copy link to clipboard

Copied

Exact same problem; upgraded from a 980ti to a 2070 super as well!

 

At the moment it's impossible to use any Adobe program with gsync enabled.

Votes

Translate

Translate

Report

Report
New Here ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

I am havig the exact same issue with Lightroom and Photoshop!

 

I have an RTX 2080 Ti with a 165hz refresh rate G-Sync monitor.

The program never ceases to drop the refresh rate to an abismol level for no reason when using certain functions within the program and sometimes the low refresh rate is continuous until I close the program.

 

i9-9900k Processor as well.

All up to date drivers.

 

This is very annoying because I am forced to use a monitor with a refresh rate of 60hz to be able to even use the program effectively.  This needs to be fixed!

Votes

Translate

Translate

Report

Report
New Here ,
Nov 12, 2019 Nov 12, 2019

Copy link to clipboard

Copied

The Problem seems to be done for me. 

Nvidia released driver v441.20 today, after this everything works smooth again at full 120hz withhout any drops.

Votes

Translate

Translate

Report

Report
Explorer ,
Nov 21, 2019 Nov 21, 2019

Copy link to clipboard

Copied

Last Adobe updates (to 2020 versions) seem to have fixed the issue.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

I have the same problem with my 2080TI and updates don't help. 😞

Votes

Translate

Translate

Report

Report
New Here ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

Solved my problem by turning off G-Sync for Adobe Apps.

Votes

Translate

Translate

Report

Report
New Here ,
Dec 28, 2019 Dec 28, 2019

Copy link to clipboard

Copied

Same

Votes

Translate

Translate

Report

Report
New Here ,
Jan 27, 2020 Jan 27, 2020

Copy link to clipboard

Copied

I had the exact same problem ever since installing Adobe Audition. Now with the 2020 update all my Adobe apps continually dip framerate whenever I'm performing an action. After hours of troubleshooting I have finally come across this thread and my god am I happy. As someone else mentioned, turning G-Sync to "fixed refresh rate" in the Nvidia control panel for all Adobe apps fixed my issue.

Adobe needs to fix this now. Small bugs like this waste hours of productivity.

Votes

Translate

Translate

Report

Report
Contributor ,
Mar 22, 2020 Mar 22, 2020

Copy link to clipboard

Copied

"Somehow Adobe software triggers the variable refresh rate, which should only be the case in video games."

 

No, no and no! Photoshop is using OpenGL and Nvidia finally implemented OpenGL windowed G-Sync! It is great. And all problems are because of Adobe devs. You can simply turn off G-sync for ONLY Photoshop in nvidia control panel. Also here I discussed it.

https://community.adobe.com/t5/photoshop/g-sync-is-now-working-in-photoshop-with-latest-nvidia-drive...

Votes

Translate

Translate

Report

Report
Contributor ,
Apr 07, 2020 Apr 07, 2020

Copy link to clipboard

Copied

Had this problem today as well on a fresh Windows 10 installation. In the Nvidia Control Panel, I fixed it by disabling G-Sync for WINDOWED modes, and kept G-Sync only for FULL SCREEN.

 

I discovered other programs giving me the same issue, hovering my mouse over their icons would lag the mouse like crazy. Intel Rapid Storage application - just hovering over the buttons and icons- will cause the same issue I see in Adobe apps with the mouse lag as well.

Votes

Translate

Translate

Report

Report
Contributor ,
Apr 07, 2020 Apr 07, 2020

Copy link to clipboard

Copied

No need for that. You can just turn of G-sync off only for Photoshop in 3D profiles. Anyway, on fast PC it is fixed, i.e. 1 frame drawing is now fast enough.

Votes

Translate

Translate

Report

Report
New Here ,
May 06, 2020 May 06, 2020

Copy link to clipboard

Copied

The seam issue.
You can try to reduce your refresh rate to 60 and that solve, partially the problem

Votes

Translate

Translate

Report

Report
New Here ,
Jul 07, 2020 Jul 07, 2020

Copy link to clipboard

Copied

Where did you turn this off? The photoshop clitching is relentless.

Votes

Translate

Translate

Report

Report
Contributor ,
Jul 07, 2020 Jul 07, 2020

Copy link to clipboard

Copied

3d-profiles in Nvidia Control Panel.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jul 16, 2020 Jul 16, 2020

Copy link to clipboard

Copied

I wonder if the OP here has gsync enabled: Photoshop CC 2020(21.2) : App literally became critically slow with frequent stuttering

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Guide ,
Jul 16, 2020 Jul 16, 2020

Copy link to clipboard

Copied

could be. I mention the gsync issue in that thread and it's also what inspired me to create this )
i did a little more testing yesterday and the issue happens when you enable the option for Fullscreen and Windowed apps, but not when Fullscreen only.
PS-49914 is the bug and i've asked around to see if anyone has a gsync machine they can test with, but doesn't seem like there is one... maybe Noel?

Votes

Translate

Translate

Report

Report
New Here ,
Aug 16, 2020 Aug 16, 2020

Copy link to clipboard

Copied

I have had to disable the use of my Graphics Processor so that Photoshop is even usable. Below are my system requirements which I know are really good for just running photoshop. As of 8.16.2020, this is still an issue.

 

Adobe Photoshop Version: 21.2.1 20200716.r.265 2020/07/16: 2b9692040b x64
Operating System: Windows 10 64-bit
Physical processor count: 4
Logical processor count: 8
Processor speed: 4000 MHz
Built-in memory: 32671 MB
Free memory: 17951 MB
Memory available to Photoshop: 29918 MB
Memory used by Photoshop: 60 %
Scratch volume(s):
D:\, 931.5G, 682.2G free
C:\, 465.2G, 288.0G free

NVIDIA GeForce RTX 2070 Super
NVIDIA Studio Driver 451.77 : Release Date: 07/16/2020

 

Regards,

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 16, 2020 Aug 16, 2020

Copy link to clipboard

Copied

Problems started here as well. I disabled Gsync from the nvidia panel, but adobe programs still mes with the monitor's refresh rate which make it impossible to work without manually disabling gsync every time. Very annoying.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 26, 2020 Aug 26, 2020

Copy link to clipboard

Copied

What the heck is going on?

 

I have used Adobe products on the same hardware, using the same GSync display, for literally YEARS. GSync has been enabled since 2014 guys, and has had precizely zero problems until updating to the current Adobe product line. 

 

raised eyebrows

Votes

Translate

Translate

Report

Report
Contributor ,
Aug 26, 2020 Aug 26, 2020

Copy link to clipboard

Copied

Gsync is Opengl started working only in 2019. And yes, photoshop uses Opengl.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 26, 2020 Aug 26, 2020

Copy link to clipboard

Copied

What?

 

I have been using the same Gsync display, with Gsync enabled, on the same hardware, since 2014. It wasn't until I updated to CC 2020 earlier this week that this has become an issue. First I've ever encountered it, but I am certain that it functioned since 2014, and I use Photoshop almost daily.

Votes

Translate

Translate

Report

Report