P: Cursor stuttering & screen flickering in Photoshop on high refresh rate G-sync monitors

10 Votes
Guide ,
Jul 15, 2020 Jul 15, 2020

Copy link to clipboard

Copied

If you're a nvidia gsync user and experiencing mouse stuttering in Ps (and all Adobe apps), try turning off gsync to see if that resolves the issue. 
Basically what happens is that any activity in an Adobe app will result in 2-3 seconds of micro-cursor stuttering (looks like frame rate dropping) and the occasional 3-4 seconds of cursor freeze. Disabling gsync fixes the issue. This behavior appears only in Adobe apps and none other.

 

 

{Thread title edited by moderator}

Bug Investigating
TOPICS
Windows

Views

12.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 5 Correct answers

Explorer , May 10, 2022 May 10, 2022

I turnet G-Sync off and the problem was solved. Thx

Votes

Translate

Translate
Adobe Community Professional , May 10, 2022 May 10, 2022

First, try disabling GPU in the Lightroom Preferences (Performance tab). Any better?

If not, recalibrate and build a new ICC display profile, the old one might be corrupted.

If you are using software/hardware for this task, be sure the software is set to build a matrix not LUT profile, Version 2 not Version 4 profile.

If turning OFF GPU works, it's a GPU bug and you need to contact the manufacturer or find out if there's an updated driver for it. On the Mac, that's part of the OS update(s) so if

...

Votes

Translate

Translate
Adobe Employee , Jan 11, 2022 Jan 11, 2022
Adobe Community Professional , Jan 11, 2022 Jan 11, 2022

Make sure you go to PS prefs and turn on HDR display suppor under Technology Previewst. Screen Shot 2022-01-11 at 10.44.12 AM.png

Votes

Translate

Translate
Adobe Community Professional , Sep 15, 2021 Sep 15, 2021

Hello, IIRC, in the past some customers reported fixing some display issues by deactivating G-Sync in their drivers.

 

I would also  try to check "Deactivate Native Canvas" in the menu Edit/Preferences/Technology preview (Pc) or Photoshop/Preferences/Technology preview (Mac) .
This is not a fix, but rather a way to check if the issue appears only with the new technology, and should be reported to the Ps team.

Votes

Translate

Translate
replies 114 Replies 114
114 Comments
Contributor ,
Aug 27, 2020 Aug 27, 2020

Copy link to clipboard

Copied

No, OpenGL did not have VRR extensions in the driver to give it to G-sync. You updated Nvidia driver it has nothing to do with Photoshop. See my post, https://community.adobe.com/t5/photoshop/g-sync-is-now-working-in-photoshop-with-latest-nvidia-drive...

Votes

Translate

Translate

Report

Report
New Here ,
Sep 01, 2020 Sep 01, 2020

Copy link to clipboard

Copied

Disable GSYNC for adobe programs separetly in nVidia Control Panel. WORKS LIKE A CHARM. I cant bealive I solved this. My card is 2070 Super as well. Solution in Polish but you can translate it easy. I tired almost everything and finally found a solution. I couldnt even change tabs in Photoshop before without 5s lag.

kamilr80402452_0-1598961345645.png

 

Votes

Translate

Translate

Report

Report
New Here ,
Sep 22, 2020 Sep 22, 2020

Copy link to clipboard

Copied

Just a little update to the topic, the problem still not fixed on the current drivers of Nvidia and Abobe ( 09/22/2020 ). The only way i found to fix the issue was disable the g-sync capability on Adobe apps just like the people above me have described.

Votes

Translate

Translate

Report

Report
New Here ,
Nov 29, 2020 Nov 29, 2020

Copy link to clipboard

Copied

use G-sync only in full screen, this will fix all your problems

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 05, 2021 Jan 05, 2021

Copy link to clipboard

Copied

[JAN 2021]

This issue is still present on current versions of everything in the Adobe CC suite, on Windows 10, with current nVidia drivers for the 2070 Super.

 

For me it is causing terrible brightness flickering whenever an Adobe app's window is focused.

 

Successful current workaround:

NVIDIA Control Panel > Display > Set up G-SYNC

change from "Enable for windowed and full screen mode" to "Enable for full screen mode" only

reboot

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 05, 2021 Mar 05, 2021

Copy link to clipboard

Copied

Yup, this is true. I am facing this issue as well. It also stutters badly when minimizing photoshop sometimes. Everything else is butter smooth on my 165hz monitor. Some apps like adobe animate doesnt really stutter as bad as photoshop & illustrator.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 19, 2021 Jul 19, 2021

Copy link to clipboard

Copied

Same here... a year later!? Mouse and GUI lag extremely with GSync turned on.
There are lags of the mouse, but also Lightroom freezes for several seconds to minutes.
Turn off GSync = problem solved


Lightroom 10.3
NVidia driver 471.41
Windows 10 21H1 (19043.1110),

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

This issue has now become even more of a problem. I wonder if anyone else is experiencing this now. I went from small stutters that were noticable like the backlight of the monitor was flashing everytime you made a cursor movement on the screen in photoshop, even more so when adjusting the navigator changing zooming in or out on your project. 

NOW, the issue went from what I descibed before to the whole screen flashing black momentarly I'm assuming everytime the refreshrate adjust. which is anytime you make a major movement in the program with cursor or zooming in/out, so on. 

I had been able to previously fix this by setting the nvidia control panel to not use gsync in adobe programs, setting the option to use fixed refresh rate. However, this fix nor any other setting it seems is fixing the issue. I really do not want to have to set my monitor to 60hz then back everytime I use photoshop. As I have an OC 165hz monitor and changing the setting requires a monitor reboot everytime. When you have Adobe open with say a game or just anything you would like  a higher refresh rate. Even switching back an forth often, this issue becomes a huge pain.

Right now Photoshop is almost unusable for me without causing headaches. This is a huge issue!! Please fix as I use adobe for work an need to be in the program often. Thank you!!!!! 

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

I have a ROG PG279Q Monitor
and a Gigabyte windforce 2080super. If that helps at all to know?

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

All drivers and software are up to date as well!

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

Please change that updates fixed the issue, because they have not. Read my comment for details of what I'm experiencing.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

This is not true as of now, This issue should not be solved. Please check my comment for details. Wondering if its just my monitor at this point.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 19, 2021 Aug 19, 2021

Copy link to clipboard

Copied

So I found a fix to the major issue I had... Downgrading from version PS 22.5 to 22.4 and using the fixed refresh rate setting in Nvidia panel seems to be working for now. For some reason 22.5 was causing my monitor to flash black like it was off then back on everytime the refresh rate updated, or basically everytime you did anything in PS.

 

Votes

Translate

Translate

Report

Report
New Here ,
Sep 14, 2021 Sep 14, 2021

Copy link to clipboard

Copied

I have a 120hz refresh rate monitor and for some reason, the last two updates to photoshop have caused the interface and menus to flicker uncontrollably. I have up-to-date graphics drivers for my Nvidia graphics card. I have also tried disabling GPU advanced options in Photoshop to see if that would help and it only made photoshop respond even slower. The last version of photoshop that worked at 120hz was version 22.4.3. All newer versions have unfortunately had this flickering issue. When I put the monitor's refresh rate back to 60hz, the flickering issue stops and Photoshop becomes snappy and responsive again. I have fully uninstalled and reinstalled both Photoshop as well as my Nvidia graphics driver. I even used the Nvidia display driver uninstaller to completely remove the driver and its software to make sure I really removed everything for a fresh driver install. Any help would be greatly appreciated.

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Sep 15, 2021 Sep 15, 2021

Copy link to clipboard

Copied

Hello, IIRC, in the past some customers reported fixing some display issues by deactivating G-Sync in their drivers.

 

I would also  try to check "Deactivate Native Canvas" in the menu Edit/Preferences/Technology preview (Pc) or Photoshop/Preferences/Technology preview (Mac) .
This is not a fix, but rather a way to check if the issue appears only with the new technology, and should be reported to the Ps team.

Votes

Translate

Translate

Report

Report
New Here ,
Sep 16, 2021 Sep 16, 2021

Copy link to clipboard

Copied

Thanks to PECourtejoie for the reply. That got it. Thank you so much, that was driving me crazy.

Votes

Translate

Translate

Report

Report
New Here ,
Sep 19, 2021 Sep 19, 2021

Copy link to clipboard

Copied

I had the same issue after latest update on premiere and I'm using a 3070, so annoying I spent a lot of time trying to fix it. Everything was working great, I just updated to the latest Nvidia drivers and everything went bad. Thanks for the solution, I had to turn G-Sync off too. 

Votes

Translate

Translate

Report

Report
Contributor ,
Sep 22, 2021 Sep 22, 2021

Copy link to clipboard

Copied

A couple years ago I posted this as a fix:

 

  • Had this problem today as well on a fresh Windows 10 installation. In the Nvidia Control Panel, I fixed it by disabling G-Sync for WINDOWED modes, and kept G-Sync only for FULL SCREEN.

 

Yes, you can individually change this setting in the nVidia control panel for Photoshop.exe and Premiere.exe and other programs. However, I've noticed this same problem with other programs as well, such as my Corsair RGB keyboard programming software, the Epic store launcher, newer Unity engine games, some other older games, third party addons for Microsoft Flight Simulator 2020, and plenty of other things.

 

Basically this proble pops up enough that for me the solution was not to constantly keep excluding things, but instead of just turn it off for Windowed mode. After doing a little research on nVidia's and the Guru3D forums, from a technical aspect, it sounds like there is rarely a need to actually have Gsync Enabled for Windowed mode nor will you gain any advantage from doing so. I know what you're thinking - what about when you play a game in "borderless fullscreen mode" - but Gsync doesn't work that way, and you're actually not gaining any advantage to having Windowed GSync enabled. That's why on fresh driver installs it's disabled by default.

 

Keep it on for Fullscreen mode, but enabling it for Windowed mode seems to cause more problems than it's worth.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 03, 2021 Oct 03, 2021

Copy link to clipboard

Copied

Hey, I'm having the exact same issue - started about a month ago out of nowhere. Whole screen flashes black everytime I move the cursor around in photoshop (Using a 2070 on an XB270HU). Disabling G-Sync completely fixes it, but obviously not ideal. Did you manage to find a real solution? 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

Since the last PS update, I have been experiencing unacceptable lag across a variety of tools, including brushes and the crop tool. At worst, the programme has been unresponsive for up to a minute, including when saving files. This seems to happen once, early on in a session at a random point, affecting whatever tool I am using at that time. After the programme has unfrozen, the issue does not generally repeat, or if it does, not with the same severity. I have not had these problems before. I have completely reinstalled CC, Photoshop and Lightroom and have manually reset my preferences. All drivers are up to date, as are Windows updates. I have not added any new hardware or software to my PC. I have also run checks on my drives, memory and have watched for suspicious behaviour via Task Manager. There seems to be nothing wrong with Windows, any other programme, or my hardware. 


PS 22.5.1

Windows 10

Processor: Intel(R) Core(TM) i9-10920X CPU 
Installed RAM: 64.0 GB 

NVIDIA GeForce GTX 1660

ITB SSD for OS, also used as the scratch disk

4TB HDD
System type 64-bit operating system, x64-based processor
Wacom tablet

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

Did you restart your computer?

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

Hi Nancy, thank you for replying.

 

I have restarted the computer many times whilst trying to solve the issue, at many different points. Are you asking if I have tried closing PS whilst it is hanging by invoking Task Manager, followed by an immediate restart? I haven't done that yet, but I could try if I can catch PS during an unresponsive period. To be clear, either PS is responsive, but extremely laggy or it is frozen, but never for so long that I have tried using Ctrl+Alt+Del. The lag eventually goes or PS unfreezes itself at some point between 10 seconds and a minute. 

Votes

Translate

Translate

Report

Report
New Here ,
Oct 13, 2021 Oct 13, 2021

Copy link to clipboard

Copied

Same issue for me; latest NVIDIA 496.13 (Oct 12) driver still causing massive flickering when GPU acceleration is on with 144hz monitor when running 22.5.x.  Disabling G-Sync fixes it, but re-enabling it for later applications is a pain as it takes a while.

Deactivate Native Canvas also fixes this.  However, I am noticing some graphics issues in 22.5.x, regardless if solutions are used or not, such as the crop window still remaining on canvas even when canceling the selection.  Rolling back to 22.4.3 solves this, and I will remain here until these other issues are resolved.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 14, 2021 Oct 14, 2021

Copy link to clipboard

Copied

I may have solved the problem after trying many different ideas. I unchecked the 'Use Windows Ink' option in the Wacom tablet settings and everything was back to normal. I'm pretty sure I had unchecked that box when I first installed the tablet, but at some point, something probably over-wrote the setting. I might be speaking too soon, but hopefully this was the issue and the problems won't come back. 

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Oct 15, 2021 Oct 15, 2021

Copy link to clipboard

Copied

Hi,

 

We're sorry about the trouble with Photoshop on you're G-sync monitor. We have asked the product team to investigate the issue. For now, please continue using Photoshop the G-sync disabled.

 

Another workaround you can try is to enable the option to Deactivate Native Canvas by going to Preferences, then Technology Previews. 

 

Regards,

Nikunj

Votes

Translate

Translate

Report

Report