P: Export As now crops to contents instead of using the mask

10 Votes
Community Beginner ,
Aug 24, 2021 Aug 24, 2021

Copy link to clipboard

Copied

I noticed in new version of Photoshop the Export As... function no longer uses the mask but instead crops to contents. 

For example if you make a group with a 512x512 mask, place an image inside it with some space around it, Export As does not export the 512x512 masked are but instead crops to the content image. 
I don't see how this is useful change as if you've masked the group and wanted to export only its contents you would just export the layer with contents, not the masked group.

There is a workaround though, you can switch back to Legacy Eport settings in preferences, but then again everyone who uses the psd has to do the same to get it working properly. 

Does anyone know another workaround for this that would not require switching to Legacy settings?

I can see this change causing issues to a lot of users and frankly can't see the benefits to this change.


 

Bug Unresolved
TOPICS
Cross-app workflows , macOS , Windows

Views

1.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Mar 23, 2022 Mar 23, 2022

HEllo, I think this function exists only in the legacy export as function that you activate with the menu Edit Photoshop/Preferences/Export

Votes

Translate

Translate
58 Comments
Community Beginner ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Old behavior:
ps_support_img1.png

Masks give full control and can be turned off and on like a switch too. 

 

New behavior:

ps_support_img2.png

Functionality and control lost. 

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

I tried it with Quick Export and noticed it's broken even with no mask. It doesn't export only 'filled' pixels of a layer but the whole layer, so with transparency around, accordingly to document width & height dimension.

 

There is also other bug! You can't record anymore Quick Export to the action.

 

Both things are possible to do after you 'Use legacy "Export As"' option of Export preferences.

 

 

That's temporary solution till these 2 bugs are going to be fixed!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Thank you and nice to bring attention to some bugs. 

I just don't quite understand the fix/workaround. I'm using PS in german – so maybe my translation skill fails me. 

In my export preferences menu I can't find anything resembling this Use legacy "Export As" option.

Then I tried Save for web (legacy) and instead of exporting the layer, it just wanted to export my whole canvas with all the seperate art boards.


In general I am not sure if your workaround is supposed to work only for the new bugs you just discovered?

Or is it a fix for my specific problem, too? Does that mean the described functionality will come back? 

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Tick on the checkbox in 'Edit > Preferences > Export > Options' section.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

I'm sorry, I can't find it. 

 

Anne2229548871zt_0-1639758965177.png

 

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

I saw lack of that checkbox lately in one thread in german version on M1 MacExport ignores vector mask

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Lol, this is the last thing I expected. I moved to a new PS version AND to a new device.

I am relieved more people are reporting they miss this feature. It was powerful and my workflow is absolutely crippled if I can't get it back. 😞

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Please don't fiddle with any new features trying to rebuild from scraps what the old "bug" was accomplishing already -perfectly-. Please spare everyone the hassle, even if well meant. 😞

Votes

Translate

Translate

Report

Report
Community Beginner ,
Dec 17, 2021 Dec 17, 2021

Copy link to clipboard

Copied

Sorry, disregard my last reply. I now saw the explanation that this feature will have to be rebuild anyway to be future-proof. Please do so soon Adobe gang, I beg you. 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

I now saw I finally have the checkbox in the preferences, to activate the old exporting!

This is SO GOOD. Thank you! 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

If you're on M1 Mac, the developers perhaps added it with today 23.1.1 update?

Votes

Translate

Translate

Report

Report
Contributor ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Where did you found it? I've just updated PS and dont see any change. In export options i have found only "legacy export as", which doesnt change anything in regard to this behavior.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Did you check it and relaunched application?

Votes

Translate

Translate

Report

Report
Guide ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Legacy Export is still NOT available on the M1 and from my understanding, it never will be. The only to way reproduce the previous export/crop behavior is going to be when the Export team finds a way to implement in the new UXP Export. 

Votes

Translate

Translate

Report

Report
Contributor ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

Thanks for making me play with it more. I forgot to make the mask while testing. Can now confirm that after selecting legacy export in export settings, and making mask, it works as we got used to. Didnt had to relaunch the PS after changing setting.

P.S. At least with the 23.1.1 on windows 11.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

You mean it's back to old behaviour, or still it's same as before update?

Votes

Translate

Translate

Report

Report
Contributor ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

I now have the option to succesfully export masked area again with dimensions equal to mask dimensions, without forced cropping to first non-transparent pixels.

That solves my exporting issues.

Votes

Translate

Translate

Report

Report
Guide ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

@Falrinth That was always the behavior and workaround when using Legacy Export. The issue here is that the current Export doesn't allow for masked output and there's also no option for Legacy using an M1.

Votes

Translate

Translate

Report

Report
Contributor ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

If I recall well, it wasnt working as intended at the time i have posted my issue and the threads got merged - i believe that at that point in time the legacy export setting didn't do the trick, hence so many people were posting about it. Might be wrong tho, cause it was quite some time ago since i have been forced to use older version to retain that funcitonality, so i wont argue, but as i said i dont think thats the case.

Votes

Translate

Translate

Report

Report
Contributor ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

I can't export my masked area, instead it crops to the image in the layer.   This is a major slowdown in my workflow.   See the video here.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

In the past, the old Export As (Legacy) was the default, you could turn on the new version through the preferences. In a recent update to Photoshop, we changed it so that the new Export As was on by default and you would have to enable the Legacy version though the preferences instead.

 

The old Export As is built on a technology called CEP. This technology does not work with ARM processors (M1). This is one of the reasons we had to build a new Export As using UXP as the base technology. The legacy Export As was never available on Windows ARM machines and there is no workaround to add it. On Mac ARM machines, you can run Photoshop in Intel emulation mode (Rosetta), which then gives you access to the Legacy Export As through preferences. Mac is likely to drop Rosetta in a near future major update though, meaning permant loss of Legacy there as well. Apple did the same thing after switching from PowerPC to Intel. Rosetta was there for 10.4 and 10.5, it was dropped but could still be installed in 10.6, but it was no longer available in 10.7 and later. I expect similar for the new Rosetta. 

 

We are currently looking into a way to bring this workflow into the new Export As, but the behavior was a bit of a fluke in how CEP operated (which used Generator for its processing). 

Votes

Translate

Translate

Report

Report
LEGEND ,
Jan 19, 2022 Jan 19, 2022

Copy link to clipboard

Copied

You can export more layers as one when doing it with layer set containing those layers.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jan 21, 2022 Jan 21, 2022

Copy link to clipboard

Copied

I don't know if I am going crazy or it was a Mac hickup, but I indeed cheered too soon. 


Two days I just run PS in Rosetta mode to look for that checkbox you had mentioned. 

Activated it, but was thrown off by how slow PS was running in Rosetta mode.

So I switched Rosetta off again. Closed PS. Restarted. Yet export still worked the cool old way.

I even closed, checked if I had truly turned Rosetta off, then restarted PS. Export functions still worked. 

 

I assume, despite displaying it differently, my Mac didn't properly enforce Rosetta mode off. Or there is something my tapwater lol. 

 

So uh... back to the start and being massively frustarted with Adobe.

Votes

Translate

Translate

Report

Report
New Here ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

Hello,

I would like to export a layer with a mask, in PNG, with my layer taking the size of the mask.

I could do it before, but now I have a new computer it doesn't work anymore, my element keeps its size but not the size of the mask.

Do you know how I can fix it please?

Thank you!

 

NB:

macOS Monterey - 12.2 // Photoshop 2022

Votes

Translate

Translate

Report

Report
Adobe Community Professional ,
Mar 23, 2022 Mar 23, 2022

Copy link to clipboard

Copied

HEllo, I think this function exists only in the legacy export as function that you activate with the menu Edit Photoshop/Preferences/Export

Votes

Translate

Translate

Report

Report