P: Files open with wrong window size on non-Retina screens attached to Retina Macs

13 Votes
Explorer ,
Sep 09, 2013 Sep 09, 2013

Copy link to clipboard

Copied

I'm working on my external (non-Retina) monitor, with my Retina MacBook as a secondary screen next to it. Not uncommon, I believe.

When I open a document Photoshop displays it at Retina-size (i.e 50%) for a split-second before zooming in to 100%. It keeps the window size at 50% though. Since this can get a little annoying Photoshop should adjust the window size to show the full document instead.

(This happens with "Zoom Resizes Window" turned On and Off, as far as I can tell.)

Bug Fixed
TOPICS
macOS , Windows

Views

79

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Aug 04, 2015 Aug 04, 2015
OK. It sounds like we're talking about two different things. This issue reported by the original poster where the window is smaller and has scroll bars when it should be expanded and show the entire image has been fixed. The behavior described in later comments is covered by this topic: http://feedback.photoshop.com/photosh...

Votes

Translate

Translate
58 Comments
New Here ,
Sep 10, 2013 Sep 10, 2013

Copy link to clipboard

Copied

I just dl Photoshop CC and the exact same thing happened with the exact same setup!

Votes

Translate

Translate

Report

Report
New Here ,
Sep 10, 2013 Sep 10, 2013

Copy link to clipboard

Copied

It only seems to do this when it opens the first document and nothing else is open. The second and third documents have been opening in their full size

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 10, 2013 Sep 10, 2013

Copy link to clipboard

Copied

I have this problem as well, but unlike Adriana, it happens to me for every single document that I open.

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 13, 2013 Sep 13, 2013

Copy link to clipboard

Copied

Same issue:
• PS CC
• MBP 13" Retina display
• Thunderbolt monitor
• PS file with multiple Smart Object Layers (SOL)

When a SOL is opened, the window size is contracted requiring manual resizing to view entire image.

This makes me feel a little frustrated, interrupting an otherwise smooth process, especially considering the large number of SOLs I have to manually open per file.

Votes

Translate

Translate

Report

Report
LEGEND ,
Dec 10, 2013 Dec 10, 2013

Copy link to clipboard

Copied

Hmmm, I'm having issues just like every one else here.

I'm running Photoshop CC on a late 2013 MacBook Pro Retina Display with 2009 LED Cinema Display. Anything opened in the Cinema Display is in the wrong window size. It's a minor annoyance, but it IS an annoyance.

There seem to be other issues involving the retina display as well.

Would love to get these resolved, Adobe.

Thanks!

Votes

Translate

Translate

Report

Report
LEGEND ,
Mar 06, 2014 Mar 06, 2014

Copy link to clipboard

Copied

Same problem here, very frustrating having to click on the green (expand window button) every time I open a file. I get it every time I open a file no matter what size, monitor/monitors attached or not attached, doesn't seem to matter.

Especially when not having tabs activated (I prefer not to work with tabs) call me old school if you like.

Been going through the settings with no luck.

Please fix this problem Adobe.

Running Photoshop CC on macbook pro Retina 15 late 2013

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 12, 2014 Apr 12, 2014

Copy link to clipboard

Copied

Same issue on my new MBP/Retina with a Thunder Bolt display.
Its kind of annoying.
But NOW I'm really worried to notice that the problem its NOT new ( at least 7 months old ) ... please Adobe do something.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 12, 2014 Apr 12, 2014

Copy link to clipboard

Copied

Looks like Adobe has not solve this yet. Please add your mood (there is an option at the button of the text window), as well as how does this makes you feel. ( this will make the problem more noticeable so Adobe can place more attention and care on to this topic.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 12, 2014 Apr 12, 2014

Copy link to clipboard

Copied

Looks like Adobe has not solve this yet. Please add your mood (there is an option at the button of the text window), as well as how does this makes you feel. ( this will make the problem more noticeable so Adobe can place more attention and care on to this topic.
Also: Help get this topic noticed by sharing it on Facebook.
( There is a share icon on the top of this page )

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 12, 2014 Apr 12, 2014

Copy link to clipboard

Copied

Looks like Adobe has not solve this yet. Please add your mood (there is an option at the button of the text window), as well as how does this makes you feel. ( this will make the problem more noticeable so Adobe can place more attention and care on to this topic.
Also: Help get this topic noticed by sharing it on Facebook.
( There is a share icon on the top of this page )

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 12, 2014 Apr 12, 2014

Copy link to clipboard

Copied

Looks like Adobe has not solve this yet. Please add your mood (there is an option at the button of the text window), as well as how does this makes you feel. ( this will make the problem more noticeable so Adobe can place more attention and care on to this topic.
Also: Help get this topic noticed by sharing it on Facebook.
( There is a share icon on the top of this page )

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 12, 2014 Apr 12, 2014

Copy link to clipboard

Copied

Looks like Adobe has not solve this yet. Please add your mood (there is an option at the button of the text window), as well as how does this makes you feel. ( this will make the problem more noticeable so Adobe can place more attention and care on to this topic.
Also: Help get this topic noticed by sharing it on Facebook.
( There is a share icon on the top of this page )

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 12, 2014 Apr 12, 2014

Copy link to clipboard

Copied

Looks like Adobe has not solve this yet. Please add your mood (there is an option at the button of the text window), as well as how does this makes you feel. ( this will make the problem more noticeable so Adobe can place more attention and care on to this topic.
Also: Help get this topic noticed by sharing it on Facebook.
( There is a share icon on the top of this page )

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 12, 2014 Apr 12, 2014

Copy link to clipboard

Copied

Just few minutes ago, Chris Cox, a moderator from this forum, removes an invitation that I made to all persons sharing this conflict. His reason for the removal: "you already posted this once". My reasons for post this more than once: "I'm reminding, and asking to each and everyone involved to make and extra push to solve this problem that is affecting thousands of Photoshop users with a Retina Display and a Thunderbolt monitor.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 12, 2014 Apr 12, 2014

Copy link to clipboard

Copied

Hi ,Jake, please read the comment made on Adriana Tang a few minutes ago, I kindly invite you to do the same proposed to Adrian. (hopefully you can read this before a moderator of this forum deletes my comment again).

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 16, 2014 Apr 16, 2014

Copy link to clipboard

Copied

Finally I found a solution !!!
All you have to do is:
1.- Be sure that Photoshop is not running.
2.- Find Photoshop CC App.
3.- Right click on it
4.- Look for the option box -Ope in LOW RESOLUTION-
5.- Checkmark it.
... Done !!!!

Votes

Translate

Translate

Report

Report
New Here ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

OMG! THANK YOU!!! this totally works! you are amazing!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

Thanks to you for such kind reply !
Now lets hope that Adobe can spread this to the rest of the community, as well as make a FIX on the next Photoshop update.
Once again, thanks for your comment 😉

Votes

Translate

Translate

Report

Report
Explorer ,
Apr 17, 2014 Apr 17, 2014

Copy link to clipboard

Copied

That's a possible workaround but unfortunately prevents you from using your Retina display to preview any hi-dpi stuff you might be working on. Also quite annoying to change this option every time you're working without an external display... So yeah, still waiting for an official fix 😞

Votes

Translate

Translate

Report

Report
New Here ,
Jul 29, 2014 Jul 29, 2014

Copy link to clipboard

Copied

Same issue here, every time I open a file.

I've got a Mac Book Pro 15" Retina with the open lid and a second monitor attached via Thunderbolt.

It just started to happen on the Photoshop CC 2014, before I was using Photoshop CS6 and it worked without problems.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Jul 29, 2014 Jul 29, 2014

Copy link to clipboard

Copied

Edoardo,

If you still have the problem, take a look at my previous reply ( just a couple of comments before yours ).

BTW: I'm wonder why neither Adobe or Apple have made anything about this.
Anyway, the manual solution is just a few clicks above.

Votes

Translate

Translate

Report

Report
New Here ,
Jul 30, 2014 Jul 30, 2014

Copy link to clipboard

Copied

Hi Jorge, thank you, very kind.
I've tried your workaround and it worked for me as well.

Yet, I wanted to add my voice to Adobe.

The workaround is good, but I frequently use my computer without the second monitor as well and switching settings, or not getting the hidpi advantage, is annoying.

So, yeah, hoping for an official fix from Adobe too.

Votes

Translate

Translate

Report

Report
LEGEND ,
Sep 04, 2014 Sep 04, 2014

Copy link to clipboard

Copied

Having this exact issue as well. What are you doing Adobe?!

Votes

Translate

Translate

Report

Report
Community Beginner ,
Sep 04, 2014 Sep 04, 2014

Copy link to clipboard

Copied

And now the thing is going worst if you try to use Skype and share your screen at the same time.
If you have a Thunderbolt display, and a MBP retina display; dont attempt to share your screen; it will crash everything :(
BTW: Having also lots of crashes with the new PS 2014 😞 😞 😞

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 05, 2014 Nov 05, 2014

Copy link to clipboard

Copied

Same here.
At least I’m happy to see that it’s an existing problem, and not a tricks of my computer. Would love to see it resolved, thought.

Votes

Translate

Translate

Report

Report