P: Floating document windows in fullscreen w/menu bar causes window to jump to center

57 Votes
Explorer ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

With the new release, the zooming mechanism has changed and it always behaves as if "Zoom Clicked Point to Center" was turned on when I am using keyboard shortcut (mapped to Wacom Pen). It works as expected when I'm zooming with scroll wheel.

Bug Fixed
TOPICS
macOS , Windows

Views

325

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 22, 2018 Jan 22, 2018
Hey Everyone!

I am happy to announce that this issue should be resolved in the release of Photoshop that just went live, 19.1. Please open your Creative Cloud desktop app, update Photoshop and give us feedback.

Thank you!
Hannah

Adobe Blog: Selections Improvements, Advanced Support for Windows High-Density Monitors and More

What's new: https://helpx.adobe.com/photoshop/using/whats-new.html
What's fixed: https://helpx.adobe.com/photoshop/kb/fixed-issues.html

Instructions for updating: https://helpx.adobe.com/creative-cloud/help/update-app.html

Votes

Translate

Translate
replies 179 Replies 179
179 Comments
Community Expert ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Hello! have a look at the preferences, tools ans see if "focus on the location of the click " is on 😉

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
New Here ,
Oct 19, 2017 Oct 19, 2017

Copy link to clipboard

Copied

Having the same problem and the "zoom clicked..." is not checked.
The issue only happens in the "fullscreen with Menu bars" mode. In fullscreen (the second "F") in works as it should.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

I second Diego above, but you can go fullscreen (second F) and press tab and get your tools back.
Hopefully this goes back to the way it was.

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

Same issue

Votes

Translate

Translate

Report

Report
New Here ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

that's what I'm doing atm, but it is annoying. It looks like it's not a configuration issue, but a bug.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

Also having this problem.  It's a problem!

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

Mine snaps the canvas to the center of the document. Happens in all view modes. The option is unchecked.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 20, 2017 Oct 20, 2017

Copy link to clipboard

Copied

Same here! Only with "Full Screen Mode With Menu Bar", impossible to work.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 22, 2017 Oct 22, 2017

Copy link to clipboard

Copied

Guys, it works okay when you are working on TABS. I know it takes time to adjust but that's how i solved the problem.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Same problem.

I noticed that if I have "enable floating document window docking" checked in preferences, and I actually then have the file docked, all 3 view modes when hitting "F" key do not show this problem.

When I drag the file to be "un-docked" or "floating", then use the 2nd view mode when toggling "F"(full screen while still showing toolbar and other panels), this issue appears when doing opt/shift zoom many use.  This happens with both wacom pen and using non-wacom mouse.  Using the space bar feature to drag any direction over document, does not present this problem & seem to be fine.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Same problem!
I still can't find a sollution.. It's really ruining my workflow!

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Thanks, guys. It seems like you need to have Application Frame turned on, which is really annoying on the Mac. Hopefully, the update with a fix is imminent.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Having the same problem on a 2016 MacBook Pro on MacOS High Sierra 10.13. Removing application frame does not resolve the issue for me.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

This has worked for me so far. Thanks!

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 24, 2017 Oct 24, 2017

Copy link to clipboard

Copied

Same here. it happens in the full screen mode with menu bar for me. I can't figure out how to make it stop center when zoom out or selecting an object. Really frustratiting. Didn't happened before the 2018 update. Im working in a mac pro computer with macOs Sierra.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 24, 2017 Oct 24, 2017

Copy link to clipboard

Copied

You're welcome.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

I cannot work with this. THIS IS REALLY ANNOYiNG.

Votes

Translate

Translate

Report

Report
LEGEND ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

I had to revert back to the old version of Photoshop and now I'm always going to wait at least 6 months before upgrading to new versions because Adobe has glitches with every new version they release. I can't deal with the flaws and poor beta testing.

Votes

Translate

Translate

Report

Report
New Here ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Solved setting in Preferences/Workspace “Open documents as tabs”
and Window/Application frame. After reopening the file all the 3 view "F" modes are working fine.
I’m on Mac Pro with El Capitan. 

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Thank you! Not ideal as I hate using tabs but certainly a decent enough workaround <removed swearing>

Votes

Translate

Translate

Report

Report
Community Beginner ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Capo!!

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Seems like Application Frame is enough to prevent the center snapping. This will have to do for now, even though now I can't float any other app's window behind Photoshop for reference. Thanks Paolo!

Votes

Translate

Translate

Report

Report
New Here ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

In my experience also the document in tab is necessary.
I agree, Tom, Application frame is uncomfortable but I put a key shortcut to switch off it when I want.
Hoping Adobe is fixing all this.

Votes

Translate

Translate

Report

Report
Explorer ,
Oct 26, 2017 Oct 26, 2017

Copy link to clipboard

Copied

Did some work just now with both up and it seems to still snap when in Full Screen mode. Sigh.

Votes

Translate

Translate

Report

Report