P: GIF looping issue - changes by itself

0 Votes
Community Beginner ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

I've read all the other posts on this, people having isues and then they realise the issue is what they're viewing it in - but this is not the case here - I have a video to prove it.

 

When I save for web, and select the gif looping option to 'once', when I click save you can see it changing itself back to 'forever', and then saves a continuouslyt looping gif. It took me a long time to notice this, but I finally caught it on video. It only happens sometimes - but is very frustrating as I have no control over this simple command - for it to do as I'm telling - paying - for it to do. I test the gifs afterwards by dragging into Chrome - whoch does show gifs correctly and will show a gif only once if thats how it has been saved (unlike preview which alwasy loops regardless). Video attached...

Bug Acknowledged
TOPICS
macOS , Windows

Views

76

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
5 Comments
Adobe Employee ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

I've tried a few dozen times and haven't been able to reproduce. I'll keep an eye on it to see if we can figure out reliable steps/variables to reproduce.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 24, 2022 Mar 24, 2022

Copy link to clipboard

Copied

It doesn't always do it, but today since I noticed it, it does it every first time, then when I cancel the save and change it back to 'once' it works.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 25, 2022 Mar 25, 2022

Copy link to clipboard

Copied

Is the parent PSD you're working with already saved or is an unsaved document at the point you're using Save for Web?

 

Is your timeline set to Frame or Timeline mode?


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community Beginner ,
Mar 25, 2022 Mar 25, 2022

Copy link to clipboard

Copied

Just tried a couple of things; it's a .mov file from AE that i'm opening in PS to save as a gif - (no editing before trying to save) but in the save for web options - resize to 50% and change looping to once....

 

  • Save for web > set loop to once > save > works fine
  • Save for web > set image size percent to 50%, set loop to once > save > changes to forever
  • Save for web > set image size percent to 50%, set loop to once > save > changes to forever > cancel > set loop to once again > save > works fine
  • Save for web > set image size percent to 50%, set loop to once > save > changes to forever > cancel > set image size percent to 60%, set loop to once again > save > changes to forever

 

So, it seems that any time I change the size percentage it will ignore what I change the loop to. You can repeat what I did, changing the size and loop, saving and cancelling 10 times, and it will fail every time, until you don't touch the size after pressing cancel, and it will listen to my looping choice.

 

Tried it with a jpeg and PSD, saved, unsaved, all have the same result.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Mar 26, 2022 Mar 26, 2022

Copy link to clipboard

Copied

LATEST

Thanks. It seems to only happen in Timeline mode, not Frame Animation mode. I've asked engineering to take a look.


Senior Product Manager - Customer Advocacy - Digital Imaging
Bug Acknowledged

Votes

Translate

Translate

Report

Report