P: Glyphs panel behavior

1 Vote
LEGEND ,
Jun 25, 2015 Jun 25, 2015

Copy link to clipboard

Copied

Please change the Glyphs Panel behavior to be independent of the Type Tool's settings. As-is, it's not very useful.

Bug Fixed
TOPICS
macOS , Windows

Views

14

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jan 25, 2018 Jan 25, 2018
This was fixed a while back. It should be fixed in current versions of Photoshop. Let me know if you're still having trouble.

Votes

Translate

Translate
8 Comments
Adobe Employee ,
Jun 25, 2015 Jun 25, 2015

Copy link to clipboard

Copied

Hi Gary,

Could you please clarify what you mean?  What part would you like independent?  What's not working?  

Thanks,
David

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 25, 2015 Jun 25, 2015

Copy link to clipboard

Copied

Set the type tool to Segoe UI and type "Testing" on the canvas. Place the cursor at the end and insert a Glyph using a different typeface. Return to the canvas, select the type tool and begin typing a new string. The font is now set to the Glyph typeface rather then Segoe UI.

Sometimes the glyph typeface selector fails altogether. With the Glyph panel collapsed, type "Testing" on the canvas. Place the cursor at the end of the word. Expand the Glyph tool and note that you cannot change the type dropdown.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 26, 2015 Jun 26, 2015

Copy link to clipboard

Copied

Hi Gary,

What you're describing in the first paragraph is completely expected and typical Photoshop behavior.  Unlike other applications, Photoshop always retains the font face of the last font used.  Because the last font you used was "alternate typeface" that is the default font next time you start using type.  This is no different than when type was first introduced 17+ years ago.

As for the second paragraph, that does sound like a bug, but I cannot reproduce it on either Windows or Mac.  What OS are you running?  Are you getting these results reliably?

Thanks,
David

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 26, 2015 Jun 26, 2015

Copy link to clipboard

Copied

Hi David,

I can reproduce the disabled dropdown every time. Windows 8.1.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 05, 2015 Aug 05, 2015

Copy link to clipboard

Copied

Hi Gary,

Okay, I figured out what you're seeing. If the Glyph Panel is closed when you begin a new type layer, then if you subsequently open the Glyph Panel before confirming your type layer, most of the controls for the GP appear disabled.

If the Glyph Panel is already open, then there's no problem.

Turns out that this is a platform-specific focus issue. We're working on a fix, now that we know what the problem is. Meanwhile, to workaround the issue, clicking any of the controls on the bottom of the Glyph Panel (the ones that control glyph size) will restore focus correctly and remove the problem.

Thanks for pointing this out and sorry for the inconvenience. We are actively working on it.
David

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 20, 2015 Aug 20, 2015

Copy link to clipboard

Copied

This is still broken after installing the latest version. The font list dropdown is disabled after selecting the text tool, clicking on the canvas and then opening the Glyphs panel.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 20, 2015 Aug 20, 2015

Copy link to clipboard

Copied

Hi Gary,

We are aware of the problem and working on it.  We have a solution and it will be available in a future release, but we are not at liberty to say when.

In the meanwhile, as a workaround, you can simply leave the Glyph Panel visible when you begin editing text and you will not encounter the problem.

Thanks,
David

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 25, 2018 Jan 25, 2018

Copy link to clipboard

Copied

LATEST
This was fixed a while back. It should be fixed in current versions of Photoshop. Let me know if you're still having trouble.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report