P: Layer Duplicated to Incorrect Artboard in Action or ScriptingListener

0 Votes
Adobe Community Professional ,
Jun 27, 2022 Jun 27, 2022

Copy link to clipboard

Copied

Version 23.3.2 Mac, however, I can reproduce in other versions.

 

Layer in artboard "Test 1", layer menu > duplicate to artboard "Test 2" in the same file. This is correctly performed "live", however, when recording an action or using the recorded ScriptingListener code, the layer is duplicated in the original Artboard 1 and not into Artboard 2.

 

dupe-layer-to-artboard.png

 

Here is the result from an action or ScriptingListener output.

 

dupe-layer-to-artboard-result.png

 

Looking at the ScriptingListener code, the correct layer ID for the Artboard 2 is recorded, however, it is being incorrectly duped into Artboard 1.

 

Opt/alt dragging the layer from Artboard 1 to Artboard 2 does appear to be correctly recorded/played in action or ScriptingListener output.

Bug Acknowledged
TOPICS
Actions and scripting

Views

43

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 28, 2022 Jun 28, 2022

Thanks @Stephen_A_Marsh, the team will look into this.  Thank you

Status Acknowledged

Votes

Translate

Translate
1 Comment
Adobe Employee ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

LATEST

Thanks @Stephen_A_Marsh, the team will look into this.  Thank you

-- Cory
Bug Acknowledged

Votes

Translate

Translate

Report

Report