Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Mixer brush preset: saved but if I adjust the size of the brush up or down the texture disappears

4 Votes
Explorer ,
Nov 28, 2018 Nov 28, 2018

Copy link to clipboard

Copied

The Mixer brush scaling seems to be a bit buggy with saved brushes.  Reproducible in V19 and V20.  

With the Mixer brush, if I sample a texture and then paint, the texture scales up and down with the brush size when adjusted (man, would rotation be sweet too).  However, if I save that brush (either as a Tool Preset or a Brush Preset) when I load the brush again the texture is saved, but if I adjust the size of the brush up or down the texture disappears. It will revert to the last sampled texture/colour.  This only happens with saved Mixer Brushes, but it does make them a lot less useful.  Bug?

Bug Acknowledged
TOPICS
macOS, Windows

Views

66

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Dec 10, 2018 Dec 10, 2018
Perfect.  I can repro with your .tpl.  Thank you!  I'll log this as a bug right now and let you know if there is a workaround.

Votes

Translate

Translate
19 Comments
Explorer ,
Nov 28, 2018 Nov 28, 2018

Copy link to clipboard

Copied

I'm giving this advice to all who will listen. Few have my experience in photoshop. Go back to 2018. Save yourself the headache. The root problem won't be fixed for at least a year. It has to do with photoshop's rendering engine... and poor redesign. Something similar happened when Photoshop became CS, and then again when it became the cloud. This change is big, and will have a long live beta run. Users have become free beta testers on what looks to be a long shake out.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 04, 2018 Dec 04, 2018

Copy link to clipboard

Copied

Hi Brett,

Thanks for the report. I'm not seeing that behavior on Photoshop 20.0.1 on Mac OS 10.14.1 using an iMac with a magic mouse. On my setup the brush scaled after a relaunch of Ps.

What OS are you using and on what equipment?

Hannah

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 04, 2018 Dec 04, 2018

Copy link to clipboard

Copied

Hi Hannah - thanks for your reply.

I can reproduce it in V20 and V19 on my system. It is also an iMac and OS 10.14. It happens when using the magic mouse or using my Intuos Pro stylus. I recorded a screen capture of the issue:

https://www.dropbox.com/s/r2paq3nhu1mwv4l/Mixer_Brush_Problem.mp4?dl=0

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

Hi Brett, 
Have you updated to 10.14.1?  If not, can you and see if it still happens?  Also, would mind sharing your .tpl with us to see if we can repro the problem?  I haven't been able to reproduce the issue.
Thanks,
Chad

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

Hey Chad

I have, and I actually just picked up brand new Macbook Pro. Latest OS and version of Photoshop. When I loaded the brushes and tool presets from my other machine I get the same issue. I'll post a .tpl for you in a sec.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 07, 2018 Dec 07, 2018

Copy link to clipboard

Copied

Here are two tools that definitely demonstrate the issue.  I also just made an entirely new one and can replicate the problem with that one too.

https://www.dropbox.com/s/bq4sup9v0qwg9qu/mixer_test.tpl?dl=0

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 10, 2018 Dec 10, 2018

Copy link to clipboard

Copied

Perfect.  I can repro with your .tpl.  Thank you!  I'll log this as a bug right now and let you know if there is a workaround.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 10, 2018 Dec 10, 2018

Copy link to clipboard

Copied

Great - thank you

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

Hi Brett,

I think I found a workaround:
Re-save the Tool/Brushbut do not include a Color in the preset.

Daniel





Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

Hi Daniel

I did make it. I created the image by option-clicking and sampling from the file I was working on. I am not sure how you could load an image into the tool directly?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

I am able to reproduce this using the same approach:
- create blank new file and paint something into it /or load any image.
- use the Mixer Brush to sample from that image and make a new MB, save it as a tool preset.
- load that tool preset and paint, should work fine. If you change the size of the brush the image disapears.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

I think the GIF bit might be a red herring here > I just posted a possible workaround.
Try Re-save the Tool/Brush but do not include a Color in the preset.

Or just change the color after size change. Except I see there is a color jitter so this is not really useful.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

I can change the colour after resizing, but it just picks up the foreground/background colour swatch, it loses the image sample.  Same thing if I just resave the tool and do not select 'color'.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 11, 2018 Dec 11, 2018

Copy link to clipboard

Copied

If you have time to record this process > I would love to see it.
" use the Mixer Brush to sample from that image and make a new MB, save it as a tool preset."
We can continue this via daniel at adobe dot com.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 23, 2020 Jun 23, 2020

Copy link to clipboard

Copied

Hello, this problem was reported two years ago, but it still hasn't been fixed. Can you restart the correction of this problem?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 24, 2020 Jun 24, 2020

Copy link to clipboard

Copied

Hi Henri, there is an apparent workaround. This issue happens with brushes saved in an old format. Try resaving the brush preset. Does the texture work correctly with the newly saved preset?

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 25, 2020 Jun 25, 2020

Copy link to clipboard

Copied

Hello and thank's Jeffrey, these are brushes that I have just created with the latest version of PS 21.2.0.
I made a video of the problem. I can create and save as much MixerBrush as I want. But if I decide to change the size, photoshop systematically reuses the image of the last mixerbrush created.
Thank you in advance for your reply

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 25, 2020 Jun 25, 2020

Copy link to clipboard

Copied

Thanks for the video. I've asked to the team to take a look as saving a new preset doesn't seem to be working for you.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 18, 2021 May 18, 2021

Copy link to clipboard

Copied

LATEST

Still no fix for this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines