Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Odd behavior with glyphs

0 Votes
Explorer ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

I'm working with the font Lust Script available via CC. I type the word "Frappe" and it looks terrible because it's defaulting to glyphs that have swirls to the left and they're getting all tangled up together. 🙂  (See the example.)

Frappe.jpg

The font includes a number of alternates for the letters, but when I double-click on one to insert it in place of one of the originals, it keeps the original in place. The odd thing is that this problem isn't consistent; sometimes it happens, sometimes it doesn't. And when it happens, I don't know why or how to fix it.

 

Another tidbit: I can copy and paste the letter I want from another document and it works fine. I just can't get it from the glyphs panel.

 

If anyone knows anything about this and how to solve it, I would be grateful!

Bug Unresolved
TOPICS
macOS, Windows

Views

83

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Nov 05, 2021 Nov 05, 2021
I was able to reproduce your issue with Glyphs panel. This might be a bug in Glyphs panel. I will open a but report. As a workaround, you can use a feature which allows you to select alternate glyphs on canvas. To turn this feature on, open Preferences and select Type tab. Check the option "Enable Type layer glyph alternates" and close the Preferences dialog. You do not have to restart Photoshop. With this feature turned on, you will get a list of alternate glyphs when you select a character and...

Votes

Translate

Translate
6 Comments
Adobe Employee ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

Hi Jonlin,

Looks like you are applying some OpenType features to the font. If you clear those features you can get the expected default glyphs.

Screen Shot 2021-11-04 at 4.20.40 PM.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

Also check the tracking value to see if it has odd negative number. Select the text and set it back to 0.

tracking.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

Forgot to tell you the both options are available in the Type Layer Properties panel. Select the type layer, open Properties panel.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

Thanks to both of you for your input. Unfortunately, I'm still having the same problem, albeit with a twist.

 

So this morning I wanted to check your suggestions. I created a new document and typed "Frappe" as I did yesterday. This time--unlike yesterday--it automatically put in the "normal" letters without the swirls on the left (yesterday it would only give me the swirl letters).

 

It did it correctly regardless of the tracking, and also regardless of which OpenType features I had turned on--with the exception of Titling Alternates which gives me the version I got yesterday (except I don't think I had that turned on yesterday).

 

Here's where it gets odd, however. When I couldn't replicate the result I got yesterday, I tried manually changing one of the lowercase p's to the version with the swirl on the left by selecting it from the glyphs pallette. But when I try to go back to the plain version, it won't let me. If I double-click on the plain version in the glyphs pallete it keeps the version with the swirl. If I delete the letter and then type it again, it still has the swirl. No unusual tracking, no OpenType features. I have no idea what's going on here but it's aggravating to not be able to change it back. Like I said yesterday, this seems to come up at random times. Is there anything else I can check?

 

Frappe2.jpg

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

I was able to reproduce your issue with Glyphs panel. This might be a bug in Glyphs panel. I will open a but report. As a workaround, you can use a feature which allows you to select alternate glyphs on canvas. To turn this feature on, open Preferences and select Type tab. Check the option "Enable Type layer glyph alternates" and close the Preferences dialog. You do not have to restart Photoshop. With this feature turned on, you will get a list of alternate glyphs when you select a character and mouse over thick gray underline. Selecting the base glyph from the list works fine based on my experiments. A caveat is it replaces only one character. You have to do it character by character. Please try it.
Prefs.png
Glyphs panel bug s.png
When you are really stuck or many glyphs are affected, what you can do is to select text and perform "Reset Character" from the context menu of Character panel. Then, set the font and its attributes again. I know it is a pain, but at least this saves you time for retyping or recreating the type layer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 05, 2021 Nov 05, 2021

Copy link to clipboard

Copied

LATEST

Thank you for that suggestion--it worked! Thank you so much. I've run into that problem multiple times so it's good to know a workaround. And hopefully the bug will be fixed soon!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines