Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


P: Selection marquee off by 1px

5 Votes
LEGEND ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

A quite annoying "feature" in the new Photoshop is the inaccurate selection marquee. It's off by 1 px to left and to bottom.

To reproduce:

1. Create an 500x500 px image

2. Hit Ctrl+A

Result: while the whole image is selected, the marquee is inside the image on the top and left.

Photoshop_CuEh6UxPex-411504ef-0961-470b-b847-78565c387108-79309103.pngPhotoshop_CuEh6UxPex-411504ef-0961-470b-b847-78565c387108-79309103.png
Another selection touching the sides of the image:
Photoshop_U2ThJhPNwf-939e3eff-9cd5-4d89-bca7-1e76f9129457-1938501390.pngPhotoshop_U2ThJhPNwf-939e3eff-9cd5-4d89-bca7-1e76f9129457-1938501390.png
Edit:
Tested on 2 computers, the same behavior.
1. i7 7700K, 16 Gb RAM, NVIDIA GTX 1060
2. Laptop Lenovo Legion 5, i7 10750H, 16 Gb RAM, NVIDIA GTX 1650
Bug Fixed
TOPICS
macOS, Windows

Views

76

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

New Here , Jun 08, 2021 Jun 08, 2021
I just tested after getting the latest update. It looks like we have a fix! Edit: Hold on -- we aren't quite there yet. See below.

Votes

Translate

Translate
Adobe Employee , Oct 21, 2020 Oct 21, 2020
Thanks. I've asked engineering to take a look.

Votes

Translate

Translate
35 Comments
Adobe Employee ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

Thanks. I've asked engineering to take a look.


Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 22, 2020 Dec 22, 2020

Copy link to clipboard

Copied

When I select a range with the selection tool, the top and left sides of the blinking frame are off by one pixel.

However, the actual work is one pixel outside the frame.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 05, 2021 Jan 05, 2021

Copy link to clipboard

Copied

@JeffreyTranberry  I have the same issue. Your reply indicates "Official Solution" but I see no solution. Is there an update on this?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

When working on the Background layer, a rectangular selection appears to shift one pixel to the right and one pixel down when created. The selection appears to not include the pixels to the top and left while also appearing to select one pixel past the intended bottom and right. Moving the selection seems normal until the mouse button is released, at which point the shift occurs.

When deleting the selected pixels, the intended area is removed. 

Also, any part of the marquee moved outside of the image disappears. I'm not sure if that's intended, but I find it disconcerting.

This behavior occurred after the December 2020 update.

Running Windows 10 on an almost ten year old PC.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 24, 2021 Jan 24, 2021

Copy link to clipboard

Copied

PSSelectionOffsetError-4b43ab6c-41c1-45c2-8e81-8777444eaaef-1644499993.png

Any Selection, at any zoom level, the offset displays as 1 pixel Right, 1 pixel down.

System info...

Adobe Photoshop Version: 22.1.1 20210104.r.138 2021/01/04: 852879028a7  x64
Number of Launches: 193
Operating System: Windows 10 64-bit
Version: 10 or greater 10.0.19041.662
System architecture: Intel CPU Family:6, Model:10, Stepping:5 with MMX, SSE Integer, SSE FP, SSE2, SSE3, SSE4.1, SSE4.2, HyperThreading
Physical processor count: 8
Logical processor count: 16
Processor speed: 2394 MHz
Built-in memory: 29687 MB
Free memory: 16310 MB
Memory available to Photoshop: 27183 MB
Memory used by Photoshop: 60 %
ACP.local Status:
 - SDK Version: 1.34.1
 - Core Sync Status: Reachable and compatible
 - Core Sync Running: 4.3.71.1
 - Min Core Sync Required: 4.3.28.24
ACPL Cache Config: 
 - Time to Live: 5184000 seconds
 - Max Size: 20480 MB
 - Purge Percentage: 50%
 - Threshold Percentage: 85%
 - Purge Interval: 60 seconds
Live Edit Client SDK Version: 3.77.11
Native GPU: Disabled.
Manta Canvas: Enabled.
Alias Layers: Disabled.
Modifier Palette: Enabled.
Highbeam: Enabled.
Wintab Digitizer Services
    Spec Version 1.4
    Impl Version 1.39
    Num Devices 0
Image tile size: 1024K
Image cache levels: 4
Font Preview: Medium
TextComposer: Latin
"2.1"
glgpu[0].IsIntegratedGLGPU=0
glgpu[0].GLMemoryMB=1998
glgpu[0].GLName="GeForce GTX 660 Ti/PCIe/SSE2"
glgpu[0].GLVendor="NVIDIA"
glgpu[0].GLDriverVersion="27.21.14.6089"
glgpu[0].GLDriver="C:\WINDOWS\System32\DriverStore


Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 25, 2021 Jan 25, 2021

Copy link to clipboard

Copied

@JeffreyTranberry it would be good to remove the "Official solution" label from your reply. The bug has been reported more than 3 months ago, since then I received more PS updates, but the bug wasn't fixed yet, so there is no solution yet...

It's quite important to see the correct selection marquee, Adobe should treat this apparently minor issue with care.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

A lot of time passed since this bug was reported. This is getting really annoying. I had to stop using PS 22 and return to the previous version. Working a lot with precise selections, this is unacceptable.

Is PS tested before releasing? It's unbelievable, all testers are blind enough to miss this bug... 21 versions in the past were ok, how can be the 22nd version be released with such an amateur bug?

As a side note, developers are releasing more and more lower quality software/websites in every domain. It seems that attention to details is not important anymore.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

Found this thread while looking for a solution to this issue. This new behavior (either intended, or a bug) with selections is making it difficult for me to work smoothly, as I keep second-guessing what I have selected. Please revert this behavior; or -- if it's deliberate -- consider providing a preference for the old method? Thanks 🙂

edit: marquees work correctly if I disable Preferences > Performance > Graphics Processor Settings > Use Graphics Processor, so the likelihood that this is a deliberate change seems low. I've got a Radeon RX 5700 XT installed. Please fix this bug, it's terrible for workflow.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

In reference to Anthony Etienne's post above: Turning off Use Graphics Processor also "fixes" the problem when using an NVidia GeForce GTX 1050.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

*anthony etienne I just tried this and it worked. Thank you. It's really sad that none of the dozens of Adobe tech support people I've talked to in the past several months about this specific problem ever suggested this course of action. Instead, several said it's always been like that, and one even tried to install the previous version after I specifically told him not to. It's been a not-funny joke for a long time. So thank you Anthony.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

It's even worse than being a pixel off... it's the grid that is not correctly aligned with each pixel (sticking correctly to pixels has been a huge issue for quite some time, if you werent to fix stickiness by zooming at max level).

Currently the selection frame seem to be a tiny bit off to the left (like one pixel... but even if you are at the "pixel" level when zooming).

More clearly, at max zoom level, the grid is one screen pixel off to the left from the external left border of the photoshop pixel (not sure this is clear :-).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

... and like said above, this is a HUGE ISSUE !

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 05, 2021 Apr 05, 2021

Copy link to clipboard

Copied

This is a HUGE issue and I HOPE it is still being investigated.

It got slightly improved after one of the updates, where the off-by-1px offset is now 1px on screen instead of 1px on canvas, but IT IS STILL THERE. I know whenever I'll want to work on pixel-perfect graphics, I'll want to strangle someone.

PLEASE FIX THIS. It must be like one or two lines of code with an off-by-one offset variable or something, dang it...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Apr 06, 2021 Apr 06, 2021

Copy link to clipboard

Copied

HUGE and really ANNOYING. Hope they fix it soon.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 22, 2021 Apr 22, 2021

Copy link to clipboard

Copied

This is still an issue in 22.3.1.  The only way to fix it is to uncheck "Use Graphics Processor".  If it's on you'll still see the problem even if you go into Advanced and set Drawing Mode to Basic and uncheck everything else.

Photoshop 22.3.1 (latest as of this writing)

Windows 10 20H2 (all updates as of this writing)

nVidia GeForce GTX 1080

nVidia Game Ready Driver 466.11 (latest as of this writing)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 29, 2021 Apr 29, 2021

Copy link to clipboard

Copied

Thank you for posting this! It's been frustrating the bejeezus out of me for a while now. I keep having to guess which side of the selection it's actually selecting on. 😕  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

So v22.4 fixes this issue, kinda!

It's better now since the upper-left position of the marquee is now fixed, but the lower-right one is still off by 1px. It's not as big of a deal, coming from a programming standpoint, I can consider the end of the selection as "exclusive" instead of "inclusive", but still funny to realize it was still only half-fixed.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

Disabling hardware acceleration still is the only full fix it seems.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

Well it's different but not fixed.  Tried it again on 22.4:

  • Select a box and fill it.
  • Create a new layer.
  • On 100% zoom, try to select the outline of the box to the pixel.

While dragging the selection sometimes the upper left of the marquee will be one pixel too high and to the left, sometimes only the top will be off, sometimes it will be accurate.  The lower right will always be at least one pixel below and to the right of the cursor, sometimes two pixels to the right.

  • Release the mouse, having used the cursor to set the lower right corner and not the marquee, and then fill the selection with a different color.
  • Set the layer opacity to 50% and zoom in.

You'll see some of the sides were one pixel off.  It doesn't seem to be predictable which ones will be off.

This is with Use Graphics Processor on but in the advanced settings it's set to Basic and the other three checkboxes are off.  Turning Use Graphics Processor off no longer fixes it, now the selections will always be one pixel too wide and tall.  So I guess this means no accurate pixel-level selections on the 100% zoom level at all now.

Seems like you're having trouble with rounding errors on coordinates.  Even the button outlines on the Preferences panel are fuzzy now because the top and bottom aren't landing on pixel boundaries.

Untitled-c6a6d121-4461-4da5-bfbe-c22b963e0a54-515118528.png

Photoshop 22.4.0

Windows 10 Home 20H2 on 100% scaling (not high-DPI)

nVidia GeForce GTX 1080 with 466.27 Game Ready Driver

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

OMG, they made it worse?!?! I hadn't noticed, because I don't fiddle much with selections, so initially it felt better since top-left seemed fine, but... Damn...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 23, 2021 May 23, 2021

Copy link to clipboard

Copied

Not fixed in 22.4.1 but I think I found more information to make it more reproducible.

  • Open Photoshop with Use Graphics Processor on.
  • Create a new image using a preset small enough that it fits on the screen and defaults to the 100% zoom level.
  • Go through the test in my earlier post.

It seems to work.  The marquee while you're dragging will still be one pixel too tall and wide, appearing to the bottom right of the crosshair, but it will work correctly despite that if you go by the crosshair.

  • Open Photoshop with Use Graphics Processor on.
  • Create a new image using a preset big enough that it defaults to the 66.7% zoom level.  This happens when I make it the same size as my monitor resolution.
  • Zoom to 100%.
  • Go through the test in my earlier post.

Now it has a lot of one pixel off selections that aren't predictable, even though you're working at the 100% zoom level.  The fact that it started out at 66.7% seems to throw it off going forward.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

I just tested after getting the latest update. It looks like we have a fix!

Edit: Hold on -- we aren't quite there yet. See below.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

I think you're right! That's awesome. Just tested it myself with all the 3d acceleration turned on and everything looks good!

While I don't love how long this regression took to fix, I do sincerely appreciate the engineering team's efforts in getting it done, and I recognize that they may not have had a say in how it was prioritized. If you're on that team and you see this, thank you so very much.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

@Mark_Lincoln It's NOT fixed. Now, instead of always having a +1, +1 offset, it's almost random, depending on image size and zoom level. The upper-left corner is almost always correct now though, but the bottom-right one varies.

At least that's how it is for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

@ daPhie79  You are correct; this problem is not entirely fixed. I'm sorry for the premature call.

I haven't been able to get the upper-left corner to shift, and old glasses/older eyes caused me to miss the continued misbehavior on the lower-right. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines