P: Stamp Layers behaves different if the only paint layer is the background layer

1 Vote
LEGEND ,
Jun 21, 2011 Jun 21, 2011

Copy link to clipboard

Copied

There is a bug with the Stamp Layers command. If you use cmd-opt-E (on Mac) with multiple layers selected, they will correctly create a new, merged layer at the top using the selected layers. However, if the only paint layer is the background layer, then the background layer will be replaced with the merged layers, and re-adjusted by the adjustment layers above it. There is no new layer created at the top. I believe this is not the intended behavior.

Bug Won't fix
TOPICS
macOS , Windows

Views

38

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jun 21, 2011 Jun 21, 2011
Ken, Cool find. Note that the history step that is recorded is "Stamp Layers" not "Stamp Visible." Try using Cmd + Opt + Shift + E as your workaround. You'll not in this case, "Stamp Visible" is performed correctly. We'll take a look at this. One of the problems with changing something like this that it may break existing actions that expect the current behavior (Even if the present behavior is somewhat expected) - so that may affect our decision making on performing a change here.

Votes

Translate

Translate
6 Comments
Participant ,
Jun 21, 2011 Jun 21, 2011

Copy link to clipboard

Copied

May not be intended behavior, but an easy workaround is to option+double click on the Background to turn it into a layer. Now Stamp Merge should work as expected.

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 21, 2011 Jun 21, 2011

Copy link to clipboard

Copied

Thanks for the reply. Sure, a workaround is easy, but I was sort of curious if others have noticed this bug and if it is in fact a bug. How do I go about filing a bug report with Adobe? I'm not a developer...

Votes

Translate

Translate

Report

Report
Participant ,
Jun 21, 2011 Jun 21, 2011

Copy link to clipboard

Copied

From what I gather, all Adobe Photoshops bugs are now filed here at Photoshop.com. I guess just by posting like you already have in this Photoshop Family "Problems" category.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 21, 2011 Jun 21, 2011

Copy link to clipboard

Copied

Ken,

Cool find. Note that the history step that is recorded is "Stamp Layers" not "Stamp Visible."

Try using Cmd + Opt + Shift + E as your workaround. You'll not in this case, "Stamp Visible" is performed correctly.

We'll take a look at this. One of the problems with changing something like this that it may break existing actions that expect the current behavior (Even if the present behavior is somewhat expected) - so that may affect our decision making on performing a change here.

Senior Product Manager - Customer Advocacy - Digital Imaging

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jun 21, 2011 Jun 21, 2011

Copy link to clipboard

Copied

I've gone ahead and logged this in our bug database. Thanks for the report!

Votes

Translate

Translate

Report

Report
LEGEND ,
Jun 21, 2011 Jun 21, 2011

Copy link to clipboard

Copied

LATEST
Thanks for the replies! Glad to see that this is now reported as a bug.

Votes

Translate

Translate

Report

Report